Bug 120244 - FILEOPEN DOCX Answered Comment created with Word loses its hierarchy in Writer
Summary: FILEOPEN DOCX Answered Comment created with Word loses its hierarchy in Writer
Status: RESOLVED DUPLICATE of bug 119229
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: DOCX-Comments
  Show dependency treegraph
 
Reported: 2018-10-01 17:27 UTC by Gabor Kelemen (allotropia)
Modified: 2020-11-27 10:50 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file from Word with an answered comment (20.64 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-10-01 17:27 UTC, Gabor Kelemen (allotropia)
Details
Screenshot of the document in Word and Writer, also of the exported version (270.43 KB, image/png)
2018-10-01 17:30 UTC, Gabor Kelemen (allotropia)
Details
The original file saved by Writer. (14.39 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-10-01 17:31 UTC, Gabor Kelemen (allotropia)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen (allotropia) 2018-10-01 17:27:02 UTC
Answered Comment created in DOCX documents created with Microsoft Word 2013 or 2016 loses its hierarchy when the document is opened in LibreOffice Writer.
       
Steps to reproduce:

    1. Create a new document in Microsoft Word.
    2. Type text
    3. Add comment to the text
    4. Answer the comment
    5. Save the file as DOCX.
    6. Open the same file in LibreOffice Writer and compare the two versions.

Actual results:
The comments loses its hierarchy when opened in LibreOffice Writer 6.1.

Expected results:
The comment should be the same as opened in Microsoft Word 2013 or 2016.

Happens with:
Verzió: 6.1.0.3
Build az.: efb621ed25068d70781dc026f7e9c5187a4decd1
CPU szálak: 4; OS: Windows 6.3; Felületmegjelenítés: alapértelmezett; 
Területi beállítások: hu-HU (hu_HU); Calc: group threaded
Comment 1 Gabor Kelemen (allotropia) 2018-10-01 17:27:56 UTC
Created attachment 145300 [details]
Example file from Word with an answered comment
Comment 2 Gabor Kelemen (allotropia) 2018-10-01 17:30:30 UTC
Created attachment 145301 [details]
Screenshot of the document in Word and Writer, also of the exported version
Comment 3 Gabor Kelemen (allotropia) 2018-10-01 17:31:45 UTC
Created attachment 145302 [details]
The original file saved by Writer.
Comment 4 Dieter 2018-10-01 20:27:13 UTC
I confirm it with

Version: 6.2.0.0.alpha0+ (x64)
Build ID: 62cd86977ca41677c56fb2d1f97bb1c5cbdbd416
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-09-20_02:34:32
Locale: en-US (de_DE); Calc: CL

and

Version: 6.0.6.2 (x64)
Build-ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group
Comment 5 QA Administrators 2019-10-12 02:44:53 UTC Comment hidden (obsolete)
Comment 6 Timur 2019-11-15 16:27:34 UTC
repro 6.5+ and 3.5. 3.3 was worse. 
but isn't this the same as bug 119229, why just See Also?
Comment 7 NISZ LibreOffice Team 2020-11-27 10:50:47 UTC

*** This bug has been marked as a duplicate of bug 119229 ***