Bug 120253 - HiDPI icons blurry when using windows screen scalling at 150%
Summary: HiDPI icons blurry when using windows screen scalling at 150%
Status: RESOLVED DUPLICATE of bug 51733
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: HiDPI
  Show dependency treegraph
 
Reported: 2018-10-01 20:46 UTC by Gustavo HC
Modified: 2019-07-31 16:17 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
svg colibre icon theme zipped from source in master (2.26 MB, application/x-zip-compressed)
2018-10-02 10:38 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gustavo HC 2018-10-01 20:46:45 UTC
OS: Windows 10 Pro - Version 1803
Screen: standard 4k 28" monitor.
Video: Intel HD530 (i7 6700)
Video drivers: Intel (Dell original driver)

Description:

  Using windows settings to scale screen:

    -Scalling to 100% (unreadable small): LO icons works great.
    -Scalling to 125% (small): LO icons works great.
    -Scalling to 150% (recommended by windows): LO shows blurry icons.

This behavior repeats equally on 3 different machines (2 identical desktops and 1 laptop)

Thanks
-Gustavo HC
Comment 1 Regina Henschel 2018-10-02 00:56:00 UTC
Which icon theme do you use? There are known problems with HiDPI on Windows. I want to know whether the icons are png or svg format.
Do you use OpenGL? Please try with and without it. The setting for that is in menu Tools > Options > LibreOffice > View.
Comment 2 Gustavo HC 2018-10-02 01:17:22 UTC
> Which icon theme do you use? There are known problems with HiDPI on Windows.

Colibre, but it happens with other icon themes.

> I want to know whether the icons are png or svg format.

Sorry, I dont know, Its selected Colibre (default one)

> Do you use OpenGL? Please try with and without it. The setting for that is
> in menu Tools > Options > LibreOffice > View.

Same result, enabled, disabled or ignoring devices.
Comment 3 Gustavo HC 2018-10-02 02:47:55 UTC
I did a little video showing the issue.
My PC is in Portuguese language, but I think you will get the problem.

First, the Windows desktop is scalled at 150% (default for a 4k screen) and icons is broken.

Second I change the scalling to 125% (not ideal) and the icons appears perfectly.

"Filmed" the monitor due to logout/login stuff.

https://youtu.be/hfw56B-e95I

Hope it helps.
Comment 4 Regina Henschel 2018-10-02 10:32:54 UTC
Colibre in 6.1 has png-Format.

I have a normal monitor, but can see bad icons too, if I use a higher percent value for screen resolution.

There are similar reports bug 119444 as duplicate of bug 119200, and bug 114699 and its duplicates.  


I will attach an icon theme with svg. Please try whether the display will become better with that.
Comment 5 Regina Henschel 2018-10-02 10:38:54 UTC
Created attachment 145322 [details]
svg colibre icon theme zipped from source in master

Put the attached file into the folder <installation-path>\share\config. You should see other images_***.zip files there. Then start LibreOffice and select "colibre_svg" in the options. Please report back, whether it looks better.
Comment 6 Gustavo HC 2018-10-03 17:16:06 UTC
Yes. For sure, looks better.
Some icons appears to be still blurry (pixelated), but in general its really better.
Thanks.
Comment 7 Günther Breitfuß 2018-10-19 18:26:54 UTC
Ich habe es mit colibre_svg auch versucht. Die meisten Symbole werden nun richtig angezeigt. Es sind aber noch einige dabei, bei denen es nicht klappt.
Comment 8 Adolfo Jayme 2018-11-17 03:13:29 UTC

*** This bug has been marked as a duplicate of bug 51733 ***
Comment 9 JosifJosif 2019-07-31 10:28:24 UTC
Where exactly in the Options can we choose the "colibre_svg" package?
Comment 10 Regina Henschel 2019-07-31 12:13:00 UTC
(In reply to JosifJosif from comment #9)
> Where exactly in the Options can we choose the "colibre_svg" package?

If you have the icon theme "<InstPath>\share\config\images_colibre_svg.zip" then you should see the item "Colibre(SVG)" in the drop-down list "Icon style:" in Tools > Options > LibreOffice > View. If you need further help to get it, please use mailing list or forum.
Comment 11 JosifJosif 2019-07-31 16:17:53 UTC
(In reply to Regina Henschel from comment #10)
> (In reply to JosifJosif from comment #9)
> > Where exactly in the Options can we choose the "colibre_svg" package?
>
> If you have the icon theme "<InstPath>\share\config\images_colibre_svg.zip"
> then you should see the item "Colibre(SVG)" in the drop-down list "Icon
> style:" in Tools > Options > LibreOffice > View. If you need further help to
> get it, please use mailing list or forum.
Yes, it is there. But I would never would have founded on my own

And it worked to some extent- most of the icons look now normal


So thank you