Bug 120315 - FILEOPEN DOCX: Incorrect merged cells in writer table
Summary: FILEOPEN DOCX: Incorrect merged cells in writer table
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All All
: medium normal
Assignee: Bakos Attila (NISZ)
URL:
Whiteboard: target:6.4.0 target:6.3.4
Keywords:
: 90879 125574 125679 127333 (view as bug list)
Depends on:
Blocks: DOCX-Tables
  Show dependency treegraph
 
Reported: 2018-10-04 15:01 UTC by Daniel
Modified: 2019-11-16 11:40 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample Employee Personal Info Form (87.57 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-10-04 15:04 UTC, Daniel
Details
Document View in Browser (154.09 KB, image/png)
2018-10-04 15:09 UTC, Daniel
Details
View Document in Writer (131.56 KB, image/png)
2018-10-04 15:13 UTC, Daniel
Details
Comparison LibreOffice 6.3 Master and MSO 2010 (90.97 KB, image/png)
2018-12-07 23:42 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel 2018-10-04 15:01:04 UTC
Description:
Just compared this document form and found incorrect forms that I compared

Actual Results:
Just want to follow structure formats like Microsoft Office formats such as some browser document attachments. Especially in the 'latest photograph' section

Expected Results:
But in fact it's not so in Writer. I want to try to edit it in Writer so that it mimics the format of the document in the browser but I can't remove some arrowed cell (view image attachment). Especially in the 'latest photograph' section


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Daniel 2018-10-04 15:04:42 UTC
Created attachment 145383 [details]
Sample Employee Personal Info Form
Comment 2 Daniel 2018-10-04 15:09:57 UTC
Created attachment 145384 [details]
Document View in Browser
Comment 3 Daniel 2018-10-04 15:13:33 UTC
Created attachment 145385 [details]
View Document in Writer

If this happen, my job application can be cancelled just because it's little mess
Comment 4 Robert Großkopf 2018-10-04 18:01:07 UTC
Seems there is a problem with the rows of the table.

Have downloaded the example, could merge the field directly under "Latest Photograph", but couldn't merge the next field. So I saved the file as *.odt and reopened this file. Now I could merge it the way you wanted.
Comment 5 Dieter 2018-12-05 20:25:51 UTC
I also confirm it with

Version: 6.2.0.0.beta1 (x64)
Build ID: d1b41307be3f8c19fe6f1938cf056e7ff1eb1d18
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (de_DE); UI-Language: en-GB
Calc: threaded

I compared it with MS Word 2016: Merged cells in the cell "Latest photograph" doesn't persist in LO.
Comment 6 Xisco Faulí 2018-12-07 23:42:20 UTC
Created attachment 147365 [details]
Comparison LibreOffice 6.3 Master and MSO 2010
Comment 7 Xisco Faulí 2018-12-07 23:46:52 UTC
Also reproduced in

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.10; Render: default; 

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e
Comment 8 Commit Notification 2019-11-04 08:49:54 UTC
Bakos Attila committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/44e44239de35c1548809c96e13bfa9d64c7ca441

tdf#120315 DOCX import: fix cells merged vertically

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Bakos Attila (NISZ) 2019-11-04 09:15:05 UTC
*** Bug 125574 has been marked as a duplicate of this bug. ***
Comment 10 Bakos Attila (NISZ) 2019-11-04 09:45:32 UTC
*** Bug 127333 has been marked as a duplicate of this bug. ***
Comment 11 Xisco Faulí 2019-11-04 10:03:49 UTC
Verified in

Version: 6.4.0.0.alpha1+
Build ID: fa7f07d23de31e5f1660a643d83ca8a2e565f69c
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Bakos Attila, thanks for fixing this issue!
Comment 12 Xisco Faulí 2019-11-04 10:15:02 UTC
*** Bug 125679 has been marked as a duplicate of this bug. ***
Comment 13 Bakos Attila (NISZ) 2019-11-04 10:19:17 UTC
(In reply to Xisco Faulí from comment #11)
> Verified in
> 
> Version: 6.4.0.0.alpha1+
> Build ID: fa7f07d23de31e5f1660a643d83ca8a2e565f69c
> CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
> Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
> Calc: threaded
> 
> @Bakos Attila, thanks for fixing this issue!

You are welcome!
Comment 14 Commit Notification 2019-11-08 08:24:49 UTC
Bakos Attila committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/d99d2ad9f7a03663ed34008c8c3582f2999512d6

tdf#120315 DOCX import: fix cells merged vertically

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Gabor Kelemen 2019-11-16 11:40:38 UTC
*** Bug 90879 has been marked as a duplicate of this bug. ***