Download it now!
Bug 120332 - Cannot input Chinese characters
Summary: Cannot input Chinese characters
Status: RESOLVED DUPLICATE of bug 121161
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.2.1 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-05 03:50 UTC by illusory
Modified: 2018-12-03 16:03 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Works under VCLPLUGIN=gtk3 (139.69 KB, image/png)
2018-12-03 15:55 UTC, Franklin Weng
Details

Note You need to log in before you can comment on or make changes to this bug.
Description illusory 2018-10-05 03:50:26 UTC
Description:
After a recent update of my linux system (Linux Mint 19 Tara Xfce), I cannot input Chinese characters using fcitx input method. However everything else works fine. This may not be a bug of LibreOffice. 

Thank you!

Actual Results:
No Chinese character could be shown.

Expected Results:
The same as above.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Buovjaga 2018-10-27 13:58:05 UTC
Does the same happen with 6.2 alpha1? You can easily try with an appimage http://libreoffice.soluzioniopen.com/
Comment 2 illusory 2018-10-30 04:21:06 UTC
Have not tried the alpha version. But I switched from fcitx to ibus and it works...
Comment 3 Buovjaga 2018-10-30 11:12:26 UTC
(In reply to illusory from comment #2)
> Have not tried the alpha version. But I switched from fcitx to ibus and it
> works...

If you have the time, would be great to hear testing results with 6.2 and fcitx.
Comment 4 Franklin Weng 2018-12-03 15:55:17 UTC
Created attachment 147244 [details]
Works under VCLPLUGIN=gtk3


In VCLPLUGIN set to gtk3 the input method can be launched (see the red "酷" icon in the systemtray) and can type Chinese.
Comment 5 Franklin Weng 2018-12-03 15:56:55 UTC
Reproducible with VCLPLUGIN=kde5, which can not launch input method and can not type Chinese.  Specifying VCLPLUGIN=gtk3 it can work well.

版本:6.2.0.0.beta1+
組建 ID:6ab7bfbca4148416233dbf8b9bfc79f3a1dfa821
CPU 執行緒:2; OS:Linux 4.15; UI 算繪:預設; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-6-2, Time: 2018-11-27_19:54:44
語言地區:zh-TW (zh_TW.UTF-8); UI-Language: zh-TW
Calc: threaded



For gtk3:
版本:6.2.0.0.beta1+
組建 ID:6ab7bfbca4148416233dbf8b9bfc79f3a1dfa821
CPU 執行緒:2; OS:Linux 4.15; UI 算繪:預設; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-6-2, Time: 2018-11-27_19:54:44
語言地區:zh-TW (zh_TW.UTF-8); UI-Language: zh-TW
Calc: threaded
Comment 6 Xisco Faulí 2018-12-03 16:03:01 UTC
I suppose it's the same as bug 121161

*** This bug has been marked as a duplicate of bug 121161 ***