Bug 120352 - Calc stopped prompting to link to external data after loading specific web page (see end of comment 2)
Summary: Calc stopped prompting to link to external data after loading specific web pa...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.6.2 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Calc-External-Datalink
  Show dependency treegraph
 
Reported: 2018-10-05 19:53 UTC by stefano.curiotto
Modified: 2020-12-27 12:10 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description stefano.curiotto 2018-10-05 19:53:43 UTC
Description:
This version of calc 6.0.6.2 does not allow anymore to import external data from web pages. I am using an old calc file, where importing data from the web was automatic.
 

Steps to Reproduce:
1.import external data
2.paste the web adress in the field
3.press enter
4.a dialog window opens, you can select automatic and press enter
5.the list of available tables does not appear as it should to select the table I want 

Actual Results:
the window remains empty and does not display the list of available tables

Expected Results:
a list of available tables appears and they can be selected


Reproducible: Always


User Profile Reset: No



Additional Info:
Versione: 6.0.6.2
Build ID: 1:6.0.6-0ubuntu0.18.04.1
Thread CPU: 4; SO: Linux 4.15; Resa interfaccia: predefinito; VCL: gtk3; 
Versione locale: it-IT (it_IT.UTF-8); Calc: group
Comment 1 Oliver Brinzing 2018-10-06 14:55:58 UTC
do you mean menu "Sheet/Link to External Data..." ?
could you please add an example file or at least the web url?
Comment 2 stefano.curiotto 2018-10-06 16:36:36 UTC
yes, sheet/link to external data
However I have installed a new version of libreoffice and the problem does not appear anymore.
This was an example of link that did not work and that with the new version of libreoffice works:
https://www.boursorama.com/cours/1rPRAL/

The version I have installed, where the bug is fixed:
Versione: 6.1.2.1
Build ID: 1:6.1.2~rc1-0ubuntu0.18.04.1
Thread CPU: 4; SO: Linux 4.15; Resa interfaccia: predefinito; VCL: gtk3; 
Versione locale: en-US (it_IT.UTF-8); Calc: group threaded

However this link does not work also in the new version of libreoffice:
https://finance.yahoo.com/quote/URW.AS/history?p=URW.AS
Comment 3 Oliver Brinzing 2018-10-07 08:03:27 UTC
i can confirm this:

> with the new version of libreoffice works:
> https://www.boursorama.com/cours/1rPRAL/

worked in LO 5.4.7.2 and LO 6.1.2 but not in LO 6.0.6

> However this link does not work also in the new version of libreoffice:
> https://finance.yahoo.com/quote/URW.AS/history?p=URW.AS

worked in LO 5.4.7.2 but not in LO 6.0.6/6.1.2
Comment 4 Oliver Brinzing 2018-10-07 08:22:54 UTC
btw: 
entering a web url is unfortune, cause one has to press 
(enter) to start the search process. 
i am missing a [Submit] button, or at least a hint.
Comment 5 Xisco Faulí 2018-10-10 10:05:12 UTC
Using https://finance.yahoo.com/quote/URW.AS/history?p=URW.AS

Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=5720c85ccea9f1481bd604b806c5be728e59a13f

author	Justin Luth <justin.luth@collabora.com>	2018-06-05 19:30:58 +0300
committer	Eike Rathke <erack@redhat.com>	2018-06-11 23:20:50 +0200
commit 5720c85ccea9f1481bd604b806c5be728e59a13f (patch)
tree cf9453f84b1fd89a4094c9a4a3a0a1ff25b647cb
parent b7a30d4bfbcf6b4c4fd773e8e1a436928e1224e3 (diff)
tdf#114487 sc htmlimp: non-global sheet range names

Bisected with: bibisect-linux64-6.2

Adding Cc: to Justin Luth
Comment 6 Justin L 2018-10-10 10:22:11 UTC
The fix is in 6.0.7 which will be available fairly soon - by the end of October according to the release plan.

*** This bug has been marked as a duplicate of bug 119141 ***
Comment 7 Xisco Faulí 2018-10-10 10:24:47 UTC
This is still reproducible in

Version: 6.2.0.0.alpha0+
Build ID: 87e3539d69626780c6d7531b725dd0d64c69e6d8
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded
Comment 8 Justin L 2018-10-10 10:36:54 UTC
(In reply to Xisco Faulí from comment #7)
> This is still reproducible in 6.2
Then it must have broken again later on, if it is currently broken in master.  The commit noted has been reverted, so it is impossible for that to be the cause.
Comment 9 Xisco Faulí 2018-10-10 11:06:05 UTC
@Justin, you're right. sorry for that.

I've bisected it again, and after the commit I mentioned in comment 5, the Import Option dialog is displayed until

author	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-06-07 09:44:02 +0200
committer	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-06-13 13:40:04 +0200
commit 3087011e2eb810866276e270a6fc61a7e0998fec (patch)
tree 961c9b25d00f0258dd0c3eb4850e50b78367f7c8
parent 4a0ca73c31990568bf20a1c3f0906c3a5770a38e (diff)
Replace SVGFilter using SVGIO

Adding Cc: to Armin Le Grand
Comment 10 Justin L 2018-10-10 12:23:36 UTC
(In reply to Xisco Faulí from comment #9)
> Import Option dialog is displayed until
> commit 3087011e2eb810866276e270a6fc61a7e0998fec
I am confirming these bibisect results, since it seemingly has no tie to Calc/HTML, but yet I still got the same results on Ubuntu 18.04 / bibisect-linux-64-6.2 when testing the link https://finance.yahoo.com/quote/URW.AS/history?p=URW.AS
Comment 11 QA Administrators 2020-12-27 03:36:42 UTC
Dear stefano.curiotto,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from https://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug