Download it now!
Bug 120364 - Bullet points appear inside a table when browsing through the cells using arrow key
Summary: Bullet points appear inside a table when browsing through the cells using arr...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.1.2.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
: 128783 (view as bug list)
Depends on:
Blocks: Regressions-AW080
  Show dependency treegraph
 
Reported: 2018-10-06 15:08 UTC by Telesto
Modified: 2020-01-10 10:50 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (11.15 KB, application/vnd.oasis.opendocument.graphics)
2018-10-06 15:09 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-10-06 15:08:53 UTC
Description:
Bullet points appear inside a table when browsing through the cells using arrow key

Steps to Reproduce:
1. Open the attached file
2. Enter cell A1
3. Press Arrow down key (B5 & C5 will get a bullet point)

Actual Results:
Bullet point in B5 an C5

Expected Results:
Shouldn't 


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
Version: 6.2.0.0.alpha0+
Build ID: 52cb73911e661fb636085337374e09845f07783b
CPU threads: 4; OS: Windows 6.3; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-10-02_01:05:50
Locale: nl-NL (nl_NL); Calc: CL

but not in
Versie: 4.4.7.2 
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: nl_NL
Comment 1 Telesto 2018-10-06 15:09:05 UTC
Created attachment 145433 [details]
Example file
Comment 2 raal 2018-10-08 14:07:32 UTC
I can confirm with Version: 6.2.0.0.alpha0+
Build ID: 75a48e37b260c145297261d0e0ab5720894404f1
CPU threads: 4; OS: Windows 6.1; UI render: default; 
but not in Version: 4.4.0.0.alpha0+
Build ID: dea4a3b9d7182700abeb4dc756a24a9e8dea8474
Comment 3 Xisco Faulí 2018-10-10 09:25:29 UTC
Reproduced in

Versión: 6.1.2.1
Id. de compilación: 65905a128db06ba48db947242809d14d3f9a93fe
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: group threaded
Comment 4 Xisco Faulí 2018-10-10 09:34:00 UTC
I guess the issue was introduced by 

https://cgit.freedesktop.org/libreoffice/core/commit/?id=6c14c27c75a03e2363f2b363ddf0a6f2f46cfa91

author	Armin Le Grand <Armin.Le.Grand@cib.de (CIB)>	2018-03-01 15:54:32 +0100
committer	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-04-06 22:29:02 +0200
commit	6c14c27c75a03e2363f2b363ddf0a6f2f46cfa91 (patch)
tree	e66f50adb222dbc1490b4df2d3c63541dad999ac
parent	e1b247a843c5eb850fe0079819239d9883412d38 (diff)
SOSAW080: Added first bunch of basic changes to helpers

I can't reproduce it before this commit. After this, it crashes selecting the table and the crash gets fixed in

https://cgit.freedesktop.org/libreoffice/core/commit/?id=c28ec6d9fbb21b363102faac0171de2754ea5d75

author	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-07-18 13:53:38 +0200
committer	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-07-18 15:40:04 +0200
commit	c28ec6d9fbb21b363102faac0171de2754ea5d75 (patch)
tree	3b7a8816aa362c4cae03117f8bf86be7d2c1da3f
parent	f35e3b36b0df830d0259d9d754c3da1946da3e6b (diff)
tdf#118354 Do not dereference non-exsisting Object

Adding Cc: to Armin Le Grand
Comment 5 QA Administrators 2019-10-11 02:37:25 UTC Comment hidden (obsolete)
Comment 6 Luke 2020-01-07 16:58:36 UTC
Looks like this has been fixed

Reproducible in Version: 6.3.0.0.alpha0+ (x64)
Build ID: c61623028b79f918d0ed2bc2ca47db17e68a26cb

But NOT repo in any version I tested after: Version: 6.4.0.0.alpha0+ (x64)
Build ID: 6b888ac476fe6ac2ee96c7086cb8c24249f08473
Comment 7 Xisco Faulí 2020-01-09 11:00:01 UTC
Also fixed in

Versió: 6.3.3.2
ID de la construcció: 1:6.3.3-0ubuntu0.18.04.1~lo1
Fils de CPU: 4; SO: Linux 4.15; Renderitzador de la IU: per defecte; VCL: x11; 
Configuració local: ca-ES (ca_ES.UTF-8); Llengua de la IU: ca-ES
Calc: threaded

thus, no need for backport
Comment 8 Luke 2020-01-09 14:42:34 UTC
Telesto,
I noticed that comparing the behavior of cells B5, C5 in 5.4, 6.1, and 6.5, the behavior is now different in all 3. Should B5 and C5 be set to bullet formatted text? 
5.4: Cells not bullet format when text entered
6.1: Down Arrow or text triggers bullet
6.5: Only entered text triggers a bullet

I bisected this fix to:
commit f4ea84ff370d33a02a8fb1d6405b9d964491258e
Author: Noel Grandin <noel.grandin@collabora.co.uk>
    tdf#119650 slow saving spreadsheet with comments, part 1

https://cgit.freedesktop.org/libreoffice/core/commit/?id=f4ea84ff370d


Noel, 
Did you intend your file save optimization to change run-time behavior?
Comment 9 Xisco Faulí 2020-01-10 10:50:15 UTC
*** Bug 128783 has been marked as a duplicate of this bug. ***