Bug Hunting Session
Bug 120470 - criteria prompt not working in base
Summary: criteria prompt not working in base
Status: RESOLVED DUPLICATE of bug 117053
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.1.0.1 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-09 20:42 UTC by vlangford
Modified: 2018-10-10 07:13 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vlangford 2018-10-09 20:42:02 UTC
Description:
After upgrading to LO 6.1.0.1 my odb files that use the : prompt in form control and also in query filters stopped working, giving a message "about index >1 which is 0" (I am sorry I do not have the exact message.  On other boxes using older LO installs everything continued fine.  I uninstalled then reinstalled 6.0.6 now everything is fine again.

LinuxMint 17.3 /Ubuntu 14.04

Steps to Reproduce:
1.using LO 6.1.0.1
2.use the facility to set user parameters in forms or queries
3.

Actual Results:
got error message which stopped the filtering of data records

Expected Results:
the form would normally prompt for user parameter then continue with records filtering


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Alex Thurgood 2018-10-10 07:03:44 UTC
@vlangford : are you using the distrib provided packages, or the TDF packages available from the LibreOffice download site ?

There has been some recent work to correct a problem discovered with parameterized queries, so perhaps upgrading your version of LO to the latest released by TDF will solve your problem, or alternatively, download and install a daily build in parallel.
Comment 2 Alex Thurgood 2018-10-10 07:13:50 UTC
@vlangford : please read comments 11, 12 and 15 of bug 117053 for how to correct this for ODB files created with older versions of LibreOffice.

*** This bug has been marked as a duplicate of bug 117053 ***