Bug 120541 - Images inserted in Writer documents don't show up in a fresh master build on macOS
Summary: Images inserted in Writer documents don't show up in a fresh master build on ...
Status: RESOLVED DUPLICATE of bug 120252
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: x86-64 (AMD64) Mac OS X (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: regressions-buffering-GraphicData
  Show dependency treegraph
 
Reported: 2018-10-12 09:30 UTC by Tor Lillqvist
Modified: 2019-01-15 10:07 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (998.48 KB, image/png)
2018-10-12 09:30 UTC, Tor Lillqvist
Details
Second screenshot (3.86 MB, image/png)
2018-10-12 09:33 UTC, Tor Lillqvist
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tor Lillqvist 2018-10-12 09:30:21 UTC
Created attachment 145635 [details]
Screenshot

Run a fresh master build of LO on macOS. Create a new Writer document. Insert>Image..., choose some JPEG. Only the outline of the image shows up, not its contents. (See screenshot.) Reloading it doesn't help.

The image gets saved properly in .odt at least, though, and when opening the document in an older LO it shows up fine.
Comment 1 Tor Lillqvist 2018-10-12 09:33:45 UTC
Created attachment 145636 [details]
Second screenshot
Comment 2 Tor Lillqvist 2018-10-12 09:34:20 UTC
If I insert an image in a Writer document in an older version of LibreOffice (6.0.4), save the document, and open that in a fresh master build, the image does show up, but scaled wrongly. It doesn't fill its boundaries as expected. See second screenshot.
Comment 3 Telesto 2018-10-12 16:39:22 UTC
Partial conformation (older build)
* The insert image (jpg) shows up in a build of 1 october, but scaled wrongly at insertion.
* The image in the about window isn't rendered probably either (for me)
Comment 4 Xavier Van Wijmeersch 2018-10-13 16:09:52 UTC
I can not reproduce the problem

Version: 6.2.0.0.alpha0+
Build ID: fd41fb8392a4e9a27d9fd09071a5f1e2be4b5a0e
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); Calc: threaded
Comment 5 Tor Lillqvist 2018-10-13 22:16:10 UTC
Well, that is why I point out that this is on macOS.
Comment 6 Alex Thurgood 2018-10-15 07:01:58 UTC
Confirming.

FWIW, I see this also in the StartCenter, where the preview thumbnails are either seemingly not displayed at all, or else only display partially within the image frame
Comment 7 Alex Thurgood 2018-10-15 07:02:51 UTC
(In reply to Telesto from comment #3)

> * The image in the about window isn't rendered probably either (for me)

I see this too.
Comment 8 Alex Thurgood 2018-10-15 07:11:00 UTC
Tested against :

Version: 6.2.0.0.alpha0+
Build ID: a6032ff5418ad66cc8fec10c636e32b124ee7864
CPU threads: 4; OS: Mac OS X 10.14; UI render: default; VCL: osx; 
Locale: fr-FR (fr_FR.UTF-8); Calc: threaded
Comment 9 Alex Thurgood 2018-10-23 06:45:26 UTC
*** Bug 120815 has been marked as a duplicate of this bug. ***
Comment 10 Tor Lillqvist 2018-10-23 09:41:32 UTC Comment hidden (off-topic)
Comment 11 Telesto 2018-10-23 09:49:17 UTC
@Xisco
Adding you. To keep track on relevant bug which should be fixed before LibO6.2 release
I get a AW080 feeling around here..
Comment 12 Xisco Faulí 2018-10-25 23:32:41 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=7034311dce663c895577267110baadbec312d491

author	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-09-06 18:15:02 +0200
committer	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-09-13 08:49:35 +0200
commit	7034311dce663c895577267110baadbec312d491 (patch)
tree	8c1d712cbfb1b15dc492e6e724b6b22892914249
parent	d92b0efe58b77247e1e5292c1a989baa934df797 (diff)
Support buffering SystemDependent GraphicData (II)

Bisected with: bibisect-mac64-6.2

Adding Cc: to Armin Le Grand
Comment 13 Xisco Faulí 2018-11-08 15:58:08 UTC
Fixed by https://gerrit.libreoffice.org/#/c/63104/
Closing as duplicated of 120252

*** This bug has been marked as a duplicate of bug 120252 ***
Comment 14 phillyelliott 2018-11-08 16:07:26 UTC
Same issue here. Images in Writer just a white box, but appear upon typing, and then disappear again. Occurs in .odt and .docx. Export to pdf renders images fine. They also appear in StartCentre thumbnail.

Altering numerous settings does nothing (OpenGL on/off, memory cache changes, etc)

Version: 6.1.1.2
Build ID: 5d19a1bfa650b796764388cd8b33a5af1f5baa1b
CPU threads: 4; OS: Mac OS X 10.13.6; UI render: GL; 
Locale: en-GB (en_GB.UTF-8); Calc: group threaded
Comment 15 Xisco Faulí 2018-11-08 16:12:21 UTC
(In reply to phillyelliott from comment #14)
> Same issue here. Images in Writer just a white box, but appear upon typing,
> and then disappear again. Occurs in .odt and .docx. Export to pdf renders
> images fine. They also appear in StartCentre thumbnail.
> 
> Altering numerous settings does nothing (OpenGL on/off, memory cache
> changes, etc)
> 
> Version: 6.1.1.2
> Build ID: 5d19a1bfa650b796764388cd8b33a5af1f5baa1b
> CPU threads: 4; OS: Mac OS X 10.13.6; UI render: GL; 
> Locale: en-GB (en_GB.UTF-8); Calc: group threaded

This issue is only happening in master.
To be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?
Comment 16 Buovjaga 2019-01-15 10:07:49 UTC
(In reply to Xisco Faulí from comment #15)
> (In reply to phillyelliott from comment #14)
> > Same issue here. Images in Writer just a white box, but appear upon typing,
> > and then disappear again. Occurs in .odt and .docx. Export to pdf renders
> > images fine. They also appear in StartCentre thumbnail.
> > 
> > Altering numerous settings does nothing (OpenGL on/off, memory cache
> > changes, etc)
> > 
> > Version: 6.1.1.2
> > Build ID: 5d19a1bfa650b796764388cd8b33a5af1f5baa1b
> > CPU threads: 4; OS: Mac OS X 10.13.6; UI render: GL; 
> > Locale: en-GB (en_GB.UTF-8); Calc: group threaded
> 
> This issue is only happening in master.
> To be certain the reported issue is not
> related to corruption in the user profile, could you please reset your
> Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
> re-test?

phillyelliott was not in CC, so adding.