Bug 120550 - Draw - Changes to table size "Optimal" features need documentation
Summary: Draw - Changes to table size "Optimal" features need documentation
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.4.0 target:7.5.0
Keywords:
Depends on:
Blocks: Help-Changes-Features
  Show dependency treegraph
 
Reported: 2018-10-12 12:25 UTC by Heiko Tietze
Modified: 2022-07-28 21:12 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Draw document with attempt to use Minimal Row Height (17.18 KB, application/vnd.oasis.opendocument.graphics)
2022-05-27 00:10 UTC, sdc.blanco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Heiko Tietze 2018-10-12 12:25:34 UTC
The proposal by Justin is here https://bugs.documentfoundation.org/show_bug.cgi?id=117721#c22
Comment 1 Justin L 2018-10-12 16:16:26 UTC
Comment 0 is specifically related to Draw.  Note that Writer also has these changes (with very slight variations) as documented in https://bugs.documentfoundation.org/show_bug.cgi?id=64242#c23 and c24.
Comment 2 Xisco Faulí 2018-11-12 12:16:48 UTC
Moving to NEW.
@Olivier, change it back to UNCONFIRMED if you think otherwise
Comment 3 sdc.blanco 2022-05-26 10:46:13 UTC Comment hidden (obsolete)
Comment 4 Justin L 2022-05-26 11:57:38 UTC
(In reply to sdc.blanco from comment #3)
> Afaict -- the only UI for table optimization in Draw is the Table toolbar
No, it is also in the menu at Format - Table - ...

> 2. If yes, please identify specifically what changes, if any, are needed to
> that page.
There is nothing that tells the user what distinguishes distribute, optimize, or minimal. Proposed wording indicated in comment 0's link.
Comment 5 sdc.blanco 2022-05-26 12:56:01 UTC Comment hidden (obsolete)
Comment 6 sdc.blanco 2022-05-26 12:58:32 UTC Comment hidden (obsolete)
Comment 7 sdc.blanco 2022-05-26 13:28:32 UTC Comment hidden (obsolete)
Comment 8 sdc.blanco 2022-05-26 14:01:14 UTC Comment hidden (obsolete)
Comment 9 sdc.blanco 2022-05-26 14:42:43 UTC Comment hidden (obsolete)
Comment 10 Justin L 2022-05-26 17:51:50 UTC
(In reply to sdc.blanco from comment #5)
> Do any of the relevant pages need updating?
All of the relevant pages will need updating since all functions have been tweaked.

(In reply to sdc.blanco from comment #6)
> Have now found "Optimize Size"
> iiuc -- this page needs the following controls added for Draw:
> 
> "Minimal Row Height"
> "Minimal Column Width"
> "Optimal Row Height"
> "Optimal Column Width"
Yes, and the descriptions for "Distribute * Equally" might need to be corrected as well.

> I assume that the "Optimize Size" toolbar in Draw and Writer have (a) the
> same controls, and (b) the same behavior.
The same controls, yes. The behaviour is approximately the same, but not completely as indicated in comment 1 (since the code is completely different).

(In reply to sdc.blanco from comment #7)
> Just to be sure... no such menu for Calc?
Correct.

(In reply to sdc.blanco from comment #8)
> Writer:  "Minimize Row Height"  "Minimize Column Width"
> Draw/Impress:  "Minimal Row Height" "Minimal Column Width"
> 
> (but it looks like they use the same .uno:SetMinimalRowHeight and
> uno:SetMinimalColumnWidth )
Yes, these ought to be the same wording. Probably "minimal" to match "optimal"

(In reply to sdc.blanco from comment #9)
> but it is possible that the text that appears in
> https://help.libreoffice.org/master/en-US/text/swriter/main0110.html (with
> possible additions) would be correct/adequate in relation to Draw/Impress (?)
These descriptions are not very accurate or complete.
Comment 11 sdc.blanco 2022-05-26 23:38:27 UTC
(In reply to Justin L from comment #10)
Thanks for clear answers, which help to define the scope of what is needed.
Now to more forward with the actual descriptions.

Comparing c22 (from Comment 0 here) (for Draw) and c23 and c23 (from Comment 1) here, plus bug 121367, comment 1 (for Writer):  I see only one clear difference:  Minimize Column Width.  

(in fact, your descriptions are identical for Draw and Writer, but then you add a note explaining "selected cells" (for Writer) vs. "entire column" for Draw -- will try to convey this difference.)

Does that sound right? -- that the differences between Writer and Draw are in relation to "Minimal Column Width" (and possibly "Optimal Column Width", addressed in the next topic here.)

If there are other differences, then please identify them, because I cannot see more in what has been provided.

Bug 121367, comment 1 (for Writer) indicates:

  Minimize column and optimize column DO grow the table size if the space is available.

Questions (to be sure I have it right):

1.  Minimal column: DOES grow table for Writer; DOES NOT grow for Draw

2.  Optimal column DOES grow table for Writer (if space is available); DOES NOT grow for Draw?  (your descriptions for "Optimal" did not comment on growing, hence the uncertainty)

3.  What does "if space is available" mean in this context?  (left/right page margins? plus top/bottom margins, unless table can flow over a page?  Will the top border of the table ever move up in the page, or is the space always added at the end of the table?
Comment 12 sdc.blanco 2022-05-26 23:39:49 UTC
> >.uno:SetMinimalRowHeight and uno:SetMinimalColumnWidth 
> Yes, these ought to be the same wording. Probably "minimal" to match "optimal"
https://gerrit.libreoffice.org/c/core/+/135005
Comment 13 sdc.blanco 2022-05-27 00:10:19 UTC
Created attachment 180419 [details]
Draw document with attempt to use Minimal Row Height

In Writer 

"Minimize row height: Adjusts the height of the selected rows to fit the content, causing the table to shrink. "

Counter-demonstration to "causing the table to shrink" (or demonstration of my misunderstanding).

2 x 2 table 

48 pt size text  | 12 pt size text
12 pt size text  | 12 pt size text

1. Cursor in first row
2. Right-click Size > Row Height
3. unclick "Fit to Size", set Height to 1cm
4. Select the two rows, right-click Size > Minimal Row Height

Actual:  table grows
Expected: (according to help): table shrinks.

I also tried in Draw -- but could not see that I can set Row Height (steps 2 and 3), so maybe this will not be an issue in Draw.  

But ... I did try to use the "Minimal" commands, and got an unexpected result -- have attached the .odg, with a description of what I did, what I expected, and what I got.  (not claiming any misbehavior in Draw -- just seeking to gain a proper understanding).
Comment 14 Justin L 2022-05-27 06:28:49 UTC
(In reply to sdc.blanco from comment #11)
> Does that sound right?
It has been a while since I did this. Probably the only way to be accurate is to test all kinds of situations and see what actually happens. I assume that testing and confirming is already a large part of the documentation role.

> 1.  Minimal column: DOES grow table for Writer; DOES NOT grow for Draw
Correct. Confirmed by testing in 7.4.

> 2.  Optimal column DOES grow table for Writer; DOES > NOT grow for Draw? 
Correct. Confirmed by testing.

> 3.  What does "if space is available" mean in this context?
Up to 100% relative size of a table - fitting in the text margins. (Same idea in a frame.)

> Will the top border of the table ever move up in the page, or is the space
> always added at the end of the table?
It always grows downward. I don't think that needs to be mentioned because that is the natural experience with tables as you add content etc.


(In reply to sdc.blanco from comment #13)
> Actual:  table grows
> Expected: (according to help): table shrinks.
This is a bit of an extreme example. Minimal is a "fit to contents and nothing more". In your case you minimized the table below "fit to content" status, and thus it grew. Basically, minimize just gets rid of excess space.

> But ... I did try to use the "Minimal" commands, and got an unexpected
> result -- have attached the .odg, with a description of what I did,
It works until 7.0.4. This is bug 139511.
Comment 15 Commit Notification 2022-06-01 00:51:30 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/f2d2334b032780d97f7a95aacb8283008e91c529

tdf#121367 (related: tdf#120550) consistent labeling between modules

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 sdc.blanco 2022-06-27 20:06:14 UTC
This patch addresses all the relevant commands for Draw / Impress
https://gerrit.libreoffice.org/c/help/+/135002
Comment 17 Commit Notification 2022-06-29 12:47:07 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/b6a8105c3ceb14f1216a12dbbe4b191acc0b99f3

tdf#120550,tdf#121367 update row and column resizing in tables
Comment 18 Commit Notification 2022-07-01 14:13:07 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/3569af3cc1cffcf14ff13273f422b99d652b9c39

tdf#120550,tdf#121367 followup to add or correct links
Comment 19 sdc.blanco 2022-07-07 10:23:52 UTC
Unfortunately the patches that were made for master was not cherry-picked for LO 7.4, even though they were ready before the string freeze.  So, at present, the updated help is now committed to master, but as I understand, there may be changes coming to how "optimize column" will work, which will require updates to the help in master, so I will leave this ticket open, because the "status quo" has not changed in relation to the help available to users. Unassigning myself.