Download it now!
Bug 120608 - Some keyboard-shortcuts do not work with German keyboards
Summary: Some keyboard-shortcuts do not work with German keyboards
Status: RESOLVED DUPLICATE of bug 82117
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.2.1 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-15 11:32 UTC by Helmut Leininger
Modified: 2018-10-15 19:35 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Helmut Leininger 2018-10-15 11:32:10 UTC
Description:
Some shortcuts do not work with GErman keyboards. One example is <ctrl>+<;> to insert the date into a cell. This works well qith US keyboard layouts, but does nothing with German keyboars, although it is described in the help and keyboard settings.

Probably, there is a similar behaviour with other shortcuts, too. They should be examined for compatibility and be "repaired" accordingly (in the settings, help, documentation, dropdown menus ...)

Steps to Reproduce:
1. Set keyboard to German layout
2. create new spredsheet
3. press <ctrl>+<;>

Actual Results:
nothing

Expected Results:
should insert date


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: de
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: yes
Comment 1 Thomas Lendo 2018-10-15 19:35:22 UTC
Thanks for reporting this issue.

Problems with non-US keyboard shortcut keys were reported in the past, see Bug 82117 - Improve shortcut key list for German keyboard layout.

See also Bug 115052 - Allow other keys than from US keyboard as shortcut keys.

*** This bug has been marked as a duplicate of bug 82117 ***