Bug 120617 - Add fill pattern for cell background in Calc (workaround: use extension)
Summary: Add fill pattern for cell background in Calc (workaround: use extension)
Status: RESOLVED DUPLICATE of bug 31205
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.2.1 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-15 14:19 UTC by Pierre
Modified: 2019-01-24 18:24 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre 2018-10-15 14:19:46 UTC
Description:
In Calc, the background can only be set to some fill color.
There seems to be no way to specify a fill pattern e.g. hatching (like in Excel, sorry to compare)

Steps to Reproduce:
1.Open any spreadsheet with Calc (ods or xls)
2.Select any cell
3.Right-click to format
4.Select Background tab


Actual Results:
No way to choose a fill pattern

Expected Results:
A tab (or a part of the background tab) with a choice of fill patterns (lines, diamonds, dots, ...) with their own background and foreground colors.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Xisco Faulí 2018-10-15 15:54:19 UTC
The new cell background was changed in https://cgit.freedesktop.org/libreoffice/core/commit/?id=76d9d6c9bf0167d4203d7e2f6867254687915caa

@Jim, Any opinion here?
Comment 2 m.a.riosv 2018-10-15 18:09:48 UTC
There is an extension for that:
https://extensions.libreoffice.org/extensions/hatch-patterns-for-cells
Comment 3 Pierre 2018-10-16 14:29:33 UTC
I have downloaded "CalcHatchCells-L-1.2.1.oxt" and tried to install the hatch-patter-for-cells extension on my dualboot 64 bits laptop.

When logged under Linux Mint either as user or administrator, the extension does not install with the extension manager. The message box says: "Failed to register package for vnd.sun.star.expand:$UNO_USER_PACKAGES_CACHE/uno_packages/lu1737bspybr.tmp_/CalcHatchCells-L-1.2.1.oxt/python1/"

When logged under Windows 7 as user, the extension does install with the extension manager, but is not functional. There is no obvious way for the user to add a fill pattern to a cell. If the workbook has been created with Excel (sorry!) and the cell does have a fill pattern, then the cell appears with a background color and no pattern.
Comment 4 Buovjaga 2018-11-25 17:43:24 UTC
(In reply to Pierre from comment #3)
> When logged under Windows 7 as user, the extension does install with the
> extension manager, but is not functional. There is no obvious way for the
> user to add a fill pattern to a cell. If the workbook has been created with
> Excel (sorry!) and the cell does have a fill pattern, then the cell appears
> with a background color and no pattern.

Works for me on Linux. It by default shows a floating toolbar. You can (de)activate it from View - Toolbars - Hatch cells.

"Insert Hatch in Selected Cells" in the dialog does the trick.

Arch Linux 64-bit
Version: 6.3.0.0.alpha0+
Build ID: 51e6a95757906dff8b2819a4141bf3dc7938e95f
CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: gtk3_kde5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 24 November 2018
Comment 5 Timur 2018-11-28 16:05:04 UTC
Unless we have a reason not to do it, let's accept this as an enhancement. 
With no promises or expectations that it will be solved, except by a volunteer.
Comment 6 Buovjaga 2019-01-24 18:24:22 UTC

*** This bug has been marked as a duplicate of bug 31205 ***