Bug 120743 - Firefox themes: 'Select Theme' button can be misinterpreted to apply a selected preinstalled theme
Summary: Firefox themes: 'Select Theme' button can be misinterpreted to apply a select...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Muhammet Kara
URL:
Whiteboard: target:6.3.0
Keywords: needsUXEval
: 124308 (view as bug list)
Depends on:
Blocks: Firefox-Themes
  Show dependency treegraph
 
Reported: 2018-10-20 21:13 UTC by Thomas Lendo
Modified: 2019-05-02 10:58 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Lendo 2018-10-20 21:13:45 UTC
I don't know if this is really an issue, but during my tests of the new cool personalization enhancements by Muhammet Kara it occurred to me that users can misinterpret the 'Select Theme' button below the preinstalled themes to apply a selected preinstalled theme and not to choose another theme from the web.

I didn't find any similar situation in another options dialog to have a better idea how to handle that. Maybe it's enough to be more specific in the button description. 'Select another theme' or something else.

I'll add needsUXEval to get more input.

For an example see attachment 145865 [details].


Version: 6.2.0.0.alpha0+
Build ID: 6baca63b44bf7f75a522b1adc4b4bbce502aec3b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: de-DE (de_DE.UTF-8); Calc: threaded
from today
Comment 1 Thomas Lendo 2018-10-20 23:03:26 UTC
I made a proposal for the own theme area, which could make this request obsolete: attachment 145874 [details] (png image) in bug 120747 - Firefox themes: Show an image of the own theme. In this proposal I named the button 'Select New Theme'. Better name desired.
Comment 2 Heiko Tietze 2018-10-24 11:08:34 UTC
Yes, your solution to bug 120747 fixes also this issue. Meanwhile we could go with "Load Firefox theme" perhaps.
Comment 3 Muhammet Kara 2018-10-25 12:27:41 UTC
What about "More Themes"?
Comment 4 Adolfo Jayme 2018-10-25 13:26:24 UTC
Just reposition that button adequately and any potential confusion will be gone. There is no need to rename it and cause it to need re-translation.
Comment 5 Muhammet Kara 2018-12-22 19:50:03 UTC
Let's continue with "Load Firefox theme", and get over with this then.
Comment 6 Commit Notification 2018-12-23 19:28:41 UTC
Muhammet Kara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/8e5d874ae2b6135d923302e078ee195a398c23e5%5E%21

tdf#120743: Rename the 'Select Theme' button to clarify

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 BogdanB 2019-01-14 19:34:58 UTC
Solved.
Verified on
Version: 6.3.0.0.alpha0+
Build ID: afbbdcc216a84b59fb263777659b044c4a7cf6f0
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-01-13_03:54:12
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded
Comment 8 Xisco Faulí 2019-05-02 10:58:13 UTC
*** Bug 124308 has been marked as a duplicate of this bug. ***