Bug 120772 - kde5: Drag'n'drop of image from file manager doesn't work
Summary: kde5: Drag'n'drop of image from file manager doesn't work
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All Linux (All)
: medium normal
Assignee: Katarina Behrens (CIB)
URL:
Whiteboard: target:6.3.0 target:6.2.1
Keywords:
: 123140 123751 (view as bug list)
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2018-10-22 07:26 UTC by Michael Weghorn
Modified: 2019-02-28 16:38 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
sample PNG image (15.98 KB, image/png)
2018-10-22 07:26 UTC, Michael Weghorn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Weghorn 2018-10-22 07:26:27 UTC
Created attachment 145891 [details]
sample PNG image

Version: 6.2.0.0.alpha0+
Build ID: 27b0d7237a7e2f32897fa52820c3aa382f6683e9
CPU threads: 4; OS: Linux 4.18; UI render: default; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); Calc: threaded

This is specific to the qt5/kde5 VCL plugins. It works e.g. with gtk3.

Steps to reproduce:

1) download attached image "test.png" (or use another one)
2) open the directory where the file is saved in the file manager (tested with Dolphin)
3) open a new document in Writer
4) put the file manager window and Writer window next to each other
5) left-click on the "test.png" file in file manager and drag to the Writer document

Result: When moving the mouse over the Writer document, a read "stop" icon appears, indicating that dropping it there is not possible. Releasing the mouse button does not cause the image to be inserted into the document.

Expected result: Dropping the image into the Writer document should be possible, resulting in the image being inserted.

Side note: The same applies for other LibreOffice components, e.g. Impress.
Comment 1 Xisco Faulí 2018-10-22 07:37:16 UTC
I can reproduce it in

Version: 6.2.0.0.alpha0+
Build ID: 3846561f79cf9065abd9ca83c9fbfbe7e52e28e2
CPU threads: 1; OS: Linux 4.13; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-10-21_02:45:54
Locale: en-US (en_US.UTF-8); Calc: threaded

but not in

Version: 6.2.0.0.alpha0+
Build ID: 3846561f79cf9065abd9ca83c9fbfbe7e52e28e2
CPU threads: 1; OS: Linux 4.13; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-10-21_02:45:54
Locale: en-US (en_US.UTF-8); Calc: threaded
Comment 2 Commit Notification 2019-01-30 11:03:51 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/67b0fcea9d748c4dd8101036cbb2c587d65f0bf7%5E%21

tdf#120772: implement file manager -> LibO DnD

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2019-02-02 13:22:29 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/b8ac898eb0e1ce9f068e5b4e0c4b04a729a394cb%5E%21

tdf#120772: DnD of multiple URLs from file manager -> LibO

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Katarina Behrens (CIB) 2019-02-02 13:27:19 UTC
The ticket as originally reported is hereby fixed. Dropping anything else than file(s) from file manager is still not working but please open new tickets for those
Comment 5 Katarina Behrens (CIB) 2019-02-04 11:56:18 UTC
*** Bug 123140 has been marked as a duplicate of this bug. ***
Comment 6 Commit Notification 2019-02-06 15:27:37 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/18a451e4719a8205374478f1f58b09ac5fe63beb%5E%21

tdf#120772: implement file manager -> LibO DnD

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2019-02-06 15:27:45 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/98b7cf194f012d06f569259c9379ac71f6cd565a%5E%21

tdf#120772: DnD of multiple URLs from file manager -> LibO

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Katarina Behrens (CIB) 2019-02-28 16:38:58 UTC
*** Bug 123751 has been marked as a duplicate of this bug. ***