Download it now!
Bug 120777 - KDE5: Dialogs get blank when they are resized
Summary: KDE5: Dialogs get blank when they are resized
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2018-10-22 08:00 UTC by Xisco Faulí
Modified: 2018-12-21 12:24 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (25.86 KB, image/png)
2018-10-22 08:00 UTC, Xisco Faulí
Details
wiz-converter (23.29 KB, image/png)
2018-10-22 11:54 UTC, Vera Blagoveschenskaya
Details
video.mkv (1.05 MB, video/x-matroska)
2018-11-06 06:48 UTC, Vera Blagoveschenskaya
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2018-10-22 08:00:52 UTC
Created attachment 145895 [details]
screenshot

Steps to reproduce:
1. Launch LibreOffice with --safe-mode
2. In the safe mode dialog, click on the Advanced button

-> The top part of the dialog disappears...

reproduce it in

Version: 6.2.0.0.alpha0+
Build ID: 3846561f79cf9065abd9ca83c9fbfbe7e52e28e2
CPU threads: 1; OS: Linux 4.13; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time:
2018-10-21_02:45:54
Locale: en-US (en_US.UTF-8); Calc: threaded

but not in

Version: 6.2.0.0.alpha0+
Build ID: 3846561f79cf9065abd9ca83c9fbfbe7e52e28e2
CPU threads: 1; OS: Linux 4.13; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time:
2018-10-21_02:45:54
Locale: en-US (en_US.UTF-8); Calc: threaded
Comment 1 Xisco Faulí 2018-10-22 10:14:43 UTC
Same behaviour reproduced in Pivot Table dialog when clicking on Options...
Comment 2 Vera Blagoveschenskaya 2018-10-22 11:54:54 UTC
Created attachment 145900 [details]
wiz-converter

Wizards -> Letter, Fax, Agenda, Converters and Address Data Source are shown partitially.
Comment 3 Vera Blagoveschenskaya 2018-10-22 11:55:27 UTC
(In reply to Vera from comment #2)
> Created attachment 145900 [details]
> wiz-converter
> 
> Wizards -> Letter, Fax, Agenda, Converters and Address Data Source are shown
> partitially.

I use kworkstation (ALT Linux): KDE Plasma 5.12.7, KDE frameworks 5.49.0, QT 5.9.6
Comment 4 Xisco Faulí 2018-10-22 12:13:41 UTC
Found the general problem: Dialogs get completely blank if they are resized
Comment 5 Michael Weghorn 2018-10-22 17:32:28 UTC
Confirmed with

Version: 6.2.0.0.alpha1+
Build ID: cd9aa5bc508244082b4baf4a3094875bf2c6f992
CPU threads: 4; OS: Linux 4.18; UI render: default; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); Calc: threaded
Comment 6 Commit Notification 2018-11-01 08:36:16 UTC
Aleksei Nikiforov committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/f541da4f6d61d089c8d7a7c25b58795705c787eb%5E%21

tdf#120777 KDE5: Dialogs get blank when they are resized

It will be available in 6.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Vera Blagoveschenskaya 2018-11-06 06:47:40 UTC
Aleksei, thank you for the fix.

I've checked it with the lastest master from here
https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@86-TDF/current/?C=N&O=D
master~2018-11-04_22.10.34_LibreOfficeDev_6.2.0.0.alpha1_Linux_x86-64_rpm.tar.gz

Steps from Description:
- can't reproduce = OK

Steps from Comment2:
- can't reproduce = OK

Resize of different dialogs:
- Unfortunately, I can reproduce getting blank for some dialogs: 
Wizards -> Letter, Fax, Agenda, Converters
Steps to reproduce: 
- open some dialog (for ex, Wizards -> Letter)
- resize it

Please see video in the attachment.

Reproduced for 

Version: 6.2.0.0.alpha1+
Build ID: 7cf6cee97bc05512fae482733ee45f039e9d2160
CPU threads: 1; OS: Linux 4.14; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-11-04_22:10:34
Locale: ru-RU (ru_RU.UTF-8); Calc: threaded

DO NOT Reproduced for

Version: 6.2.0.0.alpha1+
Build ID: 7cf6cee97bc05512fae482733ee45f039e9d2160
CPU threads: 1; OS: Linux 4.14; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-11-04_22:10:34
Locale: ru-RU (ru_RU.UTF-8); Calc: threaded
Comment 8 Vera Blagoveschenskaya 2018-11-06 06:48:03 UTC
Created attachment 146334 [details]
video.mkv
Comment 9 Commit Notification 2018-11-08 14:58:30 UTC
Aleksei Nikiforov committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/bb9ddf256452a3fe5aec2f638335453063449f5f%5E%21

tdf#120777 KDE5: Prohibit resizing windows unless they're marked resizeable

It will be available in 6.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2018-11-08 14:58:36 UTC
Aleksei Nikiforov committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/97cba40765d3178fecd463879304bac7da0efa59%5E%21

tdf#120777 KDE5: Remove initial painting of widgets

It will be available in 6.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Vera Blagoveschenskaya 2018-11-09 07:31:07 UTC
Can't reproduce 
https://bugs.documentfoundation.org/show_bug.cgi?id=120777#c8

for

Version: 6.2.0.0.alpha1+
Build ID: 3d70b1253f964fb75cd4b5915b8dd031ee54d5c7
CPU threads: 4; OS: Linux 4.14; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-11-08_16:22:16
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded
Comment 12 Michael Weghorn 2018-11-09 14:58:27 UTC
(In reply to Vera Blagoveschenskaya from comment #11)
> Can't reproduce 
> https://bugs.documentfoundation.org/show_bug.cgi?id=120777#c8
> 
> for
> 
> Version: 6.2.0.0.alpha1+
> Build ID: 3d70b1253f964fb75cd4b5915b8dd031ee54d5c7
> CPU threads: 4; OS: Linux 4.14; UI render: default; VCL: kde5; 
> TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time:
> 2018-11-08_16:22:16
> Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
> Calc: threaded

Let's mark this bug as fixed then.

A big thanks to Aleksei for fixing the bug(s)!
Comment 13 Commit Notification 2018-11-16 09:43:58 UTC
Aleksei Nikiforov committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/5edc23dbc53773536265fd6a54319d9cd1cd9e99%5E%21

tdf#120777 KDE5: Update initialization of QImages

It will be available in 6.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Xisco Faulí 2018-12-21 12:24:50 UTC
Verified in

Version: 6.2.0.1
Build ID: 0412ee99e862f384c1106d0841a950c4cfaa9df1
CPU threads: 1; OS: Linux 4.15; UI render: default; VCL: kde5; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded