Bug 120816 - Crash if i open "insert line' and begin to draw line
Summary: Crash if i open "insert line' and begin to draw line
Status: RESOLVED DUPLICATE of bug 120794
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha1+
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-10-23 06:34 UTC by Nick Safonov
Modified: 2018-10-24 10:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Safonov 2018-10-23 06:34:51 UTC
Description:
when i select "insert line" and drawing lie,LO crushed.

Steps to Reproduce:
1.Open LO Writer
2.select "Show Draw Functions"
3.select "Insert Line"
4.Start draw line

Actual Results:
LO crushed

Expected Results:
LO should not crushed


Reproducible: Sometimes


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 6.2.0.0.alpha1
Build ID: ff46ad24d1d3cbcea45895520483ed1fd4ff488b
CPU threads: 4; OS: Linux 4.18; UI render: default; VCL: gtk3; 
Locale: ru-RU (ru_RU.UTF-8); Calc: threaded

UUID of crush report: f2e45f2d-ec4c-4e25-81af-4e86c1a88194
Comment 1 Dieter 2018-10-23 07:44:19 UTC
I tried to reproduce it:

1.Open LO Writer
2.View => Toolbars => Drawing
3.Select "Insert Line" from Drawing tooolbar
4.Start draw line

No crash with

Version: 6.2.0.0.alpha1+ (x64)
Build ID: 8274c4c62df5b937b3f0bec9e1eeca85f3b219d4
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-10-22_01:47:50
Locale: en-US (de_DE); Calc: CL
Comment 2 Xisco Faulí 2018-10-23 08:10:38 UTC
duplicate of bug 120794 ?
Comment 3 Xisco Faulí 2018-10-23 08:14:33 UTC
OTOH, Does it work if you disable OpenGl ? -> https://wiki.documentfoundation.org/OpenGL
Comment 4 Nick Safonov 2018-10-23 08:16:04 UTC
reproduced on Windows 7 x64

Version: 6.2.0.0.alpha1+ (x64)
Build ID: 8274c4c62df5b937b3f0bec9e1eeca85f3b219d4
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-10-22_01:47:50
Locale: ru-RU (ru_RU); Calc: CL
Comment 5 Nick Safonov 2018-10-23 08:19:17 UTC
(In reply to Dieter Praas from comment #1)
> I tried to reproduce it:
> 
> 1.Open LO Writer
> 2.View => Toolbars => Drawing
> 3.Select "Insert Line" from Drawing tooolbar
> 4.Start draw line
> 
> No crash with
> 
> Version: 6.2.0.0.alpha1+ (x64)
> Build ID: 8274c4c62df5b937b3f0bec9e1eeca85f3b219d4
> CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
> TinderBox: Win-x86_64@42, Branch:master, Time: 2018-10-22_01:47:50
> Locale: en-US (de_DE); Calc: CL

try to make the line beyond the field and wait 1-2min.
i reproduced this on Windows7 too
Comment 6 Xisco Faulí 2018-10-23 08:45:07 UTC
Regression introduced by 
https://cgit.freedesktop.org/libreoffice/core/commit/?id=b4fc996520b47a6212661a9de3a1c72ccfc379a4

*** This bug has been marked as a duplicate of bug 120794 ***