Bug 120818 - dotted line climbs out of document fields,and then crash
Summary: dotted line climbs out of document fields,and then crash
Status: RESOLVED DUPLICATE of bug 120794
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha1+
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-10-23 06:57 UTC by Nick Safonov
Modified: 2018-10-24 10:53 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Safonov 2018-10-23 06:57:37 UTC
Description:
When select "insert line" and start to draw  dotted linу climbs out of document fields(Writer),and crash LO.

Steps to Reproduce:
1.Open LO Writer
2.Select "Show Draw Function"
3.Select "Insert Line"
4.Start to draw line
5.Grub end of line(green box)
6.pull it out of the page

Actual Results:
dotted line climbs out of document fields,and then LO crash

Expected Results:
dotted line should remain in the document field
and LO should work))


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 6.2.0.0.alpha1
Build ID: ff46ad24d1d3cbcea45895520483ed1fd4ff488b
CPU threads: 4; OS: Linux 4.18; UI render: default; VCL: gtk3; 
Locale: ru-RU (ru_RU.UTF-8); Calc: threaded

http://crashreport.libreoffice.org/stats/crash_details/70b344a6-bb10-469d-bd18-599fa192b6e9
Comment 1 Nick Safonov 2018-10-23 07:00:14 UTC
Reproducible: Sometimes
Steps to Reproduce:
7)wait 1-2 minutes
then LO crash
Comment 2 Xisco Faulí 2018-10-23 08:59:40 UTC
Regression introduced by 
https://cgit.freedesktop.org/libreoffice/core/commit/?id=b4fc996520b47a6212661a9de3a1c72ccfc379a4

*** This bug has been marked as a duplicate of bug 120794 ***