Download it now!
Bug 120836 - KDE5: LO Calc slow at 'Select all'
Summary: KDE5: LO Calc slow at 'Select all'
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha1+
Hardware: All Linux (All)
: medium normal
Assignee: Aleksei Nikiforov
URL:
Whiteboard: target:6.3.0 target:6.2.1 target:6.2.5
Keywords:
: 122679 122819 (view as bug list)
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2018-10-23 13:51 UTC by Vera Blagoveschenskaya
Modified: 2019-06-13 14:46 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
test document (28.62 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2018-10-23 13:52 UTC, Vera Blagoveschenskaya
Details
Another sample document (12.74 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-10-24 08:06 UTC, Michael Weghorn
Details
extended sample documents with ~1000 unformatted rows (25.66 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-01-19 11:44 UTC, Michael Weghorn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vera Blagoveschenskaya 2018-10-23 13:51:06 UTC
Description:
LO Calc hangs at 'Select all'

Steps to Reproduce:
1. Open .xlsx document via LO Calc (see test sample in the attachment)
2. Ctrl+A or Select all

Actual Results:
Application hangs

Expected Results:
Normal selection


Reproducible: Always


User Profile Reset: No



Additional Info:
Reproduced for

Version: 6.2.0.0.alpha1
Build ID: ff46ad24d1d3cbcea45895520483ed1fd4ff488b
CPU threads: 1; OS: Linux 4.14; UI render: default; VCL: kde5; 
Locale: ru-RU (ru_RU.UTF-8); Calc: threaded

DO NOT reproduced for

Version: 6.2.0.0.alpha1
Build ID: ff46ad24d1d3cbcea45895520483ed1fd4ff488b
CPU threads: 1; OS: Linux 4.14; UI render: default; VCL: gtk3; 
Locale: ru-RU (ru_RU.UTF-8); Calc: threaded

DO NOT reproduced for

Version: 6.1.2.1
Build ID: 65905a128db06ba48db947242809d14d3f9a93fe
CPU threads: 4; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: ru-RU (ru_RU.UTF-8); Calc: group threaded
Comment 1 Vera Blagoveschenskaya 2018-10-23 13:52:41 UTC
Created attachment 145934 [details]
test document
Comment 2 Xisco Faulí 2018-10-23 14:08:50 UTC
When you say it hangs, you mean you have to kill LibreOffice?
Comment 3 Vera Blagoveschenskaya 2018-10-23 14:13:16 UTC
I mean no menu available, scroll doesn't work for 20-30 sec.
Anyway, there is no text selection as a result.
Comment 4 Xisco Faulí 2018-10-23 14:21:49 UTC
I can't reproduce it in

Version: 6.2.0.0.alpha0+
Build ID: 3846561f79cf9065abd9ca83c9fbfbe7e52e28e2
CPU threads: 1; OS: Linux 4.13; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-10-21_02:45:54
Locale: en-US (en_US.UTF-8); Calc: threaded
Comment 5 Vera Blagoveschenskaya 2018-10-23 14:32:28 UTC
Xisco can you try with my test document ?
Comment 6 Michael Weghorn 2018-10-23 19:02:09 UTC
I guess the duration for "Select all" (Ctrl+A) depends on the hardware/CPU.

For me (on a Fujitsu Lifebook E756 with an Intel Core i7-6500U CPU), it takes about 10 seconds when using the attached document and kde5, while it feels "instantaneous" when using gtk3 (~1 second), so it's actually quite slower.

However, the whole sheet content is finally selected in my case (though copying and pasting into a new Calc sheet does not yield the desired result).

Version: 6.2.0.0.alpha1+
Build ID: 25af42bc70e1a0a61d2ea90d7b0ef1ed6000ed69
CPU threads: 4; OS: Linux 4.18; UI render: default; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); Calc: threaded

Vera: Did you use the mouse or press any buttons while waiting? That might have an effect on whether the cells are selected in the end.
Comment 7 Vera Blagoveschenskaya 2018-10-24 06:13:09 UTC
(In reply to Michael Weghorn from comment #6)

> Vera: Did you use the mouse or press any buttons while waiting? That might
> have an effect on whether the cells are selected in the end.

Yes, I tried to use scroll, open menus, etc.
This is the reason for "nothing selected".

Thus, bug is only for "slow selection"
Comment 8 Michael Weghorn 2018-10-24 07:50:44 UTC
(In reply to Vera from comment #7)
> (In reply to Michael Weghorn from comment #6)
> [...]
> Thus, bug is only for "slow selection"
Thanks for the clarification.

Slowness of Ctrl+A on attached document with kde5 (as compared to gtk3) confirmed with

Version: 6.2.0.0.alpha1+
Build ID: d11594db10c6c4eb9251c6eeeccbf9b9565cc693
CPU threads: 4; OS: Linux 4.18; UI render: default; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); Calc: threaded
Comment 9 Michael Weghorn 2018-10-24 08:06:35 UTC
Created attachment 145959 [details]
Another sample document

Slowness can also be reproduced with this simpler document that has no special formatting applied. (The amount of "used" cells does play a role however; an empty sheet is fast.)

Besides Ctrl+A, selecting cells using the mouse is also significantly slower than with gtk3.
Comment 10 Michael Weghorn 2019-01-15 13:38:04 UTC
*** Bug 122679 has been marked as a duplicate of this bug. ***
Comment 11 Commit Notification 2019-01-18 18:22:34 UTC
Aleksei Nikiforov committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/7e01a02b12a9ea3a39b5a627f3b26d94bc1ad921%5E%21

tdf#120836 KDE5: allow adding multiple mime types to clipboard

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Michael Weghorn 2019-01-19 11:44:49 UTC
Created attachment 148433 [details]
extended sample documents with ~1000 unformatted rows

Thanks, this commit significantly improves performance!

kde5 is still significantly slower than gtk3 at "Select All", though, e.g. the attached sample document (with some more unformatted rows now) still takes ~30 seconds for me with kde5, while they are selected instantly with gtk3.
Comment 13 Michael Weghorn 2019-01-19 11:48:52 UTC
(In reply to Michael Weghorn from comment #12)
> kde5 is still significantly slower than gtk3 at "Select All", though, e.g.
> the attached sample document (with some more unformatted rows now) still
> takes ~30 seconds for me with kde5, while they are selected instantly with
> gtk3.

(with master as of commit 87bf8b7900fe4757bd8494f7a72966915f653eb6)
Comment 14 Vera Blagoveschenskaya 2019-01-21 06:38:06 UTC
Thanks Alexei,

I've checked selection (Ctrl+A) for the following build:

Version: 6.3.0.0.alpha0+
Build ID: 87bf8b7900fe4757bd8494f7a72966915f653eb6
CPU threads: 4; OS: Linux 4.14; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-01-19_19:05:11
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

For the documents from 
Comment#1
Comment#9
CTRL+A works in a 1-2 second

But for the document from
Comment#12
it is about 10-15 sec to select all (I confirm Michael's test).

Could you please take a look?
Comment 15 Aleksei Nikiforov 2019-01-21 11:54:28 UTC
(In reply to Vera Blagoveschenskaya from comment #14)
> But for the document from
> Comment#12
> it is about 10-15 sec to select all (I confirm Michael's test).
> 
> Could you please take a look?

Yeah, looks slow to me too. I'll continue to investigate it.
Comment 16 Xisco Faulí 2019-01-21 13:18:47 UTC
*** Bug 122819 has been marked as a duplicate of this bug. ***
Comment 17 Commit Notification 2019-01-26 10:47:33 UTC
Aleksei Nikiforov committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/c8b0c382c6330865df50ae7cf7360c8a2c08ebe6%5E%21

tdf#120836 KDE5: Clipboard: don't put images to clipboard

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Vera Blagoveschenskaya 2019-01-27 09:33:57 UTC
Thanks, Alexei,

I've tried Ctrl+A for each test document in the attachment,
--> it works fine.

Version: 6.3.0.0.alpha0+
Build ID: ed707a4806a489467c6d9be7d1b787dab94b5f78
CPU threads: 1; OS: Linux 4.14; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-01-26_22:55:03
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded
Comment 19 Commit Notification 2019-02-04 13:36:46 UTC
Aleksei Nikiforov committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/b0b203b5d09054250a257c052d7c7870eb1c4ffe%5E%21

tdf#120836 KDE5: allow adding multiple mime types to clipboard

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2019-02-06 15:27:26 UTC
Aleksei Nikiforov committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/012e471393b41dae7fe6d35bbaf575f87e7c8470%5E%21

tdf#120836 KDE5: Clipboard: don't put images to clipboard

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Commit Notification 2019-05-16 10:33:45 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/0d58f51d7672c569c93c6e814dbfffa586eebfb7%5E%21

Revert "tdf#120836 KDE5: Clipboard: don't put images to clipboard"

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 Commit Notification 2019-06-13 14:46:04 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/d0b03870b7eb67a5a4f4981c1e104ca03bd6e993%5E%21

Revert "tdf#120836 KDE5: Clipboard: don't put images to clipboard"

It will be available in 6.2.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.