Download it now!
Bug 120845 - link to other worksheets don't work well
Summary: link to other worksheets don't work well
Status: RESOLVED DUPLICATE of bug 76047
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.6.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-23 16:06 UTC by Andres Pochat
Modified: 2018-10-26 16:59 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andres Pochat 2018-10-23 16:06:59 UTC
Description:
I have a cell that looks for a value in another file. When I save the file, it changes the address of the reference I placed and doesn't bring the value.
If I write the reference every time I need it, it brings it ok, unless I change the value in the origin reference. It brings the previous value.
IE 1: ORIGINAL AND CORRECT CELL REFERENCE 'file:///home/andres/Dropbox/creditos/resumen prestamos.xls'#$Real.D7+1
SAME CELL AFTER SAVING, CLOSING AND OPENING AGAIN   =[2]real!d7+1
And it doesn't work

IE 2: cell value moment 1 = 366. Pasting the cell reference brings '366' as value. If the 366 value changes, and I paste again the cell reference, it keeps bringing '366', even though I even edit the cell, press F9, save, etc. If I close and open again, and paste the cell reference, it works

Steps to Reproduce:
1.reference a value to another .xlsx file.
2.save and close both files
3.open file, and the reference is 'crooked' and doesn't work

Actual Results:
reference doesn't work. It doesn't matter if the referenced file is opened or closed

Expected Results:
reference to external files should work


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.0.6.2
Build ID: 1:6.0.6-0ubuntu0.18.04.1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: es-AR (en_US.UTF-8); Calc: group
Comment 1 m.a.riosv 2018-10-23 21:31:00 UTC
Your files seems to be ms format, then maybe it's a dup of:
https://bugs.documentfoundation.org/show_bug.cgi?id=76047
Comment 2 Andres Pochat 2018-10-26 14:07:49 UTC
yes, it's .xlsx format. But, shouldn't it work anyway?
Comment 3 m.a.riosv 2018-10-26 15:22:38 UTC
Yes, but seems the same issue already reported tdf#76047
Comment 4 Timur 2018-10-26 16:59:44 UTC
Sorry for not testing this, but I'll mark duplicate. 
Andres, if you disagree, please explain and set back to Unconfirmed.

*** This bug has been marked as a duplicate of bug 76047 ***