Download it now!
Bug 120851 - icons in menu bar look blurry
Summary: icons in menu bar look blurry
Status: RESOLVED DUPLICATE of bug 115439
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.6.1 rc
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: HiDPI
  Show dependency treegraph
 
Reported: 2018-10-23 22:45 UTC by Andreas Saladin
Modified: 2019-01-28 09:33 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
blurry icons (27.41 KB, image/png)
2018-10-26 21:54 UTC, Andreas Saladin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Saladin 2018-10-23 22:45:22 UTC
Description:
While the libreoffice 6.0.6 looks great on my linux mint system the same version looks horrible on my windows 10 system. All icon themes have the same problem. How can I fix this problem?

Steps to Reproduce:
1.download latest version for windows 10
2.open writer or calc
3.icons are blurry

Actual Results:
blurry icons

Expected Results:
good looking icons


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
the basic version should just work
Comment 1 V Stuart Foote 2018-10-24 03:22:21 UTC
What is the screen resolution of your "new" windows 10 system? And, improvement if you reduce your Windows -> Display Settings -> Scale and Layout to 125%?
Comment 2 Andreas Saladin 2018-10-24 13:19:58 UTC
This doesn't solve the problem - maybe it is a little bit better - but marginal. Still it is a very bad overall impression
Comment 3 Andreas Saladin 2018-10-24 13:22:58 UTC
I tried several solutions windows offers: compatibility mode for windows 8 and also what is called "optimize full pictur" - vollbildoptimierung in German.
Comment 4 Xisco Faulí 2018-10-26 09:34:17 UTC
Could you please share a screenshot ?
Comment 5 Andreas Saladin 2018-10-26 21:54:20 UTC
Created attachment 146050 [details]
blurry icons

another strange aspect is the loading time of libreoffice - it takes very long to load - longer than any other program on my computer (even longer than matlab)
Comment 6 Regina Henschel 2018-10-26 22:56:28 UTC
Do you use a larger scaling for the display, eg. 150%? That is the default setting in Windows 10, if you have a high resolution (4k) monitor. To see your actual scaling right click the desktop > Display settings. If you do not get the information directly, click on "Advanced scaling settings".

Does starting is always longer or only the first time you use something which you have not used before? With a larger scaling, LibreOffice generates larger icons on the fly and store them into <installation-path>/cache/<icon-theme-name>/<scaling-factor>.
Comment 7 Andreas Saladin 2018-10-28 08:41:23 UTC
I tried the scaling a few times before - however - I downloaded the newest version: 6.2 (testing version) and now changing the scaling works - it is sharp now with the 125% scaling.

This comes as a surprise as I really changed all these things many times and never had a positive effect. 

Btw: I cannot find the path with the scaled icons in the cache. I have the libreoffice folder but there are folders like help, readmes, share, preset etc. - but no cache. 

I would prefer larger icons in general. It is only libreoffice that has a problem with 150% - which is a pity.

Is there a way to get 150% scaling sharp?

The loading time is very quick - also the first time. Takes about 2 seconds to oper writer

Thanks for your help - it is very appreciated.
Comment 8 Regina Henschel 2018-10-28 12:13:37 UTC
The cache folder is likely in the UserProfile folder in your case, because you have installed LibreOffice regular, but I have made an administrative installation. [https://wiki.documentfoundation.org/UserProfile  Set Windows explorer to show hidden files, that makes it easier.]

125% works because it is exactly the threshold in /core/vcl/source/window/window.cxx. 125% * 96dpi = 120 dpi

If you scale up a raster graphic format (here png), you get always problems. Thus the solution is to start with a vector format (here svg). For some icon-themes svg versions already exists in the source, but they are not delivered yet. There still exist problems in case a command has no own icon but shares an icon with other commands. You can pack such svg icon-theme and try whether it works for you.

Starting a part of LibreOffice the first time might have a noticeable delay, because the enlarged icons are generated then. After they are in the cache, starting will be shorter next time.

If a scaling of 125% is high enough for the menu fonts and you only need larger icons, you can try to use "Extra Large" instead of "Automatic" in Tools > Options > LibreOffice > View.

*** This bug has been marked as a duplicate of bug 115439 ***