Download it now!
Bug 120891 - Sign exported PDF → OpenPGP
Summary: Sign exported PDF → OpenPGP
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.2.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pdf, implementationError
Depends on:
Blocks: PDF-Export-Options-Dialog
  Show dependency treegraph
 
Reported: 2018-10-25 07:49 UTC by Timur Davletshin
Modified: 2020-05-20 13:44 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Steps to reproduce (559.29 KB, image/jpeg)
2019-08-12 11:44 UTC, Timur Davletshin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timur Davletshin 2018-10-25 07:49:03 UTC
Description:
Do not show OpenPGP signature in PDF export dialog

Steps to Reproduce:
1. Save document
2. File → Export As → Export to PDF
3. Digital Signatures → Certificate
4. Choose OpenPGP signature. In this case Certificate field will be empty regardless of your choice.
5. Click export

Actual Results:
Export operation will produce error (Signature generation failed).

Expected Results:
PDF standard is not compatible with PGP signatures. Do not show OpenPGP signatures during PDF export.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Comment 1 Xisco Faulí 2019-01-14 17:54:14 UTC
I can't reproduce it in

Versión: 6.2.0.2
Id. de compilación: 2ce5217b30a543f7666022df50f0562f82be0cff
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; VCL: win; 
Configuración regional: es-ES (es_ES); Idioma de IU: es-ES
Calc: threaded

Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 2 QA Administrators 2019-07-14 02:49:28 UTC Comment hidden (obsolete)
Comment 3 Timur Davletshin 2019-08-09 09:33:27 UTC
(In reply to Xisco Faulí from comment #1)
> I can't reproduce it in
> 
> Versión: 6.2.0.2
> Id. de compilación: 2ce5217b30a543f7666022df50f0562f82be0cff
> Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; VCL: win; 
> Configuración regional: es-ES (es_ES); Idioma de IU: es-ES
> Calc: threaded
> 
> Could you please try to reproduce it with the latest version of LibreOffice
> from https://www.libreoffice.org/download/libreoffice-fresh/ ?
> I have set the bug's status to 'NEEDINFO'. Please change it back to
> 'UNCONFIRMED' if the bug is still present in the latest version.

Yes, it does. It can be reproduced in ALL recent builds.
Comment 4 Timur Davletshin 2019-08-12 11:44:27 UTC
Created attachment 153321 [details]
Steps to reproduce

PDF isn't compatible with PGP. PGP signatures must be hidden.
Comment 5 Timur Davletshin 2019-09-04 05:54:59 UTC
Looks like it is fixed in 6.3. Can anyone confirm it?
Comment 6 lachend 2019-12-31 17:56:41 UTC
I've got the same problem in LibreOffice 6.3.4.2 for Ubuntu.
I know, that PDF is incompatible with OpenPGP signatures, but there's no option to add *.p12 files.
Comment 7 Buovjaga 2020-04-29 18:20:28 UTC
(In reply to Timur Davletshin from comment #5)
> Looks like it is fixed in 6.3. Can anyone confirm it?

Let's close, then
Comment 8 lachend 2020-04-30 18:30:49 UTC
It's NOT resolved in 6.4.0.3 version.
Comment 9 Buovjaga 2020-04-30 18:59:11 UTC
(In reply to lachend from comment #6)
> I've got the same problem in LibreOffice 6.3.4.2 for Ubuntu.
> I know, that PDF is incompatible with OpenPGP signatures, but there's no
> option to add *.p12 files.

Your issue is not the same as Timur's! Please open a new report, if you want to discuss it.
Comment 10 Timur 2020-05-20 13:44:24 UTC
This looks like a duplicate of bug 113278, see also bug 115884.