Bug 120892 - Sign existing PDF → Broken
Summary: Sign existing PDF → Broken
Status: RESOLVED DUPLICATE of bug 104815
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.2.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Digital-Signatures
  Show dependency treegraph
 
Reported: 2018-10-25 07:59 UTC by Timur Davletshin
Modified: 2020-06-05 07:26 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
Test PDF file (67.93 KB, application/pdf)
2018-10-25 08:00 UTC, Timur Davletshin
Details
Broken PDF after operation (117.79 KB, application/pdf)
2018-10-25 08:00 UTC, Timur Davletshin
Details
Test PDF file without compression (217.92 KB, application/pdf)
2018-10-26 17:11 UTC, Timur Davletshin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timur Davletshin 2018-10-25 07:59:19 UTC
Description:
Signing existing PDF damages PDF file.

Steps to Reproduce:
1. File → Digital Signatures → Sign Existing PDF
2. Open PDF file (attached)
3. Click "Sign Document" in blue popup bar
4. Choose (doubleclick) your digital signature (in my case I used COMODO, available for free)
5. Close "Close" of Digital Signatures manager (it will show nothing after your choice)

Actual Results:
Check signed PDF — it is broken, no signature.

Expected Results:
Sign PDF


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Comment 1 Timur Davletshin 2018-10-25 08:00:22 UTC
Created attachment 145988 [details]
Test PDF file
Comment 2 Timur Davletshin 2018-10-25 08:00:51 UTC
Created attachment 145989 [details]
Broken PDF after operation
Comment 3 Timur 2018-10-26 08:44:43 UTC Comment hidden (obsolete)
Comment 4 Timur Davletshin 2018-10-26 14:01:43 UTC
(In reply to Timur from comment #3)
> As in Bug 104815, not clear whether this is about PDF content (external) or
> PDF version (this one is 1.5 and that one 1.6) or both.

It does work for certain PDFs but I don't see any link with PDF version.
Comment 5 Timur 2018-10-26 16:29:07 UTC
New possibility is that problems happen with compressed PDFs. Please see Bug 104815.
Comment 6 Timur Davletshin 2018-10-26 17:06:57 UTC
(In reply to Timur from comment #5)
> New possibility is that problems happen with compressed PDFs. Please see Bug
> 104815.

Probably you're right, compiling same document with compression disabled fixed my issue (PDF version remains the same).
Comment 7 Timur Davletshin 2018-10-26 17:11:51 UTC
Created attachment 146045 [details]
Test PDF file without compression
Comment 8 Timur 2018-11-05 09:56:16 UTC
Let's close as a duplicate of Bug 104815, unless shown that it's not.

*** This bug has been marked as a duplicate of bug 104815 ***