Download it now!
Bug 120944 - REGRESSION: Can not open .txt files nor tabbed txt files in Calc
Summary: REGRESSION: Can not open .txt files nor tabbed txt files in Calc
Status: RESOLVED DUPLICATE of bug 120796
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2018-10-26 18:56 UTC by Pedro
Modified: 2018-10-26 19:09 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
When Selecting Calc in "Open with" Dialog in W10, txt files open in Writer. If I predefine Calc as program to open txt files, they open in Writer (337.69 KB, image/png)
2018-10-26 18:56 UTC, Pedro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro 2018-10-26 18:56:34 UTC
Created attachment 146046 [details]
When Selecting Calc in "Open with" Dialog in W10, txt files open in Writer. If I predefine Calc as program to open txt files, they open in Writer

Before 6.1 rolled around I frequently used Calc to open tabulated txt files to manipulate and convert them into either .ods files or even .xlxs files. The options in Calc on how to split txt files.

Starting with 6.1 even if I expressly try to define Calc to open .txt files as the predefined program, .txt files will ALWAYS open in Writer.
This is extremely frustrating since I use several programs in my workflow (bioinformatics) that output tabulated .txt files (not csv, not .tab) and starting with 6.1 I can't open them on my preferred tool to sort the tabulated files, which is Calc.

Arguably the only thing in which Calc shines over Excel is in the options it gives on how to partition a .txt file when opening it. Now that has been taken away because .txt files are forcibly opened on Writer every freaking time even when I expressly try to force open them with Calc.

There is a workaround, which is to have Calc opened and drop the .txt file on an open instance of Calc, but a new user won't know about this and it breaks with Calc's behaviour from pre-6.1.

Also, Writer should NEVER be pre-defined as the default module to open .txt files in Libre Office. Document formats and text formats ARE DIFFERENT THINGS. The later are used to save scripts, or outputs from software like R or many bioinformatics tools and even code. Why would I want to open it on a document editor? Why is this pre-defined by LibreOffice? Why was previous behaviour broken? Why break something that was working great beforehand???
Comment 1 Pedro 2018-10-26 19:09:34 UTC
Sorry If I was out of line with some comments but this situation cropped up in a high pressure situation at work and it made lose precious time to figure out what was going on.

I like the work you guys do, and this thing showed up out of nowhere so it threw me off.
Comment 2 Buovjaga 2018-10-26 19:09:57 UTC

*** This bug has been marked as a duplicate of bug 120796 ***