Download it now!
Bug 121036 - Diagonal lines trespass the outer cell border
Summary: Diagonal lines trespass the outer cell border
Status: RESOLVED DUPLICATE of bug 115626
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha1+
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Regressions-borderline
  Show dependency treegraph
 
Reported: 2018-10-29 16:31 UTC by Telesto
Modified: 2019-01-21 12:41 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (13.38 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-10-29 16:32 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-10-29 16:31:21 UTC
Description:
Diagonal lines trespass the outer cell border

Steps to Reproduce:
1. Open the attached file
2. Check the diagonal line

Actual Results:
Line goes outside the expect area

Expected Results:
Only drawn within the cell


Reproducible: Always


User Profile Reset: No



Additional Info:
Repro with
Version: 6.2.0.0.alpha1+
Build ID: cb7500ddb8de6c41fca84a0009ffe22240bb1845
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-10-29_03:24:02
Locale: nl-NL (nl_NL); Calc: CL

No repro with
Versie: 4.4.7.2 
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: nl_NL
Comment 1 Telesto 2018-10-29 16:32:00 UTC
Created attachment 146144 [details]
Example file
Comment 2 m.a.riosv 2018-10-29 16:54:56 UTC
Repro
Versión: 6.1.3.1 (x64)
Id. de compilación: a9670562c26181ec3afbe381c9ff499ae88c98b7
Subprocs. CPU: 4; SO: Windows 10.0; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: CL
Comment 3 Telesto 2018-10-29 17:02:55 UTC
No repro with
Version: 5.4.0.0.alpha0+
Build ID: aabc5aab5af27e929a81a6036d2f470ab1f5ac4d
CPU Threads: 4; OS Version: Windows 6.29; UI Render: default; Layout Engine: new; 
Locale: nl-NL (nl_NL); Calc: CL
Comment 4 raal 2018-10-30 10:39:48 UTC
This seems to have begun at the below commits.
Adding Cc: to Armin Le Grand ; Could you possibly take a look at this one?
Thanks


    source sha:2f16219741aba016677103e4b22738d055c39a91
    
    source sha:2f16219741aba016677103e4b22738d055c39a91
    source sha:16fd7af90a9be159ebc7eab09083f1ef7eb64645
    source sha:1f02af4dbd13d79647549e1269722e2c0b67fa90
    source sha:53599a9a183878cdf435f80939f8d301a3909d78
    source sha:98ceb50c0a65708729df8f2967e616f52db42261
    source sha:0d2b5305263b01fbefdc998cfc713e36084d6294
    source sha:2135e461167dd873fd622e948b88b4194e6854b7
    source sha:2813d70f4a7e5522db1056352cd646a585a5c5d0
Comment 5 Telesto 2019-01-21 12:41:40 UTC

*** This bug has been marked as a duplicate of bug 115626 ***