Download it now!
Bug 121043 - Cutting and pasting a value into a cell referenced in formula doesn't update formula
Summary: Cutting and pasting a value into a cell referenced in formula doesn't update ...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 121568 (view as bug list)
Depends on:
Blocks: Paste Calculate
  Show dependency treegraph
 
Reported: 2018-10-29 19:35 UTC by Aron Budea
Modified: 2019-04-08 09:12 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample ODS (7.77 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-10-29 19:35 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2018-10-29 19:35:31 UTC
Created attachment 146149 [details]
Sample ODS

- Open attached spreadsheet.
- Cut A1.
- Paste into A2 (overwrite existing data).

=> F2, which is the sum of A2:D2, isn't updated accordingly (should become 22 instead of 26).

Observed using LO 6.2.0.0.alpha1+ (313392119522c21a6ecd14403d6f92c948149df7) & 4.4.0.3 / Ubuntu 18.04.
No issue in LO 4.3.0.4.
=> regression

Bibisected to the following commit using repo bibisect-44max.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=5ef856e975d7c0396984d588a43fd1a7c7085c55
author		Kohei Yoshida <kohei.yoshida@collabora.com>	2014-11-18 21:03:05 -0500
committer	Kohei Yoshida <kohei.yoshida@collabora.com>	2014-11-18 21:03:50 -0500

Use group area listeners during ODS import.
Comment 1 Aron Budea 2018-10-29 19:42:42 UTC
There are a couple of other, already fixed bugs starting with the same commit, eg. bug 86615.
Comment 2 raal 2018-10-29 21:46:48 UTC
Confirm with Version: 6.2.0.0.alpha1+
Build ID: a50f845957fff66ca7f459da4878be4597e0bae3
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: x11;
Comment 3 Xisco Faulí 2018-11-21 13:45:06 UTC
*** Bug 121568 has been marked as a duplicate of this bug. ***
Comment 4 Xisco Faulí 2018-11-21 13:47:01 UTC
Hi Eike, I've just found this issue as being the same root cause of bug 121568, I thought you might be interested in this issue as it's affecting formulas...
Comment 5 Oliver Brinzing 2019-03-15 19:24:16 UTC Comment hidden (obsolete)
Comment 6 Xisco Faulí 2019-03-18 19:47:19 UTC
Still reproducible in

Version: 6.3.0.0.alpha0+
Build ID: a11a2d84b09f85d2020c47f3ce42cd9efbff818a
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 7 Oliver Brinzing 2019-03-18 20:48:46 UTC
(In reply to Xisco Faulí from comment #6)
> Still reproducible in
> Version: 6.3.0.0.alpha0+
> Build ID: a11a2d84b09f85d2020c47f3ce42cd9efbff818a

are you sure ? i can not reproduce again in my new dev build:

Version: 6.3.0.0.alpha0+ (x64)
Build ID: a11a2d84b09f85d2020c47f3ce42cd9efbff818a
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded
Comment 8 Xisco Faulí 2019-04-04 10:07:42 UTC
You're right!!
This is fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=7fdc5df36f5b50e0629405a47ff3d5765fcfeb93
Comment 9 Xisco Faulí 2019-04-04 11:04:38 UTC
No need a test for this, this is already covered by https://gerrit.libreoffice.org/plugins/gitiles/core/+/6280b5c1c62ad40b5b9780a93c7cbee9ca0260f8%5E%21
Comment 10 Xisco Faulí 2019-04-08 09:12:21 UTC
Setting to VERIFIED FIXED