Download it now!
Bug 121066 - Chapter Numbering does not continue with document outline when saved and reopened in DOCX format (works with ODT)
Summary: Chapter Numbering does not continue with document outline when saved and reop...
Status: RESOLVED DUPLICATE of bug 76817
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks:
 
Reported: 2018-10-30 18:54 UTC by Alex
Modified: 2018-11-08 13:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
ODT example showing expected result (9.56 KB, application/vnd.oasis.opendocument.text)
2018-10-30 18:54 UTC, Alex
Details
DOCX file showing bug (4.94 KB, application/zip)
2018-10-30 18:56 UTC, Alex
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex 2018-10-30 18:54:09 UTC
Description:
If a chapter numbering outline (following the 1,1.1,1.1.1,... format) is created using the header styles for a document which is then saved in the DOCX format new additions cannot be added after file re-open as they always default to 1.1 or 1.1.1 (defending on heading style). Consequently I cannot ammend an already existing chapter numbering order.

Examples of documents in DOCX format showing error and another in ODT which shows expected result.

Steps to Reproduce:
1. Open writer.
2. Create several lines of text (e.g. Title 1 First Open, Title2 First Open etc)
3. Apply a heading style to each these (one Heading 1 and a mix of Level 2 and 3 Styles for the rest).
4. Go to Tools>Chapter Numbering
5. Set the Number field for Levels 1-3 as "1,2,3...". 
6. Click Ok. This way your several titles should all have numbers in the style of 1.1.1 
7. Save document in DOCX format
8. Close
9. Reopen file
10. Add new lines of text in between level 2 and 3 titles
11. Give these heading styles of levels 2 and 3

Actual Results:
Numbering wrong for newly added styles. Previously added numbers have not changed.

Expected Results:
Headings get numbers which fit with the existing document scheme. Previously added numbers are ammended so there no duplicate heading numbers.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Alex 2018-10-30 18:54:49 UTC
Created attachment 146174 [details]
ODT example showing expected result

ODT example showing expected result
Comment 2 Alex 2018-10-30 18:56:29 UTC
Created attachment 146175 [details]
DOCX file showing bug

DOCX file showing bug - note the incorrectly numbered headings
Comment 3 Alex 2018-10-30 18:58:33 UTC
I forgot to include that I'm using: 
Version: 6.1.2.1 (x64)
Build ID: 65905a128db06ba48db947242809d14d3f9a93fe
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
Locale: en-GB (en_GB); Calc: CL
Comment 4 Roman Kuznetsov 2018-11-01 17:37:25 UTC
confirm in

Версия: 6.1.0.2
ID сборки: b3972dcf1284967612d5ee04fea9d15bcf0cc106
Потоков ЦП: 4; ОС:Linux 4.13; Отрисовка ИП: по умолчанию; VCL: gtk2; 
Локаль: ru-RU (ru_RU.UTF-8); Calc: group threaded
Comment 5 Roman Kuznetsov 2018-11-01 17:38:53 UTC
looks as duplicate of bug 76817
Comment 6 Xisco Faulí 2018-11-08 13:12:47 UTC
Closing as a dupe of bug 76817
@Roman, Thanks for pinpointing that...

*** This bug has been marked as a duplicate of bug 76817 ***