Download it now!
Bug 121095 - Let "paragraph symbol" and "newline symbol" be "determined by yourself"
Summary: Let "paragraph symbol" and "newline symbol" be "determined by yourself"
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.1.1 rc
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-01 14:43 UTC by 00
Modified: 2018-11-05 15:42 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
1 (14.71 KB, image/png)
2018-11-01 14:46 UTC, 00
Details
2 (56.84 KB, image/png)
2018-11-02 06:52 UTC, 00
Details
The "paragraph symbol" of Microsoft Office is ¶ (25.55 KB, image/png)
2018-11-02 09:12 UTC, Mike Kaganski
Details
The Microsoft Office 2019 paragraph symbol of the Traditional Chinese version is not ¶. (1) (157.68 KB, image/png)
2018-11-04 08:25 UTC, 00
Details
The Microsoft Office 2019 paragraph symbol of the Traditional Chinese version is not ¶. (2) (156.85 KB, image/png)
2018-11-04 08:26 UTC, 00
Details

Note You need to log in before you can comment on or make changes to this bug.
Description 00 2018-11-01 14:43:27 UTC
Description:
Put this feature in "Custom".
In "Custom", input the desired symbol and it will become "paragraph symbol" and "newline symbol".

Note: 
1. Press the “Paragraph Symbol” of “Enter”. The default is “¶”.
2. Press 『Shift+Enter』 to change the line symbol. The default is ↵.
3. This design will make LibreOffice "personalized".

E.g:
Use "☺" as the "paragraph symbol".


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 00 2018-11-01 14:46:57 UTC
Created attachment 146227 [details]
1
Comment 2 Mike Kaganski 2018-11-01 14:55:44 UTC
What is the use case for such a fancy feature? what would be the benefit for how many users?

Clear WONTFIX imo.
Comment 3 00 2018-11-02 06:41:19 UTC
(In reply to Mike Kaganski from comment #2)
> What is the use case for such a fancy feature? 


The idea is to achieve "personalization."


what would be the benefit for
> how many users?


I think a lot of people need this feature, at least I need it.
Because the "¶" symbol is too ugly, this is the truth.
Comment 4 00 2018-11-02 06:52:25 UTC
Created attachment 146241 [details]
2
Comment 5 Mike Kaganski 2018-11-02 06:56:38 UTC
(In reply to 和尚蟹 from comment #3)
> I think a lot of people need this feature, at least I need it.
> Because the "¶" symbol is too ugly, this is the truth.

The Pilcrow sign [1] is the dedicated standard symbol for the purpose. It is simply wrong to use a different symbol (and to allow such usage) for some other symbol. Or, for the sake of "personalization", let's allow showing symbol "A" when there's a character "z" in the text.

Closing WONTFIX.

[1] https://en.wikipedia.org/wiki/Pilcrow
Comment 6 00 2018-11-02 07:31:44 UTC
(In reply to Mike Kaganski from comment #5)


> The Pilcrow sign [1] is the dedicated standard symbol for the purpose. It is
> simply wrong to use a different symbol (and to allow such usage) for some
> other symbol. Or, for the sake of "personalization", let's allow showing
> symbol "A" when there's a character "z" in the text.


1. No one stipulates that it must be done according to the regulations. The times will change. In the future, the "paragraph symbol" of "personalization" may also replace "¶".
2, the symbols you set yourself, you will remember, will not be mistaken.
Comment 7 00 2018-11-02 09:07:34 UTC
(In reply to Mike Kaganski from comment #5)


supplement
The "paragraph symbol" of Microsoft Office is not "¶".
Comment 8 Mike Kaganski 2018-11-02 09:12:55 UTC
Created attachment 146248 [details]
The "paragraph symbol" of Microsoft Office is ¶

(In reply to 和尚蟹 from comment #7)
Comment 9 00 2018-11-02 15:18:24 UTC
(In reply to Mike Kaganski from comment #8)


Sorry

Just checked, the new version of Microsoft Office has been changed to "¶".

It's ok
The mountain does not turn, the road turns.
The road does not turn, people turn.

Because I believe that you must be a good person, so give you 2 suggestions.
1, you can still provide this feature for everyone to use.
2. Make this function into an "expansion kit" for everyone to use.

Note: This program is very small, just write it, just fine.
Comment 10 00 2018-11-04 08:25:33 UTC
Created attachment 146278 [details]
The Microsoft Office 2019 paragraph symbol of the Traditional Chinese version is not ¶. (1)
Comment 11 00 2018-11-04 08:26:39 UTC
Created attachment 146279 [details]
The Microsoft Office 2019 paragraph symbol of the Traditional Chinese version is not ¶. (2)
Comment 12 00 2018-11-04 08:31:40 UTC
(In reply to Mike Kaganski from comment #8)



wrong.

I just installed the "Traditional Chinese version" of Office 2019, and found that Microsoft's "paragraph symbol" is not "¶".

This represents the practice of Microsoft's "paragraph symbol", which is different from "the east".

This may be because "¶" is a "Western" creation,
So only the "Western" uses "¶",
"Oriental" uses "↵".

It is currently possible to determine:
◎, the "paragraph symbol" of the "English version" is "¶".
◎, "The traditional Chinese version" of the "paragraph symbol" is "↵".

In this case, this is the suggestion is right.