Download it now!
Bug 121136 - No response from "Create Report in Design View"
Summary: No response from "Create Report in Design View"
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.1.2.1 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-03 02:01 UTC by dmneufeld
Modified: 2018-11-06 08:40 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dmneufeld 2018-11-03 02:01:44 UTC
Description:
When I click on "Create Report in Design View", nothing happens.

Steps to Reproduce:
1.Create a database.
2.Click on the "Reports" button.
3.Click on the "Create Report in Design View" button.

Actual Results:
Nothing at all happens.

Expected Results:
A report builder window should have opened.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.1.2.1
Build ID: 1:6.1.2~rc1-0ubuntu0.18.04.1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group threaded
Comment 1 Xisco Faulí 2018-11-03 13:33:26 UTC
Hello,
Thanks for reporting the issue.
Would you mind testing it with LibreOffice 6.1.3.2 from https://www.libreoffice.org/download/pre-releases/ ? This version is due to be release next week and contains many fixes related to the area affected in your bug...

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 2 dmneufeld 2018-11-03 15:43:56 UTC
I installed version 6.1.3.2 alongside my existing LO installation, but none of the modules (Writer, Base, etc.) will open. I click on their icons, and the only reaction is that I see a "wait" symbol for a few seconds, but nothing else happens.
Comment 3 Xisco Faulí 2018-11-05 13:17:08 UTC
Could you please run LibreOffice from command line like 'soffice --safe-mode' ?
Does it work that way ?
Comment 4 Alex Thurgood 2018-11-05 14:02:41 UTC
@dmneufeld : you did install the ubuntu provided report-builder and report-builder-bin  packages didn't you ?


By default, Ubuntu does not install these packages, even if you choose to install the LibreOffice Base package.

If this is the case with your setup, then this is NOTOURBUG.
Comment 5 Alex Thurgood 2018-11-05 14:05:23 UTC
@dmneufeld : you might also need to tell LibreOffice where your "Java Home" is to be found - this is an environment variable - I read recently that some installations of Ubuntu were not picking this up correctly and thus anything that required Java instantiation was failing. As the report-builder relies on Java to function, if a JVM can not be started then the report-builder will not start either.
Comment 6 dmneufeld 2018-11-05 15:35:32 UTC
Thank you @Xisco Fauli and @Alex Thrugood for some good suggestions. Moving a few states away this week will keep me from testing them out. When I am able I will keep working on this and report the results back here.

I asked for help, and got some other ideas here:
https://ask.libreoffice.org/en/question/170784/cannot-create-report-in-design-view/
Comment 7 dmneufeld 2018-11-05 20:21:32 UTC
(In reply to Alex Thurgood from comment #4)
> @dmneufeld : you did install the ubuntu provided report-builder and
> report-builder-bin  packages didn't you ?
> 
> 
> By default, Ubuntu does not install these packages, even if you choose to
> install the LibreOffice Base package.
> 
> If this is the case with your setup, then this is NOTOURBUG.

Bingo, this was the solution. The -bin package was installed, but the other one was not. Having both packages installed fixed the problem. So right, this is NOTOURBUG.
Comment 8 Xisco Faulí 2018-11-06 08:40:18 UTC
Glad you could fix it!! Closing as RESOLVED NOTABUG