Download it now!
Bug 121163 - Enhancement for Personas from Firefox on LibreOffice
Summary: Enhancement for Personas from Firefox on LibreOffice
Status: RESOLVED DUPLICATE of bug 120406
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-04 17:16 UTC by Leandro Martín Drudi
Modified: 2018-11-08 23:49 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Themes preinstaled and favorites (46.40 KB, image/png)
2018-11-04 17:33 UTC, Leandro Martín Drudi
Details
Checkboxes to select the favorites (12.24 KB, image/png)
2018-11-04 17:38 UTC, Leandro Martín Drudi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Leandro Martín Drudi 2018-11-04 17:16:25 UTC
Description:
[ES]
Hola! He leído en un grupo de Telegram sobre LibreOffice en español que se ha integrado una importante mejora en la venidera 6.2. Tengo entendido que se podrán usar al menos 6 temas preinstalados.
Ahora, mi sugerencia para esa nueva característica es que el usuario pueda seleccionar 3 o 6 temas de su agrado para ponerlos como "preinstalados" y poder tener acceso a ellos estando offile. Y siempre poder restablecer los temas preinstalados con un botón.

[EN]
Hello! I have read in a Telegram group about LibreOffice in Spanish that an important improvement has been integrated in the coming 6.2. I understand that at least 6 pre-installed themes can be used.
Now, my suggestion for this new feature is that the user can select 3 or 6 themes of his liking to put them as "pre-installed" and be able to access them while being offile. And always be able to reset the pre-installed themes with a button.

Steps to Reproduce:
1. Clic Tools|Options|Personalize
2. Click on "Select theme"
3. Find a theme.
4. Click an Checkbox in a favorithe result to add to Preinstaled theme.

-Later-
1. Clic Tools|Options|Personalize
2. Click on the preinstaled theme selected by the user and apply them.


Actual Results:
You should always look for your favorite topic and be online to apply it.

Expected Results:
Have favorite themes always accessible, even when offline.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Comment 1 Leandro Martín Drudi 2018-11-04 17:33:49 UTC
Created attachment 146300 [details]
Themes preinstaled and favorites
Comment 2 Leandro Martín Drudi 2018-11-04 17:38:39 UTC
Created attachment 146301 [details]
Checkboxes to select the favorites

You can select 3 themes. During the selection:
1) The checkboxes with result will be enabled.
2) The checkboxes will remain enabled until 3 is selected.
3) Those that are not selected when selecting the 3 will be deactivated. They will be enabled again when there is at least 1 to be selected (removing the selection to one of those already selected, for example).

If the user simply wants to use a theme without adding it to a favorite, he selects it without activating the corresponding checkbox. Both actions apply and add the theme.

NOTE: TEH CAPTURES WAS EDITED IN PAINT, IS NOT A WORK IN PROGRESS ;)
Comment 3 Heiko Tietze 2018-11-08 15:38:09 UTC
I'm against this special solution. Rather you download an extension containing Personas and install that locally (bug 120406). I resolve the request respectively, feel free to reopen if you disagree.

*** This bug has been marked as a duplicate of bug 120406 ***
Comment 4 Leandro Martín Drudi 2018-11-08 18:40:02 UTC
(In reply to Heiko Tietze from comment #3)
> I'm against this special solution. Rather you download an extension
> containing Personas and install that locally (bug 120406). I resolve the
> request respectively, feel free to reopen if you disagree.
> 
> *** This bug has been marked as a duplicate of bug 120406 ***

[ES]
Soy un simple usuario: nada de lo que he visto en lo que has pasado me ha ayudado ni sirve para el 99% de las personas que usarían LibreOffice. ¿Extensión? NO he encontrado ninguna extensión, solo interminables lineas de código que no tienen ningún significado ni sé cómo diablos usarlas. NO SOY PROGRAMADOR ¡SOY USUARIO!
No entiendo qué pasó por tu cabeza al creer que el mundo entero tiene tu nivel de conocimiento. Considero tu respuesta una ofensa contra mi persona y que me desprecias (y nos desprecias a todos los usuarios) considerándonos que podemos resolver estas cosas por nuestra propia cuenta.
Por cuestiones como esta y la poca importancia que demuestran en el trato con el usuario final, dejé de hacer donaciones económicas. Creo que ahora dejaré de hacer aportes a soluciones. Y consideraré dejar de usar LibreOffice y no lo recomendaré a otras personas. Ya he quitado el vínculo a LibreOffice en mi página. Estas cosas son las que hacen que el mundo se aleje del software de código abierto. Linux no tiene éxito porque los que podríamos usarlo NO LO ENTENDEMOS. Pero los expertos se ríen de uno cuando hace preguntas básicas.
¿De verdad que no consideran algo así cuando lo están planteando desde la versión 4.0.0.3?
Volveré a abrirlo. Si recibo nuevamente una respuesta similar, sin siquiera tomarse la molestia de discutir la posibilidad de implementarlo, haré efectivo mi retiro del uso y apoyo a LibreOffice de forma definitiva.
Esta respuesta no la considero válida cuando no ha llegado a NADIE.

[EN]
I'm a simple user: nothing I've seen in what you've been through has helped me or serves 99% of the people who would use LibreOffice. Extension? I have not found any extension, only endless lines of code that have no meaning or know how the hell to use them. I AM NOT A PROGRAMMER I AM A USER!
I do not understand what went through your head to believe that the whole world has your level of knowledge. I consider your response an offense against me and that you despise me (and you despise all users) considering that we can resolve these things on our own.
For issues like this and the little importance they show in dealing with the end user, I stopped making financial donations. I think that now I will stop making contributions to solutions. And I will consider stopping using LibreOffice and I will not recommend it to other people. I have already removed the link to LibreOffice on my page. These things are what make the world move away from open source software. Linux is not successful because those of us who could use it DO NOT UNDERSTAND IT. But experts laugh at you when you ask basic questions.
Do not really consider something like this when they are considering it from version 4.0.0.3?
I will open it again. If I receive a similar response again, without even bothering to discuss the possibility of implementing it, I will make my withdrawal of the use and support of LibreOffice definitively effective.
I do not consider this answer valid when it has not reached ANYONE.
Comment 5 Heiko Tietze 2018-11-08 21:17:27 UTC
Usually I do not reply on accusations like this but lets have an exception.

First of all being upset is okay. But in case you want people to handle your input it's recommended to put things into a question. That could have been "I don't understand how I can use extensions to install Personas". My reply would be to read the referenced bug where the idea is outlined: We should extend LibreOffice by the ability to load Personas as extensions. You can find those extensions today at https://extensions.libreoffice.org/ (admittedly not the perfect page but we are working on alternatives); of course not yet with Personas. Extensions are installed locally and do not require a special solution that involves downloading something from Mozilla's Persona page and storing it at the right place locally. It could even be integrated at the dialog which would be more or less what you ask for.

My input comes from the user perspective, always striving for simplicity. There are for sure a good number of users that share your wish to customize the UI. But the more options and special solutions we implement the less easy to use becomes the application. That's why not all requests are accepted.

As an open source project you are part of the game. Feel free to object, to share, and to make noise. I do not close reopened tickets and if you find someone who implements your ideas it's your right - and our goal. At the same time you should also be able to use any application you like with your documents. That's the freedom of open source. And you can also run Microsoft products. They do really great IMHO. But try to ask for a feature there...
Comment 6 Leandro Martín Drudi 2018-11-08 23:49:38 UTC
(In reply to Heiko Tietze from comment #5)
> Usually I do not reply on accusations like this but lets have an exception.
> 
> First of all being upset is okay. But in case you want people to handle your
> input it's recommended to put things into a question. That could have been
> "I don't understand how I can use extensions to install Personas". My reply
> would be to read the referenced bug where the idea is outlined: We should
> extend LibreOffice by the ability to load Personas as extensions. You can
> find those extensions today at https://extensions.libreoffice.org/
> (admittedly not the perfect page but we are working on alternatives); of
> course not yet with Personas. Extensions are installed locally and do not
> require a special solution that involves downloading something from
> Mozilla's Persona page and storing it at the right place locally. It could
> even be integrated at the dialog which would be more or less what you ask
> for.
> 
> My input comes from the user perspective, always striving for simplicity.
> There are for sure a good number of users that share your wish to customize
> the UI. But the more options and special solutions we implement the less
> easy to use becomes the application. That's why not all requests are
> accepted.
> 
> As an open source project you are part of the game. Feel free to object, to
> share, and to make noise. I do not close reopened tickets and if you find
> someone who implements your ideas it's your right - and our goal. At the
> same time you should also be able to use any application you like with your
> documents. That's the freedom of open source. And you can also run Microsoft
> products. They do really great IMHO. But try to ask for a feature there...

First of all, I would like to apologize if I somehow offended you. He was very angry. I understand that achieving these improvements is not blowing and making a bottle, but the truth is that I feel that they cared little and nothing about my proposal, that they did not even take the trouble to analyze it and they already had the "NO" at the beginning.
Apart from this, I insist, I believe that some ways of doing things in LibreOffice distances potential users. Although the objective is not to cover a market, but only I know LibreOffice in a company with about 7000 employees, it is sad. LibreOffice must be aggiornarse to the new market. You can not stay in the Windows 98 interface, with outdated policies; there is already an interface change; A step has already been taken. But that is not enough. I want to see LibreOffice doing TV advertising or when I go to work all the machines have LibO installed.
I work in a company where during the more than 20 years that it has in the market, the client cared little and nothing. To the point that there were claims of technical failures with 7 years old. Now a larger company bought it and dissolved it because repairing the damage done to its image was impossible. Not even with the good image of the buyer.
To what I am going, the user is the one who makes LibreOffice, to a greater extent. He is the one who recommends, contributes, uses.