Bug 121176 - Docx with Track changes enabled show removed fragment as present
Summary: Docx with Track changes enabled show removed fragment as present
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: László Németh
URL:
Whiteboard: target:6.3.0
Keywords:
Depends on: 116084
Blocks: DOCX-Track-Changes
  Show dependency treegraph
 
Reported: 2018-11-05 14:29 UTC by Tadas Balaišis
Modified: 2019-07-21 04:40 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
The changes are near "8." article. Just check this part in Writer and other mentioned soft. (67.33 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-11-05 15:20 UTC, Tadas Balaišis
Details
Comparison LibreOffice 6.2 Master and MSO 2010 (146.67 KB, image/png)
2018-11-05 16:51 UTC, Xisco Faulí
Details
MS Word Viewer (582.82 KB, image/jpeg)
2018-11-05 17:38 UTC, Tadas Balaišis
Details
LibreOffice Writer (647.95 KB, image/jpeg)
2018-11-05 17:39 UTC, Tadas Balaišis
Details
What I can see in LO (130.28 KB, image/png)
2018-11-05 17:48 UTC, Alex
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tadas Balaišis 2018-11-05 14:29:05 UTC
Description:
I've received docx file, edited by other people in MS Office. I can see in MS Word Viewer or Google Documents that specific text fragment is removed. But in LibreOffice it shows as not removed. Also in Print Preview.

Steps to Reproduce:
1. In MS Office Track changes for the document were enabled.
2. Some text fragment was added by the first user using MS Word.
3. The same text fragment was removed by another user using MS Word.


Actual Results:
The final document, opened in LibreOffice, shows old "Step2" text.

Expected Results:
No text fragment as it was done in "Step3".


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Tadas Balaišis 2018-11-05 14:38:22 UTC
The error was detected in LibreOffice 6.1.2.1. Then I installed 6.2 alpha1 and it is reproducible in it either.
Comment 2 Xisco Faulí 2018-11-05 15:01:55 UTC
Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
Comment 3 Tadas Balaišis 2018-11-05 15:20:58 UTC
Created attachment 146317 [details]
The changes are near "8." article. Just check this part in Writer and other mentioned soft.
Comment 4 Xisco Faulí 2018-11-05 16:51:12 UTC
Created attachment 146320 [details]
Comparison LibreOffice 6.2 Master and MSO 2010

I don't see any difference between LibreOffice 6.2 Master and MSO 2010.
Could you please indicate where the problem is ?
Comment 5 Tadas Balaišis 2018-11-05 17:38:42 UTC
Created attachment 146321 [details]
MS Word Viewer
Comment 6 Tadas Balaišis 2018-11-05 17:39:10 UTC
Created attachment 146322 [details]
LibreOffice Writer
Comment 7 Alex 2018-11-05 17:48:11 UTC
Created attachment 146324 [details]
What I can see in LO

I can see the text in the document that is highlighted in the attachment. I'm a little confused, but I think that means I can replicate. (screenshot attached)

Version: 6.1.3.2 (x64)
Build ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
Locale: en-GB (en_GB); Calc: CL
Comment 8 Tadas Balaišis 2018-11-05 18:27:14 UTC
That's right. I see the same. My previous picture in LO was done after I unckecked Edit\Track Changes\Show. Just tried to show final look. The point is that in final  edition third cell in "8." row should had be empty. And LO shows those names, which is the fragment I mentioned. It should be invisible in the final edition view.
Comment 9 Dieter 2018-11-05 19:15:37 UTC
I could also reproduce with

Version: 6.2.0.0.alpha1+ (x64)
Build ID: 8274c4c62df5b937b3f0bec9e1eeca85f3b219d4
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-10-22_01:47:50
Locale: en-US (de_DE); Calc: CL
Comment 10 Xisco Faulí 2018-11-06 09:30:40 UTC
I see the problem now. I can reproduce it in

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.10; Render: default; 

Version: 5.0.0.0.alpha1+
Build ID: 0db96caf0fcce09b87621c11b584a6d81cc7df86
Locale: ca-ES (ca_ES.UTF-8)

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 11 Tadas Balaišis 2018-11-21 07:12:27 UTC
Any progress?
Comment 12 Gabor Kelemen 2018-11-28 09:28:30 UTC
Opening the file in Word I see the setting for removing document properties and personal settings is on.
This is the same problem as bug #116084

*** This bug has been marked as a duplicate of bug 116084 ***
Comment 13 László Németh 2019-03-02 13:48:22 UTC
Not exactly the same as bug 116084 (it needs a new/extended fix and unit test for this case).
Comment 14 László Németh 2019-03-05 21:05:38 UTC
Proposed fix: https://gerrit.libreoffice.org/#/c/68779/
Comment 15 Commit Notification 2019-03-06 16:22:31 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/df4f405a153603551f67e289bbaccf9ac39b923c%5E%21

tdf#121176 DOCX track changes: same size w:del in w:ins

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Dieter 2019-07-21 04:40:14 UTC
Verified with

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 2f2f4767089512c34514896bc37823f9310e9dd4
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-07-10_02:13:57
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded

László Németh, thanks for fixing!