Bug 121186 - A section has white background, but reports as having no fill in a specific document
Summary: A section has white background, but reports as having no fill in a specific d...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.5.0 target:6.4.0.1
Keywords:
Depends on:
Blocks: Section
  Show dependency treegraph
 
Reported: 2018-11-06 06:42 UTC by Mike Kaganski
Modified: 2019-11-20 11:28 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A document with a section with white background (32.60 KB, application/vnd.oasis.opendocument.text)
2018-11-06 06:42 UTC, Mike Kaganski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2018-11-06 06:42:55 UTC
Created attachment 146333 [details]
A document with a section with white background

Original report: https://ask.libreoffice.org/en/question/171381/what-controls-white-background-of-writer-document/

In the attached document, the text has white background (apparent when Options→LibreOffice→Application Colors→Document background is set to non-white). There are three nested sections; and upon inspection, all of them show that there is no area fill in them. But setting the innermost section's ("mv-content-text") area to some solid color, applying the change, then setting it back to None makes the background transparent; so obviously, there *is* some color set in the section's background.

The bug is, therefore, incorrect display of actual background setting.
Comment 1 Thomas Lendo 2018-11-15 22:54:32 UTC
Confirmed in the attached document with Version: 6.2.0.0.alpha1+
Build ID: 20b2903354138f8ab19261fab74658fcf6af70e3
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: de-DE (de_DE.UTF-8); UI-Language: en-US
from yesterday

But I couldn't reproduce with a new document. Setting meanwhile to NEW.
Comment 2 QA Administrators 2019-11-17 03:32:00 UTC Comment hidden (obsolete)
Comment 3 Mike Kaganski 2019-11-17 08:25:06 UTC
Still repro with Version: 6.3.3.2 (x64)
Build ID: a64200df03143b798afd1ec74a12ab50359878ed
CPU threads: 12; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 4 Commit Notification 2019-11-19 19:37:54 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/8586051f02125e7358984d2cd14c5383b26bd246

tdf#121186: sync itemset and supportsFullDrawingLayerFillAttributeSet

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2019-11-20 11:28:20 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/584cbb64ac1d3ed6db5531159cd8057a345cfb1e

tdf#121186: sync itemset and supportsFullDrawingLayerFillAttributeSet

It will be available in 6.4.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.