Bug 121191 - View PDF after export doesn't work if to perform File -> Export...
Summary: View PDF after export doesn't work if to perform File -> Export...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All Linux (All)
: medium normal
Assignee: Pierre Marty
URL:
Whiteboard: target:7.1.0 target:7.0.1
Keywords:
: 130175 (view as bug list)
Depends on: 130175
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2018-11-06 08:34 UTC by Vera Blagoveschenskaya
Modified: 2020-07-21 14:49 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
video.mkv (1.60 MB, video/x-matroska)
2018-11-06 08:35 UTC, Vera Blagoveschenskaya
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vera Blagoveschenskaya 2018-11-06 08:34:58 UTC
Description:
View PDF after export doesn't work if to perform File -> Export...

Steps to Reproduce:
1. Create some .ods or .odt test document, write 'test'
2. File -> Export ... Select .pdf 
3. Mark the checkbox 'View PDF after export', then push button 'Export'

Actual Results:
No PDF viewer starts (but I have installed PDF viewer).

Bug is NOT reproduced if to select File -> Export to PDF

See video in the attachment.

Expected Results:
PDF viewer starts after export


Reproducible: Always


User Profile Reset: No



Additional Info:
Reproduced for

Version: 6.2.0.0.alpha1+
Build ID: 7cf6cee97bc05512fae482733ee45f039e9d2160
CPU threads: 1; OS: Linux 4.14; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-11-04_22:10:34
Locale: ru-RU (ru_RU.UTF-8); Calc: threaded

Reproduced for

Version: 6.2.0.0.alpha1+
Build ID: 7cf6cee97bc05512fae482733ee45f039e9d2160
CPU threads: 1; OS: Linux 4.14; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-11-04_22:10:34
Locale: ru-RU (ru_RU.UTF-8); Calc: threaded
Comment 1 Vera Blagoveschenskaya 2018-11-06 08:35:32 UTC
Created attachment 146338 [details]
video.mkv
Comment 2 Xisco Faulí 2018-11-06 09:17:25 UTC
Reproduced in

Version: 6.2.0.0.alpha1+
Build ID: b0da1ca2d7a426ff13f39b21362fbcd5c0580c24
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.10; Render: default; 

Version: 5.0.0.0.alpha1+
Build ID: 0db96caf0fcce09b87621c11b584a6d81cc7df86
Locale: ca-ES (ca_ES.UTF-8)

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e
Comment 3 QA Administrators 2019-11-07 03:34:33 UTC Comment hidden (obsolete)
Comment 4 Vera Blagoveschenskaya 2019-12-17 08:45:13 UTC
Hello, I've recheck this bug for 

Version: 6.5.0.0.alpha0+
Build ID: 3e33a11d8a553a99bd5f23940a65c301924198fb
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kf5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-12-16_11:03:40
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

Issue is still reproducible.
Comment 5 Jean-Sebastien Bevilacqua 2020-01-24 15:25:46 UTC
*** Bug 130175 has been marked as a duplicate of this bug. ***
Comment 6 Pierre Marty 2020-04-29 08:27:53 UTC
I found a patch for this issue.

It can be reviewed here:
https://gerrit.libreoffice.org/c/core/+/92715
Comment 7 Commit Notification 2020-07-21 11:33:43 UTC
Pierre MARTY committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/fef72302dac39674103c8cf66f1a5e27b9f3d7ab

tdf#121191 Fix PDF viewer after "Export..."

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2020-07-21 13:05:45 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6592afdd7d6e8a56e1450131a2d0a2b652eb6f82

Related: tdf#121191 check what filter was used for export

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Caolán McNamara 2020-07-21 13:06:25 UTC
a combined backport to 7-0 as https://gerrit.libreoffice.org/c/core/+/99143
Comment 10 Commit Notification 2020-07-21 14:49:01 UTC
Pierre MARTY committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/68880474423c4e2b22cdc2a25b64750863a9023f

tdf#121191 Fix PDF viewer after "Export..."

It will be available in 7.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.