Download it now!
Bug 121195 - KDE5: Edit filename for existing LO document -> icon changes to 'blank'
Summary: KDE5: Edit filename for existing LO document -> icon changes to 'blank'
Status: VERIFIED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha1+
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2018-11-06 09:26 UTC by Vera Blagoveschenskaya
Modified: 2018-11-07 13:29 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
video (1.46 MB, video/x-matroska)
2018-11-06 09:27 UTC, Vera Blagoveschenskaya
Details
kde5 view (81.77 KB, image/png)
2018-11-06 09:28 UTC, Vera Blagoveschenskaya
Details
kde4-view (77.06 KB, image/png)
2018-11-06 09:28 UTC, Vera Blagoveschenskaya
Details
new video (1.42 MB, video/x-matroska)
2018-11-07 13:04 UTC, Vera Blagoveschenskaya
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vera Blagoveschenskaya 2018-11-06 09:26:11 UTC
Description:
Edit filename for existing LO document -> icon changes to 'blank'

Steps to Reproduce:
1. Create some LO document, for example, .odt
2. File -> Save as, push cursor to some existing .odt document test.odt
3. Edit filename ('test' -> 'test123'), do not change extension '.odt'

Actual Results:
Icon near filename changes to 'blank'. See screenshot and video.

Expected Results:
Icon shouldn't be changed


Reproducible: Always


User Profile Reset: No



Additional Info:
Reproduced for kde5

Version: 6.2.0.0.alpha1+
Build ID: 7cf6cee97bc05512fae482733ee45f039e9d2160
CPU threads: 1; OS: Linux 4.14; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-11-04_22:10:34
Locale: ru-RU (ru_RU.UTF-8); Calc: threaded

DO NOT reproduced for kde4

Version: 6.2.0.0.alpha1+
Build ID: 7cf6cee97bc05512fae482733ee45f039e9d2160
CPU threads: 1; OS: Linux 4.14; UI render: default; VCL: kde4; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-11-04_22:10:34
Locale: ru-RU (ru_RU.UTF-8); Calc: threaded
Comment 1 Vera Blagoveschenskaya 2018-11-06 09:27:43 UTC
Created attachment 146342 [details]
video
Comment 2 Vera Blagoveschenskaya 2018-11-06 09:28:08 UTC
Created attachment 146343 [details]
kde5 view
Comment 3 Vera Blagoveschenskaya 2018-11-06 09:28:31 UTC
Created attachment 146344 [details]
kde4-view
Comment 4 Xisco Faulí 2018-11-07 12:38:09 UTC
I can't reproduce it in

Version: 6.2.0.0.alpha1+
Build ID: bc42b6bfa49cc2b58201a8f6177dd3b1a0c038d8
CPU threads: 1; OS: Linux 4.15; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-11-06_19:01:37
Locale: en-US (en_US.UTF-8); Calc: threaded

on Kubuntu 18.04.01 with Plasma 5.12.6.

Which plasma version do you use ?
Comment 5 Xisco Faulí 2018-11-07 12:38:38 UTC
OTOH, do you reproduce it with another application?
Comment 6 Vera Blagoveschenskaya 2018-11-07 13:04:23 UTC
(In reply to Xisco Faulí from comment #4)

> Which plasma version do you use ?

KDE Plasma 5.12.7

(In reply to Xisco Faulí from comment #5)
> OTOH, do you reproduce it with another application?

I tried with Writer, Calc, Impress - the same situation.
Please look at the new video - in the attachment.
Comment 7 Vera Blagoveschenskaya 2018-11-07 13:04:47 UTC
Created attachment 146394 [details]
new video
Comment 8 Xisco Faulí 2018-11-07 13:11:58 UTC
(In reply to Xisco Faulí from comment #5)
> OTOH, do you reproduce it with another application?

I mean another app different from LibreOffice
Comment 9 Vera Blagoveschenskaya 2018-11-07 13:29:30 UTC
(In reply to Xisco Faulí from comment #8)
> (In reply to Xisco Faulí from comment #5)
> > OTOH, do you reproduce it with another application?
> 
> I mean another app different from LibreOffice

I see. Tried with KWrite, the same situation.