Bug 121266 - KDE5: Impress crashes after selecting some of Slide Transitions
Summary: KDE5: Impress crashes after selecting some of Slide Transitions
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha1+
Hardware: All Linux (All)
: high major
Assignee: Aleksei Nikiforov
URL:
Whiteboard: target:6.3.0 target:6.2.0.1
Keywords:
: 122195 (view as bug list)
Depends on:
Blocks: KDE Slide-Transitions
  Show dependency treegraph
 
Reported: 2018-11-08 09:50 UTC by Vera Blagoveschenskaya
Modified: 2018-12-21 13:03 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
gdbtrace.log (116.82 KB, text/x-log)
2018-11-08 09:51 UTC, Vera Blagoveschenskaya
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vera Blagoveschenskaya 2018-11-08 09:50:06 UTC
Description:
Impress crashes after selecting some of Slide Transitions

Steps to Reproduce:
1. Create new Impress presentation
2. Slide -> Slide Transition
3. Select Fade

Actual Results:
Application crashes

Expected Results:
No crash


Reproducible: Always


User Profile Reset: No



Additional Info:
The same crash if to select any transition from Tiles to the end of the list

Also SEE 
https://bugs.documentfoundation.org/show_bug.cgi?id=91456

Reproduced for 
Version: 6.2.0.0.alpha1+
Build ID: bc42b6bfa49cc2b58201a8f6177dd3b1a0c038d8
CPU threads: 4; OS: Linux 4.14; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-11-06_19:01:37
Locale: ru-RU (ru_RU.UTF-8); Calc: threaded

DO NOT reproduced for 

Version: 6.2.0.0.alpha1+
Build ID: bc42b6bfa49cc2b58201a8f6177dd3b1a0c038d8
CPU threads: 4; OS: Linux 4.14; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-11-06_19:01:37
Locale: ru-RU (ru_RU.UTF-8); Calc: threaded

DO NOT reproduced for 

Version: 6.1.2.1
Build ID: 65905a128db06ba48db947242809d14d3f9a93fe
CPU threads: 4; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: ru-RU (ru_RU.UTF-8); Calc: group threaded
Comment 1 Vera Blagoveschenskaya 2018-11-08 09:51:26 UTC
Created attachment 146426 [details]
gdbtrace.log
Comment 2 Xisco Faulí 2018-11-08 09:58:53 UTC
I can reproduce it in

Version: 6.2.0.0.alpha1+
Build ID: bc42b6bfa49cc2b58201a8f6177dd3b1a0c038d8
CPU threads: 1; OS: Linux 4.15; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time:
2018-11-06_19:01:37
Locale: en-US (en_US.UTF-8); Calc: threaded

but not in

Version: 6.2.0.0.alpha1+
Build ID: bc42b6bfa49cc2b58201a8f6177dd3b1a0c038d8
CPU threads: 1; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time:
2018-11-06_19:01:37
Locale: en-US (en_US.UTF-8); Calc: threaded
Comment 3 Xisco Faulí 2018-11-08 09:59:43 UTC
Not happening with other transitions like Wheel, Wipe or Uncover...
Comment 4 Xisco Faulí 2018-11-19 12:27:07 UTC
Still reproduced in

Version: 6.2.0.0.beta1
Build ID: d1b41307be3f8c19fe6f1938cf056e7ff1eb1d18
CPU threads: 1; OS: Linux 4.15; UI render: default; VCL: kde5; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 5 Commit Notification 2018-12-19 06:21:04 UTC
Aleksei Nikiforov committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/56b19f9a814ae5a39ed760ee542d715493cd0bf3%5E%21

tdf#121247, tdf#121266 KDE5: Add basic support for OpenGL

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2018-12-19 07:43:17 UTC
Aleksei Nikiforov committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/d51452fc4f15f956dde32cb2cc3e118473f4f23a%5E%21

tdf#121247, tdf#121266 KDE5: Add basic support for OpenGL

It will be available in 6.2.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 gepardo 2018-12-19 13:31:20 UTC
*** Bug 122195 has been marked as a duplicate of this bug. ***
Comment 8 Michael Weghorn 2018-12-19 17:08:40 UTC
Fix verified with

Version: 6.3.0.0.alpha0+
Build ID: b5e86ee88e38ea8e2e454adf3ab3007195c6d6bf
CPU threads: 4; OS: Linux 4.18; UI render: default; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded
Comment 9 Xisco Faulí 2018-12-21 13:03:30 UTC
Verified in

Version: 6.2.0.1
Build ID: 0412ee99e862f384c1106d0841a950c4cfaa9df1
CPU threads: 1; OS: Linux 4.15; UI render: default; VCL: kde5; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded