Download it now!
Bug 121276 - KDE5: Can't save minimized presentation
Summary: KDE5: Can't save minimized presentation
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha1+
Hardware: All Linux (All)
: medium normal
Assignee: Michael Weghorn
URL:
Whiteboard: target:6.2.0 target:6.1.4
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2018-11-08 15:08 UTC by Vera Blagoveschenskaya
Modified: 2018-12-04 07:48 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screen (175.20 KB, image/png)
2018-11-08 15:09 UTC, Vera Blagoveschenskaya
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vera Blagoveschenskaya 2018-11-08 15:08:48 UTC
Description:
Can't save minimized presentation 

Steps to Reproduce:
1. Open some .odp file
2. Tools -> Minimize Presentation
3. Go through Presentation Minimizer Wizard with default settings -> Finish
4. Enter name for minimized presentation and click Save

Actual Results:
Warning appears The file <> couldn't be found (???)

See screen

Expected Results:
Normal saving


Reproducible: Always


User Profile Reset: No



Additional Info:
Reproduced for 

Version: 6.2.0.0.alpha1+
Build ID: bc42b6bfa49cc2b58201a8f6177dd3b1a0c038d8
CPU threads: 4; OS: Linux 4.14; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-11-06_19:01:37
Locale: ru-RU (ru_RU.UTF-8); Calc: threaded


DO NOT reproduced for

Version: 6.2.0.0.alpha1+
Build ID: bc42b6bfa49cc2b58201a8f6177dd3b1a0c038d8
CPU threads: 4; OS: Linux 4.14; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-11-06_19:01:37
Locale: ru-RU (ru_RU.UTF-8); Calc: threaded

FOR kde4 crash appears - https://bugs.documentfoundation.org/show_bug.cgi?id=117466
Comment 1 Vera Blagoveschenskaya 2018-11-08 15:09:18 UTC
Created attachment 146444 [details]
screen
Comment 2 Michael Weghorn 2018-11-08 21:16:03 UTC
Reproduced with

Version: 6.2.0.0.alpha1+
Build ID: 2c614b4b2537997aece7ba0aa7ecd38e55fcffaa
CPU threads: 4; OS: Linux 4.18; UI render: default; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

Not reproducible when using the gtk3 VCL plugin.
Comment 3 Michael Weghorn 2018-11-08 23:00:56 UTC
Gerrit change to address the problem explicitly described here (cannot select a new file in the file picker): https://gerrit.libreoffice.org/#/c/63142/

However, this does not yet make all of the use case of using the presentation minimizer work yet. For me, LibreOffice freezes most of the times once the optimization has been done.
I've created a separate bug report for this, since the underlying issue is another one: bug 121293
Comment 4 Commit Notification 2018-11-09 09:13:40 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/c0f45c89063fa5c4334ff9e624d24d48638ffb4d%5E%21

tdf#121276 kde5: Don't prevent creating new files

It will be available in 6.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2018-11-09 14:48:18 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/a6318cb430fd8f90b760f7dc36f4eacd3904e22e%5E%21

tdf#121276 gtk3_kde5: Don't prevent creating new files

It will be available in 6.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2018-11-12 12:10:16 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/bedd49e6b40c1a51459f9a0dfa0c0ed0d0b8ae2e%5E%21

tdf#121276 gtk3_kde5: Don't prevent creating new files

It will be available in 6.1.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 andreas.sturmlechner 2018-11-13 16:33:43 UTC
I applied this patch over 6.1.3.2 and lo_kde5filepicker is crashing since then whenever it is finished (OK, cancel does not matter).
Comment 8 Michael Weghorn 2018-11-13 17:00:52 UTC
(In reply to andreas.sturmlechner from comment #7)
> I applied this patch over 6.1.3.2 and lo_kde5filepicker is crashing since
> then whenever it is finished (OK, cancel does not matter).

What happened without the patch applied?
For me, LibreOffice also crashes when using the presentation minimizer with the gtk3_kde5 VCL plugin, but this is independent of that patch (it already happens without the patch).

Can you please open a separate bug report and mention it here if the behaviour is the same for you?
Comment 9 andreas.sturmlechner 2018-11-13 18:03:28 UTC
Yes, seems like that particular commit is not the culprit. This crash is not limited to Impress in particular, it happens all the time in Writer and Calc. Will look into it more.
Comment 10 Michael Weghorn 2018-11-13 19:27:53 UTC
(In reply to andreas.sturmlechner from comment #9)
> Yes, seems like that particular commit is not the culprit. This crash is not
> limited to Impress in particular, it happens all the time in Writer and
> Calc. Will look into it more.

Thanks for testing.

Your problem seems to be different from what I get. The "normal" save dialog (e.g. "File" -> "Save As") works fine for me. Since you wrote that you were using version 6.1.3.2, and added the patch on top, it would be helpful if you could do a test with the current git master branch or branch "libreoffice-6-1", since these contain more fixes for the file dialog in gtk3_kde5. (You can either build them yourself or download daily builds from https://dev-builds.libreoffice.org/daily/ .

Anyway, I'd suggest to continue the discussion in the new bug report then. Please feel free to add me in "CC" (or I'll do so my self if you mention it here).
Comment 11 Michael Weghorn 2018-11-13 22:08:22 UTC
(In reply to Michael Weghorn from comment #10)
> [...]
> Anyway, I'd suggest to continue the discussion in the new bug report then.
> Please feel free to add me in "CC" (or I'll do so my self if you mention it
> here).

Bug 121399 has been created for this.
Comment 12 Vera Blagoveschenskaya 2018-11-14 13:52:44 UTC
Mickael, thank you for the fix!

I've checked it with the latest build --> Not reproduced

Version: 6.2.0.0.alpha1+
Build ID: 85dba18a3d3644a4ac49bd32ea106a4d69159fb4
CPU threads: 1; OS: Linux 4.14; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-11-13_23:14:30
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded
Comment 13 Michael Weghorn 2018-12-04 07:48:54 UTC
(In reply to Michael Weghorn from comment #8)
> For me, LibreOffice also crashes when using the presentation minimizer with
> the gtk3_kde5 VCL plugin, but this is independent of that patch (it already
> happens without the patch).

For the record: I've created bug 121892 for this.