Download it now!
Bug 121289 - Enhancement for Themes from Firefox on LibreOffice
Summary: Enhancement for Themes from Firefox on LibreOffice
Status: RESOLVED DUPLICATE of bug 61311
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Firefox-Themes
  Show dependency treegraph
 
Reported: 2018-11-08 19:14 UTC by Leandro Martín Drudi
Modified: 2019-01-16 07:35 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Themes preinstalled and the favorites of the user. (48.69 KB, image/png)
2018-11-08 19:15 UTC, Leandro Martín Drudi
Details
Interface with checkboxes to select the theme to add favorites (18.71 KB, image/png)
2018-11-08 19:18 UTC, Leandro Martín Drudi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Leandro Martín Drudi 2018-11-08 19:14:01 UTC
Description:
[ES]
Actualmente el uso de temas en LibreOffice es bastante malo (por no decir extremadamente ineficiente y malfuncional).
Considerando que muchas veces tenemos temas que nos gustan y encontrarlos es un problema por las frecuentes fallas, pronponto que el usuario pueda tener temas favoritos accesibles todo el tiempo mediante la selección de algunos temas que le interese y que queden "guardados" para su posterior reutilización.

[EN]
Currently the use of themes in LibreOffice is quite bad (not to say extremely inefficient and malfunctional).
Considering that many times we have topics that we like and find them is a problem due to frequent failures, I predict that the user can have favorite themes accessible all the time by selecting some topics that interest him and that are "saved" for later reuse .

Steps to Reproduce:
1. Clic Tools|Options|Personalize
2. Click on the "Find theme".
3. Find a theme.
4. Cross your fingers so there are no problems
5. Wait too long for the expected result to appear (and many times it requires you to paste a URL that returns an error, or it never brings the result you expect)
6. Select the theme you want.
7. Clic Acept two times.

Actual Results:
You should always look for your favorite topic and be online to apply it and pray that there will not be a problem.

Expected Results:
1. Clic Tools|Options|Personalize
2. Click on "Select theme"
3. Find a theme (that does not always work).
4. Click an Checkbox in a favorite result to add the theme.


Reproducible: Always


User Profile Reset: No



Additional Info:
[ES]
Beneficios:
-> El usuario tendrá a mano siempre sus temas favoritos.
-> Si el usuario decide cambiar alguno, podrá eliminar de los que seleccionó o reemplazarlos.
-> No deberá estar online para poder aplicarlo.
-> Si hay problemas para encontrar temas por otro fallo, siempre tendrá sus favoritos al alcance de su mano.
-> Siempre podrá seleccionar un tema y otros 3 (1 seleccionándolo de la forma tradicional para aplicarlo inmediatamente + 3 favoritos)
-> Más posibilidades de que LibreOffice sea personal, le pertenezca al usuario y esté exactamente como lo quiere.

Espero que esto se tome con la seriedad que se requiere y no que una sola persona decida por encima de los usuarios.
Una empresa que no escucha a sus clientes (usuarios para este caso), es una empresa condenada a la mediocridad o a que caiga (o permanezca) en el anonimato.
Y como dije oportunamente, he dejado de aportar económicamente al sentirme insultado por los programadores; estoy analizando la posibilidad de no reportar nada más por el mismo motivo. El siguiente paso (y cada vez está más cerca) es dejar de usar y recomendar LibreOffice.

[EN]
Benefits:
-> The user will always have his favorite topics on hand.
-> If the user decides to change one, he can delete the ones he selected or replace them.
-> You must not be online to apply it.
-> If there are problems to find topics for another failure, you will always have your favorites at your fingertips.
-> You can always select a theme and another 3 (1 selecting it in the traditional way to apply it immediately + 3 favorites)
-> More chances that LibreOffice is personal, belongs to the user and is exactly as he wants it.

I hope that this is taken with the seriousness that is required and not that a single person decides over the users.
A company that does not listen to its clients (users for this case), is a company condemned to mediocrity or to which it falls (or remains) in the anonymity.
And as I said in a timely manner, I stopped contributing financially when I felt insulted by the programmers; I am analyzing the possibility of not reporting anything else for the same reason. The next step (and getting closer) is to stop using and recommend LibreOffice.
Comment 1 Leandro Martín Drudi 2018-11-08 19:15:23 UTC
Created attachment 146462 [details]
Themes preinstalled and the favorites of the user.

El usuario siempre podrá seleccionar el tema de su interés y si no está allí, podrá añadirlo.
Comment 2 Leandro Martín Drudi 2018-11-08 19:18:44 UTC
Created attachment 146463 [details]
Interface with checkboxes to select the theme to add favorites

The user can activate the checkboxes to add that theme to their favorites. At the same time, the user can select a fourth topic to apply immediately.
You can always delete your favorites by removing them with the X button on the main screen or by selecting new ones in this panel.
Comment 3 Heiko Tietze 2019-01-16 07:35:52 UTC
Agreed, having more than one theme available locally makes it convenient to switch between, let's say day and night. That's requested in bug 61311 (and regarding extensions in bug 120406).

The second idea about multiselection at the download dialog is obsolete now since the access got speed up significantly. And eventually I'd prefer to have no dialog at all but list the first couple of available themes directly under the radiobutton (with means to load more).

*** This bug has been marked as a duplicate of bug 61311 ***