Bug 121295 - Autorecovery not working
Summary: Autorecovery not working
Status: RESOLVED DUPLICATE of bug 120097
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: AutoSave-AutoRecovery-Backup
  Show dependency treegraph
 
Reported: 2018-11-09 01:48 UTC by Aron Budea
Modified: 2018-11-09 05:51 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2018-11-09 01:48:21 UTC
- In Options / Load/Save / General, set 'Save AutoRecovery information every: X minutes' to 1.
- Restart LO. (just in case)
- Open a saved ODT document, make some changes to it, and leave it there for 1-2 mins without saving.
- Kill soffice.bin. (via task manager in Windows, or by pressing Ctrl-C in the command line it was started from in Linux)
- Restart LO.

=> After restarting LO, recovery dialog isn't shown, unsaved changes are lost.

While keeping the file open, feel free to monitor temp directories (generally /tmp and C:\Users\<user>\AppData\Local\Temp), you will see directories with names like this appearing: eg. "lu1056059ckf.tmp"

In some versions the ODT will appear in this directory, in others it might appear in <user profile>/backup, no idea why.

Reproduced using LO 6.2 alpha1 / Windows 7.
No problem when using 6.1.0.3.
=> regression

Bibisected to the following commit using repo bibisect-win32-6.2. Adding Cc: to Noel Grandin, please take a look.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=eb34a6a93fcdebe545ab267d7cc7c5c72bab22c8
author		Noel Grandin <noel.grandin@collabora.co.uk>	2018-09-10 09:33:08 +0200
committer	Noel Grandin <noel.grandin@collabora.co.uk>	2018-09-10 11:02:23 +0200

clang-tidy bugprone-virtual-near-miss in RecoveryDialog
Comment 1 Noel Grandin 2018-11-09 05:16:28 UTC
duplicate of 120097 ?
Comment 2 Aron Budea 2018-11-09 05:51:18 UTC
Indeed, thanks Noel.

*** This bug has been marked as a duplicate of bug 120097 ***