Bug 121297 - LO Impress: "JPG Quality" overlapping with "Reduce image resolution" in Presentation Minimizer Wizard in some GTK3
Summary: LO Impress: "JPG Quality" overlapping with "Reduce image resolution" in Prese...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha1+
Hardware: All Linux (All)
: low minor
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.5.0
Keywords:
Depends on:
Blocks: GTK3
  Show dependency treegraph
 
Reported: 2018-11-09 07:24 UTC by Vera Blagoveschenskaya
Modified: 2022-12-06 19:31 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
scr1 (38.32 KB, image/png)
2018-11-09 07:25 UTC, Vera Blagoveschenskaya
Details
scr2 (50.42 KB, image/png)
2018-11-09 07:25 UTC, Vera Blagoveschenskaya
Details
13-11 (197.32 KB, image/png)
2018-11-14 13:46 UTC, Vera Blagoveschenskaya
Details
new screen (38.28 KB, image/png)
2019-01-10 13:28 UTC, Vera Blagoveschenskaya
Details
proof (52.00 KB, image/png)
2019-03-22 07:45 UTC, Vera Blagoveschenskaya
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vera Blagoveschenskaya 2018-11-09 07:24:34 UTC
Description:
Some fields are overlapping each other in Presentation Minimizer Wizard

Steps to Reproduce:
1. Open Impress -> Tools -> Presentation Minimizer Wizard
2. Go to page2, page3

Actual Results:
Some fields are overlapping each other, see screenshots

Expected Results:
No overlapping


Reproducible: Always


User Profile Reset: No



Additional Info:
Reproduced for

Version: 6.2.0.0.alpha1+
Build ID: dbe94dd3b64e74f661ea7193d8e06ac91f1dd7b0
CPU threads: 1; OS: Linux 4.14; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-11-07_16:15:05
Locale: ru-RU (ru_RU.UTF-8); Calc: threaded
 
Reproduced for

Version: 6.2.0.0.alpha1+
Build ID: dbe94dd3b64e74f661ea7193d8e06ac91f1dd7b0
CPU threads: 1; OS: Linux 4.14; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-11-07_16:15:05
Locale: ru-RU (ru_RU.UTF-8); Calc: threaded
Comment 1 Vera Blagoveschenskaya 2018-11-09 07:25:19 UTC
Created attachment 146468 [details]
scr1
Comment 2 Vera Blagoveschenskaya 2018-11-09 07:25:36 UTC
Created attachment 146469 [details]
scr2
Comment 3 Xisco Faulí 2018-11-09 10:16:58 UTC
I can't reproduce it in

Version: 6.2.0.0.alpha1+
Build ID: bc42b6bfa49cc2b58201a8f6177dd3b1a0c038d8
CPU threads: 1; OS: Linux 4.15; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time:
2018-11-06_19:01:37
Locale: en-US (en_US.UTF-8); Calc: threaded

nor in

Version: 6.2.0.0.alpha1+
Build ID: bc42b6bfa49cc2b58201a8f6177dd3b1a0c038d8
CPU threads: 1; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time:
2018-11-06_19:01:37
Locale: en-US (en_US.UTF-8); Calc: threaded

To be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present
Comment 4 Vera Blagoveschenskaya 2018-11-14 13:46:22 UTC Comment hidden (obsolete)
Comment 5 Durgapriyanka 2018-11-30 19:30:20 UTC
I can not reproduce the bug in

Version: 6.0.6.2
Build ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU threads: 2; OS: Windows 6.1; UI render: default; 
Locale: en-US (en_US); Calc: group
Comment 6 Xisco Faulí 2019-01-10 12:43:21 UTC Comment hidden (obsolete)
Comment 7 Vera Blagoveschenskaya 2019-01-10 13:28:02 UTC
Created attachment 148217 [details]
new screen

Bug is reproduced for

Version: 6.3.0.0.alpha0+
Build ID: 32b85ec64e5c901369ce3ce5dbda0e96f2ec7fc0
CPU threads: 4; OS: Linux 4.14; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-01-07_16:08:14
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

Please see new screenshot in the attachment

$ xdpyinfo | grep -iE '(resol|dimen)' 
  dimensions:    3840x1080 pixels (686x193 millimeters)
  resolution:    142x142 dots per inch
Comment 8 Buovjaga 2019-01-26 14:18:42 UTC
Can't repro for kde5 or gtk3.

Arch Linux 64-bit
Version: 6.3.0.0.alpha0+
Build ID: 1a5340788639ba71725338ddc5d340b2b304f4c2
CPU threads: 8; OS: Linux 4.20; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 26 January 2019
Comment 9 Xisco Faulí 2019-03-21 12:22:04 UTC Comment hidden (obsolete)
Comment 10 Vera Blagoveschenskaya 2019-03-22 07:45:09 UTC
Hello!
Can't reproduce for 6.2.3.0.0+, 6.3.0.0.alpha0+

Version: 6.3.0.0.alpha0+
Build ID: a03f421a878c210566dc8d728113a27400da38f2
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-03-16_09:07:41
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

Version: 6.2.3.0.0+
Build ID: 77cc7463bcd3fe9a6528ed1b0309708608cd1cc7
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-6-2, Time: 2019-03-13_11:55:49
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

$ xdpyinfo | grep -iE '(resol|dimen)'
  dimensions:    3840x1080 pixels (688x193 millimeters)
  resolution:    142x142 dots per inch
Comment 11 Vera Blagoveschenskaya 2019-03-22 07:45:48 UTC
Created attachment 150171 [details]
proof
Comment 12 Timur 2021-06-15 09:47:01 UTC
I can reproduce "JPG Quality" overlapping with "Reduce image resolution" in step 3. with LO 5.2, 6.2, 7.2+ in GTK3.

Not sure if it's about resolution. Strange that only Vera saw this before. 
xdpyinfo | grep -iE '(resol|dimen)'
  dimensions:    1680x956 pixels (444x252 millimeters)
  resolution:    96x96 dots per inch
Comment 13 Roman Kuznetsov 2022-11-07 19:09:23 UTC
I do not repro this in KDE in current 7.5 daily build

I'm not sure if GTK3 is still buggy here
Comment 14 Commit Notification 2022-12-06 19:29:49 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a70ad1568ea0fb5b4d7f888fb56fcee130afc433

Resolves: tdf#121297 weld Presentation Minimizer

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.