Download it now!
Bug 121331 - Tabbed: Wrong .uno: command in Insert and Slide Tab
Summary: Tabbed: Wrong .uno: command in Insert and Slide Tab
Status: RESOLVED DUPLICATE of bug 114077
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevAdvice
Depends on:
Blocks: Notebookbar-Tabbed
  Show dependency treegraph
 
Reported: 2018-11-10 13:08 UTC by Rizal Muttaqin
Modified: 2018-11-12 03:59 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rizal Muttaqin 2018-11-10 13:08:06 UTC
Enable experimental features (Tools > LibreOffice(Dev) > Advanced > Enable experimental features, restart if needed) and switch Impress to Tabbed interface (View > User Interface > Tabbed)

Some functions under Insert and Slide tab instead of use "Slide", they use "Page"


Insert tab:
> New Page

Slide tab:
> Format Page
> New Page
> Duplicate Page
> Delete Page
> Rename Page
> Move Page Up
> Move Page Down


Andreas Kainz (NB designer) said there's a limitation which prevent him to implement some "Slide" function so he used "Page" instead. Need an dev advice here.
Comment 1 Maxim Monastirsky 2018-11-10 20:50:49 UTC
(In reply to Rizal Muttaqin from comment #0)
> Andreas Kainz (NB designer) said there's a limitation which prevent him to
> implement some "Slide" function so he used "Page" instead. Need an dev
> advice here.
The limitation in place is that those slide commands were implemented using the command aliases feature, which was never implemented for the sidebar/notebookbar.

*** This bug has been marked as a duplicate of bug 114077 ***
Comment 2 Rizal Muttaqin 2018-11-12 03:59:56 UTC
(In reply to Maxim Monastirsky from comment #1)
> (In reply to Rizal Muttaqin from comment #0)
> > Andreas Kainz (NB designer) said there's a limitation which prevent him to
> > implement some "Slide" function so he used "Page" instead. Need an dev
> > advice here.
> The limitation in place is that those slide commands were implemented using
> the command aliases feature, which was never implemented for the
> sidebar/notebookbar.
> 
> *** This bug has been marked as a duplicate of bug 114077 ***

Could you elaborate what is command aliases feature? Does we have any possibility to implement for the sidebar/notebookbar?