Bug 121350 - Case Change SHIFT + F3 acts on all the word occurrences and not only the selected one
Summary: Case Change SHIFT + F3 acts on all the word occurrences and not only the sele...
Status: RESOLVED DUPLICATE of bug 49033
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.2.1 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 122908 (view as bug list)
Depends on:
Blocks: Shortcuts-Accelerators Character
  Show dependency treegraph
 
Reported: 2018-11-11 11:34 UTC by Giuseppe
Modified: 2019-01-25 15:34 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
example of the bug (202.17 KB, video/x-matroska)
2018-11-11 13:09 UTC, Giuseppe
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Giuseppe 2018-11-11 11:34:29 UTC
Description:
Consider I have a sentence like this: "This and then this and then this".
Then I select an occurrence of the word "this" and press multiple times SHIFT+F3 until i got "THIS". Then I select another occurrence of the word "select". When I start to iterate the SHIFT+F3 key combination, the previous selected "THIS" change back into "this". Please find attached the recorded video for better explanation. Thank you very much for attention.

Steps to Reproduce:
Consider I have a sentence like this: "This and then this and then this".
Then I select an occurrence of the word "this" and press multiple times SHIFT+F3 until i got "THIS". Then I select another occurrence of the word "select". When I start to iterate the SHIFT+F3 key combination, the previous selected "THIS" change back into "this". Please find attached the recorded video for the funny behaviour. Thank you very much for attention.

Actual Results:
Change the case of unselected word occurrences

Expected Results:
change the case only of the selected word occurrence


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Dieter Praas 2018-11-11 12:03:33 UTC
Guiseppe, do you think we can treat this as a duplicate of bug 49033?
Comment 2 Giuseppe 2018-11-11 13:09:12 UTC
Created attachment 146537 [details]
example of the bug
Comment 3 Giuseppe 2018-11-11 13:11:52 UTC
(In reply to Dieter Praas from comment #1)
> Guiseppe, do you think we can treat this as a duplicate of bug 49033?

Yes it is! Thanks,
Giuseppe

*** This bug has been marked as a duplicate of bug 49033 ***
Comment 4 Dieter Praas 2019-01-25 15:34:38 UTC
*** Bug 122908 has been marked as a duplicate of this bug. ***