Bug Hunting Session
Bug 121351 - LO crashes when inserting date / time, page numbering or shape into Base report header or footer
Summary: LO crashes when inserting date / time, page numbering or shape into Base repo...
Status: RESOLVED DUPLICATE of bug 120728
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.1.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-11 12:32 UTC by Paul Newbery
Modified: 2018-11-11 13:57 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Newbery 2018-11-11 12:32:40 UTC
Description:
Attempting to Insert anything from the Insert menu into a LO Base report header or footer, either within the wizard or editing a report, results in an immediate crash. 
Occurs in both 6.1.3.2 and 6.2.0.0.alpha1

Steps to Reproduce:
1. Create report w/o header or footer fields, using wizard from table or query
2. Run report
3. Edit report and attempt to Insert/Date Time, Insert/Page Numbering,  Inset/Media or Insert/Shape
4. LibreOffice Base will crash. 


Actual Results:
LibreOffice crash.


Expected Results:
No crash!


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
It is possible to manually insert a Date formatted Text Box with a TODAY() function. Inserting anything results in an immediate crash.
This occurs in LO 6.1.3.2 on two different Linux Mint 19 machines and 6.2.0.0.alpha1 on the second machine. Both versions installed.
Comment 1 Julien Nabet 2018-11-11 13:57:23 UTC
On pc Debian x86-64 with master sources updated yesterday, I don't reproduce this.
But I could reproduce this with LO Debian package 6.1.3.2

I suppose it's a dup of tdf#120728 which will be fixed from next release 6.1.4

*** This bug has been marked as a duplicate of bug 120728 ***