Bug 121430 - MAILMERGE:PRINTING:PDF- Computed merge field is wrong,compute only with first record values
Summary: MAILMERGE:PRINTING:PDF- Computed merge field is wrong,compute only with first...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: possibleRegression
Depends on:
Blocks: Mail-Merge
  Show dependency treegraph
 
Reported: 2018-11-15 07:29 UTC by pierre.tissendier
Modified: 2019-03-25 02:36 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Merge document (8.82 KB, application/vnd.oasis.opendocument.text)
2018-11-15 07:32 UTC, pierre.tissendier
Details
Base test (calc) (8.21 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-11-15 07:32 UTC, pierre.tissendier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pierre.tissendier 2018-11-15 07:29:50 UTC
Description:
On my mailmerge the computed merge fields is wrong,compute only with first record values. No computed merge fields are good. 
It's apparait on printing (not in printing-view) and on PDF export.


Actual Results:
record 2 Index = BBBB
record 2 mnt1 = 1600
record 2 mnt2 = 2
record 2 mnt1*mnt2= 600

Expected Results:
mnt1*mnt2 = 800


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 pierre.tissendier 2018-11-15 07:32:00 UTC
Created attachment 146644 [details]
Merge document
Comment 2 pierre.tissendier 2018-11-15 07:32:49 UTC
Created attachment 146645 [details]
Base test (calc)
Comment 3 ajlittoz 2018-11-15 10:45:18 UTC
This is a follow-on bug report for question https://ask.libreoffice.org/fr/question/172096/writer-impression-impossible-champs-calculs-contenant-des-champs-fusion/?comment=172499#post-id-172499 (French leg of AskLO site).

This may be a regression for 6.x versions because it does not occur on 5.3 and 5.4 releases.
Comment 4 Xisco Faulí 2019-03-21 12:53:41 UTC
Hello,
LibreOffice 6.2.2.2 is going to be released today, could you please try again
with this version to see if the problem has been resolved meanwhile? Thanks in
advance
Comment 5 pierre.tissendier 2019-03-24 17:45:02 UTC
(In reply to Xisco Faulí from comment #4)
> Hello,
> LibreOffice 6.2.2.2 is going to be released today, could you please try again
> with this version to see if the problem has been resolved meanwhile? Thanks
> in
> advance

Hello,
I'm try ans i think that the problem is resolved.
Thank you
Comment 6 Aron Budea 2019-03-25 02:36:43 UTC
Thanks for the update. Let's use status WORKSFORME, since it's unknown what change fixed the bug.