Bug 121456 - Writer: DOCX export from ODT: wrong tabs stops in TOC
Summary: Writer: DOCX export from ODT: wrong tabs stops in TOC
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Serge Krot (CIB)
URL:
Whiteboard: target:6.3.0 target:6.2.1 target:6.1....
Keywords: filter:docx
Depends on: 63561 64531
Blocks: TableofContents-Indexes 124106
  Show dependency treegraph
 
Reported: 2018-11-16 08:34 UTC by Serge Krot (CIB)
Modified: 2019-04-17 16:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Original TOC with correct tab stops (13.88 KB, application/vnd.oasis.opendocument.text)
2018-11-16 08:34 UTC, Serge Krot (CIB)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Serge Krot (CIB) 2018-11-16 08:34:28 UTC
Created attachment 146681 [details]
Original TOC with correct tab stops

During export of the ODT document into DOCX the TOC contains wrong tab stop positions.
Comment 1 Serge Krot (CIB) 2018-11-16 08:38:27 UTC
The issue depends on following commits:
*    https://gerrit.libreoffice.org/#/c/3884/
*    https://gerrit.libreoffice.org/#/c/57255/
Comment 2 Timur 2018-11-19 12:48:19 UTC Comment hidden (obsolete)
Comment 3 Serge Krot (CIB) 2018-11-19 13:11:39 UTC
https://gerrit.libreoffice.org/#/c/63460/
Comment 4 Commit Notification 2018-11-20 10:56:08 UTC
Serge Krot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/f2f2143316acb449baaf29dd5300a6acf8a5c632%5E%21

tdf#121456: sw: DOCX: tabs export and TABS_RELATIVE_TO_INDENT prop

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Thorsten Behrens (CIB) 2018-11-26 12:27:14 UTC
(In reply to Timur from comment #2)
> Is this a duplicate of Bug 118960?

Can you check with a nightly build? if it's fixed for you, then I suppose yes.
Comment 6 Timur 2018-11-27 09:32:45 UTC
This one is verified. 
Bug 118960 is not fixed.
Comment 7 Commit Notification 2019-01-15 08:04:11 UTC
Serge Krot committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/bc1ef6d6fd1baf7298e62f46097d5ba5762303a2%5E%21

tdf#121456: sw: DOCX: tabs export and TABS_RELATIVE_TO_INDENT prop

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2019-03-28 12:09:11 UTC
Serge Krot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/e47a5543f4b8c9e317d1e43af8c0e5a732e461fd%5E%21

tdf#121456 sw: DOCX: fix loading of empty TOC title

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2019-03-29 10:26:00 UTC
Serge Krot committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/bc5d04dfe4e53880bab21eff5a2071b368d918c1%5E%21

tdf#121456 sw: DOCX: fix loading of empty TOC title

It will be available in 6.1.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2019-03-29 10:26:12 UTC
Serge Krot committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/cc9ff57ee111f8a931e70a6bb592adbf7403d830%5E%21

tdf#121456 sw: DOCX: fix loading of empty TOC title

It will be available in 6.2.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.