Bug Hunting Session
Bug 121481 - "Select" to "automatically copy"
Summary: "Select" to "automatically copy"
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.3.1 rc
Hardware: All Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-17 15:03 UTC by 00
Modified: 2018-11-27 07:37 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
1 (188.52 KB, image/png)
2018-11-17 15:07 UTC, 00
Details
2 (138.07 KB, image/png)
2018-11-17 15:08 UTC, 00
Details
"Copy completed" message (157.40 KB, image/png)
2018-11-19 09:42 UTC, 00
Details

Note You need to log in before you can comment on or make changes to this bug.
Description 00 2018-11-17 15:03:53 UTC
Description:
In the "Options", add "Select" to select "Automatic Copy".


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 00 2018-11-17 15:07:38 UTC
Created attachment 146707 [details]
1
Comment 2 00 2018-11-17 15:08:08 UTC
Created attachment 146708 [details]
2
Comment 3 00 2018-11-19 07:57:33 UTC
This is a very "humanized" design.
Comment 4 00 2018-11-19 09:37:04 UTC
supplement
After "Copy Complete", in the upper right corner, the message "Copy Complete" will be automatically displayed, and the message will be automatically closed after three seconds.
Comment 5 00 2018-11-19 09:42:23 UTC
Created attachment 146736 [details]
"Copy completed" message
Comment 6 Heiko Tietze 2018-11-19 10:57:41 UTC
What use case do you solve with the proposal to always copy on selection? User-centered ("humanized") design typically starts with a user/scenario/workflow analysis that I miss here. And the drawback of your idea is a) an overflow of the clipboard (you cannot copy some text and paste later unless taking care of not selecting anything), b) very uncommon workflow that needs some explanation, and c) weird and potentially nagging feedback.
Comment 7 00 2018-11-19 15:49:08 UTC
(In reply to Heiko Tietze from comment #6)

It is convenient to reduce the action of pressing the "right mouse button" and "copy button".

When you don't need this feature, the user doesn't have to copy it.

When you need this function, the user will pay attention to it.



This is my function in the "browser", very easy to use, so I recommend it to you.
Comment 8 00 2018-11-19 16:16:25 UTC
(In reply to Heiko Tietze from comment #6)


The idea is to improve from the program on the website below.
A program similar to the one below is now used by many people.

Https://chrome.google.com/webstore/detail/copy-better/hpihdokfdmmghaclaojfpmbckkhjgebc
Comment 9 00 2018-11-20 06:48:00 UTC
Writer, Calc, Impress, Draw, Math, Base, all use this design.
Comment 10 Timur 2018-11-20 17:24:37 UTC
There are two possible resolutions here: 
1. to say WontFix because likely number of users is not big; someone may create an extension, just like in given example;
2. to confirm as New enhancement with some low priority; and to be aware that this may never be fixed, until some volunteers to accept it.
Comment 11 00 2018-11-21 07:03:14 UTC
(In reply to Timur from comment #10)


This feature can be "opened" or "closed" without forcing anyone to use it.
Comment 12 Adolfo Jayme 2018-11-23 23:46:30 UTC
Sometimes I wish Windows were as functional as Linux is. In most distros, you have two clipboard buffers: the usual Ctrl+V one, and the selection + middle-click one. So this feature request would be Windows-only.
Comment 13 00 2018-11-24 06:38:04 UTC
(In reply to Adolfo Jayme from comment #12)


Only Windows is OK, and Linux will be added later.
Comment 14 00 2018-11-24 06:42:08 UTC
(In reply to Adolfo Jayme from comment #12)


Ok, Windows comes first.
Comment 15 Heiko Tietze 2018-11-26 10:06:25 UTC
LibreOffice aims to fit smoothly into the operating system workflow. Special solutions like this wont fix this prerequisite.
Comment 16 00 2018-11-27 07:37:08 UTC
Don't want this feature,
It’s a shame.

Suggest
Put this feature,
Make the "expansion function" of LibreOffice "official",
Those who need it will download the "extension function".
That's it.

Controversial programs in the future,
Can be solved in this way.