Bug Hunting Session
Bug 121486 - Text in Thai for some font go right to left
Summary: Text in Thai for some font go right to left
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.3.7.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Khaled Hosny
URL:
Whiteboard: target:6.4.0 target:6.3.0.1 target:6.2.5
Keywords: bibisected, bisected, regression
: 124834 (view as bug list)
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2018-11-18 03:33 UTC by tongwarit
Modified: 2019-08-21 21:25 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
showing what it's like when I type (29.67 KB, image/png)
2018-11-18 03:33 UTC, tongwarit
Details
Bug sample of problemati font in ODT doc (12.40 MB, application/vnd.oasis.opendocument.text)
2018-11-25 04:23 UTC, tongwarit
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tongwarit 2018-11-18 03:33:59 UTC
Created attachment 146718 [details]
showing what it's like when I type

For several fonts that are in Thai, the letter seems to go from right to left.
I've attached some screen cap to demonstrate it. You can see the text are falling off the page when they are supposed to be aligned-left. I also select all by ctrl+A to highlight where the text are actually supposed to be.

The fonts in question that I've verified are having the same problems are:
TH Baijam
TH Fah kwang
TH Chakra Petch
TH Charm of AU
TH Koho

FYI, the problem also exist on another computer of mine (Win 10 X64). This computer where I'm making this report is Win 7 X64
Comment 1 V Stuart Foote 2018-11-18 16:29:46 UTC
Please create a sample document with text passages/paragraphs defined in each of the problem fonts. Also include some that format correctly. 

Then attach the sample document to this issue to upload it.

You also could try to create and attach the sample with the fonts embedded. 
Done from the File -> Properties -> Font tab to check box the "Embed fonts in the document"

But often it ends up we will need to locate the actual problem font(s) to check formatting issues of the font design.
Comment 2 tongwarit 2018-11-25 04:23:50 UTC
Created attachment 147013 [details]
Bug sample of problemati font in ODT doc

I've attached a document with passages in the fonts in question.
I've also embedded the font with the document, and included a link to download them, and their Wikipedia page.
Comment 3 V Stuart Foote 2018-11-25 13:53:30 UTC
COnfirmed on Windows 10 Home 64-bit en-US with
Version: 6.1.3.2 (x64)
Build ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb
CPU threads: 4; OS: Windows 10.0; UI render: GL (or default)
Locale: en-US (en_US); Calc: CL

current master/6.3.0
Version: 6.3.0.0.alpha0+ (x64)
Build ID: 70970f8b72eddc66693ec28d26c2dc764009d3e3
CPU threads: 4; OS: Windows 10.0; UI render: GL (or default); VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-11-24_03:32:27
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

and also with

Version: 5.3.7.2 (x64)
Build ID: 6b8ed514a9f8b44d37a1b96673cbbdd077e24059
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; Layout Engine: new; 
Locale: en-US (en_US); Calc: group

Fonts 6, 10, 11, 12, 13 from sample are inscribed to document canvas RTL and out of the paragraph object's bounds.
Comment 4 Xisco Faulí 2018-11-28 12:24:52 UTC
Seems to be win only.

I can reproduce it in

Versión: 6.1.3.2
Id. de compilación: 86daf60bf00efa86ad547e59e09d6bb77c699acb
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: group threaded

but not in

Versió: 6.1.3.2
ID de la construcció: 1:6.1.3~rc2-0ubuntu0.16.04.1
Fils de CPU: 4; SO: Linux 4.15; Renderitzador de la IU: per defecte; VCL: gtk3; 
Configuració local: ca-ES (ca_ES.UTF-8); Calc: group threaded
Comment 5 Xisco Faulí 2018-11-28 12:35:10 UTC
Not reproduced in

Versión: 4.4.0.3
Id. de compilación: de093506bcdc5fafd9023ee680b8c60e3e0645d7
Configuración regional: es_ES
Comment 6 Xisco Faulí 2018-11-28 17:51:16 UTC
The text became to be displayed on the margin after

https://cgit.freedesktop.org/libreoffice/core/commit/?id=a5750d92b2136d60d698b41ef5760f2efac0ffce

author	Khaled Hosny <khaledhosny@eglug.org>	2016-11-14 00:52:14 +0200
committer	Khaled Hosny <khaledhosny@eglug.org>	2016-11-15 11:30:42 +0000
commit	a5750d92b2136d60d698b41ef5760f2efac0ffce (patch)
tree	fea47fdbc8ae4bca99ff2bacf9b1338b012b2576
parent	098f7a4ac2b6f309a45d29f1b68bea18418b9ee7 (diff)
tdf#103725: Fix horizontal scaling on Windows

Bisected with: bibisect-win32-5.3

Adding Cc: to Khaled Hosny
Comment 7 Commit Notification 2019-06-16 15:16:48 UTC
Khaled Hosny committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/8fffb56940c6eb81674000cdb718edc79603a6c5%5E%21

tdf#121486: Correct scale of broken fonts on Windows

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2019-06-16 19:04:49 UTC
Khaled Hosny committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/cd7b82ecb9c7b96b29087e70b66210a3de5a4434%5E%21

tdf#121486: Correct scale of broken fonts on Windows

It will be available in 6.3.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2019-06-16 23:21:05 UTC
Khaled Hosny committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/cd33eb812277f516f4670edfffd68e5b763e8a4c%5E%21

tdf#121486: Correct scale of broken fonts on Windows

It will be available in 6.2.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2019-06-17 16:43:15 UTC
Khaled Hosny committed a patch related to this issue.
It has been pushed to "libreoffice-6-2-5":

https://git.libreoffice.org/core/+/9f095d0bc6b091ca8e0522533c981374d0648c09%5E%21

tdf#121486: Correct scale of broken fonts on Windows

It will be available in 6.2.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Khaled Hosny 2019-08-21 21:25:32 UTC
*** Bug 124834 has been marked as a duplicate of this bug. ***