Bug 121516 - KDE5: Crash closing check for update dialog
Summary: KDE5: Crash closing check for update dialog
Status: VERIFIED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.0.0.beta1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2018-11-19 12:44 UTC by Xisco Faulí
Modified: 2019-03-14 17:07 UTC (History)
5 users (show)

See Also:
Crash report or crash signature: ["libQt5Core.so.5.9.5"]


Attachments
screenshot of installed extensions (56.90 KB, image/png)
2018-11-20 12:21 UTC, Michael Weghorn
Details
install extensions (60.02 KB, image/png)
2018-11-20 16:15 UTC, Xisco Faulí
Details
gdbtrace.log (54.74 KB, text/x-log)
2018-11-29 08:54 UTC, Vera Blagoveschenskaya
Details
gdbtrace.log (35.61 KB, text/x-log)
2019-01-10 08:07 UTC, Vera Blagoveschenskaya
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2018-11-19 12:44:55 UTC
Steps to reproduce:
1. Open LibreOffice
2. Tools - Extension Manager
3. Check for updates
4. Close the dialog
-> CRASH

Reproduced in

Version: 6.2.0.0.beta1
Build ID: d1b41307be3f8c19fe6f1938cf056e7ff1eb1d18
CPU threads: 1; OS: Linux 4.15; UI render: default; VCL: kde5; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

but not in

Version: 6.2.0.0.beta1
Build ID: d1b41307be3f8c19fe6f1938cf056e7ff1eb1d18
CPU threads: 1; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Michael Weghorn 2018-11-20 12:21:17 UTC
Created attachment 146822 [details]
screenshot of installed extensions

I cannot reproduce here with exactly the same build and a clean user profile (nor with a custom master build):

Version: 6.2.0.0.beta1
Build ID: d1b41307be3f8c19fe6f1938cf056e7ff1eb1d18
CPU threads: 4; OS: Linux 4.18; UI render: default; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

@Xisco: Do you have any additional extensions installed besides the ones bundled with LibreOffice? I just have those, s. attached screenshot.
Comment 2 Xisco Faulí 2018-11-20 16:15:39 UTC
Created attachment 146842 [details]
install extensions
Comment 3 Xisco Faulí 2018-11-20 16:15:58 UTC
it seems I have the same extension with the same versions as you...
Comment 4 Xisco Faulí 2018-11-20 16:20:18 UTC
I'm using Kubuntu 18.04.1

For the record, it hangs with GTK3.
@Michael, it works fine with GTK3 in your end ?
Comment 5 Michael Weghorn 2018-11-20 16:53:41 UTC
(In reply to Xisco Faulí from comment #4)
> I'm using Kubuntu 18.04.1
> 
> For the record, it hangs with GTK3.
> @Michael, it works fine with GTK3 in your end ?

I'm using Debian testing with Plasma.
When using GTK3, it hangs for me as well.
Comment 6 Vera Blagoveschenskaya 2018-11-29 08:54:03 UTC
I reproduced this crash for

Version: 6.3.0.0.alpha0+
Build ID: b15b1a2a90fa4c239ff8a6a33e73ff50ea422abf
CPU threads: 1; OS: Linux 4.14; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-11-28_06:21:05
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

NO additional extentions installed.
Comment 7 Vera Blagoveschenskaya 2018-11-29 08:54:55 UTC
Created attachment 147125 [details]
gdbtrace.log
Comment 8 Julien Nabet 2018-12-20 20:42:01 UTC
On pc Debian x86-64 with master sources updated today + kde5 rendering, I got no hang but noticed these kind of trace on console:
warn:vcl.schedule:8331:8331:vcl/source/app/scheduler.cxx:367: we're too early - restart the timer (14ms)!
warn:svtools:8331:8331:vcl/source/graphic/UnoGraphicProvider.cxx:433: Could not create graphic: 0x8201(Error Area:Vcl Class:General Code:1)
QObject::startTimer: Timers cannot be started from another thread
QObject::killTimer: Timers cannot be stopped from another thread

I don't have these with gtk3 rendering.
Comment 9 Xisco Faulí 2018-12-21 12:00:10 UTC
Still reproducible in

Version: 6.2.0.1
Build ID: 0412ee99e862f384c1106d0841a950c4cfaa9df1
CPU threads: 1; OS: Linux 4.15; UI render: default; VCL: kde5; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 10 Vera Blagoveschenskaya 2019-01-10 08:07:17 UTC
Created attachment 148197 [details]
gdbtrace.log

Crash is still reproduced

Version: 6.3.0.0.alpha0+
Build ID: 32b85ec64e5c901369ce3ce5dbda0e96f2ec7fc0
CPU threads: 4; OS: Linux 4.14; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-01-07_16:08:14
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

New (advanced) gdbtrace.log in the attachment.
Comment 11 Aleksei Nikiforov 2019-01-10 10:02:31 UTC
I'm unable to reproduce this crash with Qt 5.11.3, but I didn't try Qt 5.9.x. Can someone confirm if it doesn't crash with Qt >= 5.11?

Version: 6.3.0.0.alpha0+
Build ID: 0aff7edaa4ec4a2aa232bac27f669e42435905b3
CPU threads: 12; OS: Linux 4.19; UI render: default; VCL: kde5; 
Locale: en-US (C); UI-Language: en-US
Calc: threaded
Comment 12 Michael Weghorn 2019-01-10 10:24:39 UTC
(In reply to Aleksei Nikiforov from comment #11)
> I'm unable to reproduce this crash with Qt 5.11.3, but I didn't try Qt
> 5.9.x. Can someone confirm if it doesn't crash with Qt >= 5.11?

Yes, my result in comment 1 also was with Qt 5.11.x
Comment 13 Michael Weghorn 2019-01-10 10:25:22 UTC
(In reply to Michael Weghorn from comment #12)
> (In reply to Aleksei Nikiforov from comment #11)
> > I'm unable to reproduce this crash with Qt 5.11.3, but I didn't try Qt
> > 5.9.x. Can someone confirm if it doesn't crash with Qt >= 5.11?
> 
> Yes, my result in comment 1 also was with Qt 5.11.x

... but of course I can't say that a newer Qt version will fix it for those that have the crash...
Comment 14 Katarina Behrens (CIB) 2019-03-13 16:20:02 UTC
Peeps please try again, lot of threading fixes were merged recently and the backtrace looks very much like a threading/locking issue
Comment 15 Vera Blagoveschenskaya 2019-03-14 07:43:23 UTC
Hello,

I've checked the behavior for 6.3.0.0.alpha0+, 6.2.3.0.0+, 6.2.2.0.0+

Crash is NOT reproduced for

Version: 6.3.0.0.alpha0+
Build ID: bbc5347be70d11d187cd537dd73cdab584def719
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-03-03_20:19:18
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

Crash is NOT reproduced for

Version: 6.2.3.0.0+
Build ID: 77cc7463bcd3fe9a6528ed1b0309708608cd1cc7
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-6-2, Time: 2019-03-13_11:55:49
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

BUT still ACTUAL for

Version: 6.2.2.0.0+
Build ID: b17bffe4eb15e4cec969aa2699ce8be60e01b1c1
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-6-2, Time: 2019-02-25_17:41:32
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded
Comment 16 Vera Blagoveschenskaya 2019-03-14 07:54:43 UTC
Pls set to RESOLVED if 6.2.3 and 6.3.0 is enough.
Comment 17 Xisco Faulí 2019-03-14 08:27:46 UTC
(In reply to Vera Blagoveschenskaya from comment #16)
> Pls set to RESOLVED if 6.2.3 and 6.3.0 is enough.

it works like a charm now

Version: 6.3.0.0.alpha0+
Build ID: 17b25fd3df237a64d6a28fbc57b869e080963193
CPU threads: 2; OS: Linux 4.15; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-03-13_20:42:25
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

This week some KDE5 commits were backported to 6-2 but not to 6-2-2. Probably one of those commits fixed the issue.
Closing as RESOLVED WORKSFORME
@Bubli, @Michael, thanks for your work here
Comment 18 Vera Blagoveschenskaya 2019-03-14 08:32:08 UTC
VERIFIED due to https://bugs.documentfoundation.org/show_bug.cgi?id=121516#c15
Comment 19 Katarina Behrens (CIB) 2019-03-14 09:03:45 UTC
Hm, so we might want to backport the threading fixes we made bc of crashers in tdf#119856
Comment 20 Michael Weghorn 2019-03-14 09:18:55 UTC
(In reply to Katarina Behrens (CIB) from comment #19)
> Hm, so we might want to backport the threading fixes we made bc of crashers
> in tdf#119856

As far as I understand, those should be unrelated, since comment 15 mentions it's no more reproducible with 6.2.3.0.0+, and the fixes have not been backported to libreoffice-6-2 so far.
Comment 21 Xisco Faulí 2019-03-14 09:28:32 UTC
Maybe bug 123745 ?
Comment 22 Michael Weghorn 2019-03-14 16:58:34 UTC
(In reply to Xisco Faulí from comment #21)
> Maybe bug 123745 ?

Sounds quite possible. In that case, there's nothing to do, since the patch has been backported to libreoffice-6-2-2 already. (I quickly verified that the commit wasn't yet included in Vera's 6.2.2 build from comment 15, but was in the 6.2.3 build).
Comment 23 Xisco Faulí 2019-03-14 17:01:40 UTC
(In reply to Michael Weghorn from comment #22)
> (In reply to Xisco Faulí from comment #21)
> > Maybe bug 123745 ?
> 
> Sounds quite possible. In that case, there's nothing to do, since the patch
> has been backported to libreoffice-6-2-2 already. (I quickly verified that
> the commit wasn't yet included in Vera's 6.2.2 build from comment 15, but
> was in the 6.2.3 build).

I guess it can be quickly check with a local build in KDE5 by reverting it... I don't have it though
Comment 24 Michael Weghorn 2019-03-14 17:07:19 UTC
(In reply to Xisco Faulí from comment #23)
> I guess it can be quickly check with a local build in KDE5 by reverting
> it... I don't have it though

Unfortunately, I cannot test either, since I was never able to reproduce (s. comment 1).
Alternatively, it could be checked it's actually fixed with a recent build from the 6-2-2 branch. Or one could fall back to hoping it's fixed and in case that fails, it's still going to be fixed in 6.2.3 at least...