Bug 121526 - DOCX Import Textbox inserted in header created with Word moves down in Writer
Summary: DOCX Import Textbox inserted in header created with Word moves down in Writer
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Textbox
  Show dependency treegraph
 
Reported: 2018-11-19 15:05 UTC by NISZ LibreOffice Team
Modified: 2019-12-30 07:15 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
An example file with textbox in footer (25.12 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-11-19 15:05 UTC, NISZ LibreOffice Team
Details
A screenshot showcasing the issue. (213.74 KB, image/png)
2018-11-19 15:06 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2018-11-19 15:05:10 UTC
Description:
Textbox inserted in header in DOCX documents created with Microsoft Word 2010 moves down when the document is opened in LibreOffice Writer 6.0.1.1.

Steps to Reproduce:
1. Create a new document in Microsoft Word.
2. Click on Insert, Footer, Edit Footer
3. Click on Insert, and the arrow below the TextBox
4. Choose the first
5. Save the file as DOCX
6. Open the same file in LibreOffice Writer and compare the two versions.

Actual Results:
Textbox moved down opened in LibreOffice Writer 6.0.1.1.

Expected Results:
Textbox should be the same as opened in Microsoft Word 2010.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 NISZ LibreOffice Team 2018-11-19 15:05:56 UTC
Created attachment 146783 [details]
An example file with textbox in footer
Comment 2 NISZ LibreOffice Team 2018-11-19 15:06:14 UTC
Created attachment 146784 [details]
A screenshot showcasing the issue.
Comment 3 Durgapriyanka 2018-11-19 16:41:19 UTC
I can not reproduce the bug.

Microsoft Word 2007


Version: 6.0.6.2
Build ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU threads: 2; OS: Windows 6.1; UI render: default; 
Locale: en-US (en_US); Calc: group
Comment 4 Xisco Faulí 2018-11-19 16:53:51 UTC
Reproduced in

Version: 6.2.0.0.beta1+
Build ID: 268364e35100b559f42d8c02b930c5cca1c84be7
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.10; Render: default; 

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

in

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

the textbox is not even displayed...
Comment 5 QA Administrators 2019-12-06 04:18:21 UTC Comment hidden (obsolete)
Comment 6 Roman Kuznetsov 2019-12-30 07:15:58 UTC
still repro in

Version: 6.5.0.0.alpha0+ (x64)
Build ID: 42a1a1c6b91907f81e15066ffab219411f18c4db
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded