Download it now!
Bug 121566 - If Option “Edit document properties before saving” is Chosen, PDF should be exported after closing the Properties dialog
Summary: If Option “Edit document properties before saving” is Chosen, PDF should be e...
Status: RESOLVED DUPLICATE of bug 120343
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.3.2 release
Hardware: All All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-20 21:25 UTC by Grzegorz Skoczylas
Modified: 2018-11-22 09:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Export options (17.63 KB, image/png)
2018-11-20 21:34 UTC, Grzegorz Skoczylas
Details
General save document options (21.54 KB, image/png)
2018-11-20 21:35 UTC, Grzegorz Skoczylas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Grzegorz Skoczylas 2018-11-20 21:25:50 UTC
Description:
I'm using the LibreOffice  6.1.3.2 (64-bit). I create documents in writer and export them to PDF format.

If the "Show PDF document" option is set then existing PDF document is shown BEFORE new document is created.

It worked correctly in earlier 6.1 version.

Tested only with the Writer. Don't know about other components.

Steps to Reproduce:
1. Open document in Writer.
2. Export it as PDF. Remember to set option "Display PDF after export"
3. Modify document in Writer.
4. Export it as PDF again, with the same settings.

Perhaps it is also important to set option "Edit document properties before save" option in the Load/Save options.

Actual Results:
Both document properties window and existing PDF document are displayed. It is not possible to continue exporting without closing PDF. Document contains previous version of the document.

Expected Results:
PDF document should be displayed AFTER exporting the document.


Reproducible: Always


User Profile Reset: No



Additional Info:
I'm using Polish version of the LibreOffice.

Wersja: 6.1.3.2 (x64)
Build ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb
Wątki CPU: 8; OS:Windows 10.0; UI render:domyślny; 
Ustawienia regionalne: pl-PL (pl_PL); Calc: group threaded
Comment 1 Grzegorz Skoczylas 2018-11-20 21:34:57 UTC
Created attachment 146853 [details]
Export options
Comment 2 Grzegorz Skoczylas 2018-11-20 21:35:42 UTC
Created attachment 146854 [details]
General save document options
Comment 3 Timur 2018-11-21 14:10:25 UTC
Description and steps are not clear enough. 
But I think there's a bug so I rename: 
"If Option “Edit document properties before saving” is Chosen, PDF should be exported after closing the Properties dialog".
Please confirm. And retest earlier version, unlikely it was different before. 
Could be a duplicate of Bug 91204 but let's keep separated.
Comment 4 Xisco Faulí 2018-11-22 09:39:06 UTC
Hello Grzegorz Skoczylas,
Thanks for reporting this issue.
This has been already reported in bug 120343

*** This bug has been marked as a duplicate of bug 120343 ***