Bug 121591 - CRASH: Print Preview fails if cursor inside Floating frame
Summary: CRASH: Print Preview fails if cursor inside Floating frame
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0.1 target:6.3.0 target:6.1.4
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-11-21 14:34 UTC by Me
Modified: 2018-12-04 16:13 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Me 2018-11-21 14:34:04 UTC
Description:
Print Preview fails in Floating frame inserted in worksheet

Steps to Reproduce:
1.In menu,  choose "INSERT", then " Floating Frame" to insert content come from a html.file on Desktop .
2. In menu, choose "FILE", then " Print Preview".
3.

Actual Results:
Insult in  Crash and shutdown , when doing these every time.

Expected Results:
Normal print Preview in the worksheet


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Xisco Faulí 2018-11-21 15:52:11 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=2c317751c4b7661c10bd9eb11094febeccd1b816

author	Kshitij Pathania <kshitijpathania@gmail.com>	2018-06-24 01:57:11 +0530
committer	Szymon Kłos <szymon.klos@collabora.com>	2018-06-24 20:19:56 +0200
commit	2c317751c4b7661c10bd9eb11094febeccd1b816 (patch)
tree	017a52106ac34573896d8a9a45d760cd60fb04ab
parent	a7af4bbbc0793fb78aea6a89f8fb6dc052710a11 (diff)
Notebookbar:Disabled appearence of context toolbars

Bisected with: bibisect-win32-6.2

Adding Cc: to Kshitij Pathania
Comment 2 Xisco Faulí 2018-11-21 15:53:30 UTC
On Linux it doesn't crash but the toolbars disappear. Closing the document make the start center to become totally grey
Comment 3 Xisco Faulí 2018-11-21 16:14:15 UTC
@Mike Kaganski, since you fixed bug 119042 I thought you might be interested in this issue...
Comment 4 Xisco Faulí 2018-11-21 17:08:13 UTC
Reverted the problematic commit in https://gerrit.libreoffice.org/#/c/63735/ until a better fix is provided for bug 103226
Comment 5 Xisco Faulí 2018-11-21 22:43:14 UTC
The problematic commit is already reverted in master, 6-2 and 6-1 -> https://cgit.freedesktop.org/libreoffice/core/commit/?id=9a6169529eb687190531225bfe9fef850325ee9e
Closing as RESOLVED FIXED
Comment 6 Commit Notification 2018-11-29 19:42:25 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/0a36be3fee1b4f1b47b55a64668b6aa99896ab24%5E%21

tdf#121591, tdf#119945: ModuleManager::identify throws for embedded modules

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Xisco Faulí 2018-12-02 13:30:40 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: 4da61d4cc8f70ff62d7bac23a1b97d9d7011a678
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Mike Kaganski, thanks for fixing this!

Do you think it should be cherry-picked to 6-1 and 6-1-4 as well?
Comment 8 Commit Notification 2018-12-02 13:34:19 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/9ce21daf20faae0e5c8dd8eeb0909106e23a4319%5E%21

tdf#121591, tdf#119945: ModuleManager::identify throws for embedded modules

It will be available in 6.2.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.