Download it now!
Bug 121612 - pivot table filtering lost after saving to XLSX
Summary: pivot table filtering lost after saving to XLSX
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium normal
Assignee: Vasily Melenchuk (CIB)
URL:
Whiteboard: target:6.3.0 target:6.2.0.1 target:6.1.5
Keywords: filter:xlsx
: 105254 123197 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-11-22 08:21 UTC by Vasily Melenchuk (CIB)
Modified: 2019-02-07 12:23 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
testcase (44.55 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-11-22 08:21 UTC, Vasily Melenchuk (CIB)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vasily Melenchuk (CIB) 2018-11-22 08:21:08 UTC
Description:
After saving given document as XLSX there are no filters on pivot table sheet

Steps to Reproduce:
1. Open attached pivot_table.ods and ensure, that there are filters on "Pivot-Tabelle_Filter_1" sheet.
2. Save this document as "Excel 2007-2019 (.xslx)"
3. Open saved document

Actual Results:
There are no more filters for "Fabricat" and "Karosserie"

Expected Results:
Filters are available in loaded document


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Vasily Melenchuk (CIB) 2018-11-22 08:21:29 UTC
Created attachment 146899 [details]
testcase
Comment 2 Xisco Faulí 2018-11-22 10:07:54 UTC
Also reproduced in

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)
Comment 4 Commit Notification 2018-11-28 23:58:57 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/6481bda69ade61cb5420156272fcf17edd43d620%5E%21

tdf#121612: update pivot caches during saving to XLSX

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2018-11-30 14:27:57 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/f8c76ab81bb5b443c5077c2cac9112f8e0ee6855%5E%21

tdf#121612: update pivot caches during saving to XLSX

It will be available in 6.2.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Vasily Melenchuk (CIB) 2018-11-30 14:33:39 UTC
(In reply to m.a.riosv from comment #3)
> Maybe this bug are in relation:
> https://bugs.documentfoundation.org/show_bug.cgi?id=113908
> https://bugs.documentfoundation.org/show_bug.cgi?id=105254

Yes, there is bunch of related bugs, but seems they all have different origins. At least seems my fix does not fix any of them.
Comment 7 Commit Notification 2018-11-30 14:55:18 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/52c088c4d738a3299bda434635a2d9f2da03467c%5E%21

tdf#121612: update pivot caches during saving to XLSX

It will be available in 6.1.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 m.a.riosv 2018-11-30 15:08:41 UTC
(In reply to Vasily Melenchuk (CIB) from comment #6)
> (In reply to m.a.riosv from comment #3)
> > Maybe this bug are in relation:
> > https://bugs.documentfoundation.org/show_bug.cgi?id=113908
> > https://bugs.documentfoundation.org/show_bug.cgi?id=105254
> 
> Yes, there is bunch of related bugs, but seems they all have different
> origins. At least seems my fix does not fix any of them.

Maybe there are, but the comment was thinking if they could have the same origin, can't be other way.
Comment 9 Katarina Behrens (CIB) 2019-02-05 22:56:11 UTC
*** Bug 123197 has been marked as a duplicate of this bug. ***
Comment 10 Buovjaga 2019-02-06 12:34:44 UTC
*** Bug 105254 has been marked as a duplicate of this bug. ***
Comment 11 grofaty 2019-02-07 12:23:45 UTC Comment hidden (obsolete)