Bug Hunting Session
Bug 121615 - Writer: PDF export of JPEG images from ODT/DOCX stretched and cropped with OpenGL enabled
Summary: Writer: PDF export of JPEG images from ODT/DOCX stretched and cropped with Op...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.1.1.2 release
Hardware: IA64 (Itanium) Windows (All)
: medium normal
Assignee: Luboš Luňák
URL:
Whiteboard: target:6.3.0 target:6.2.3 target:6.1.6
Keywords: bibisectRequest, filter:pdf, regression
: 106311 106357 111963 114705 116545 118410 118532 119771 124045 (view as bug list)
Depends on:
Blocks: VCL-OpenGL PDF-Export
  Show dependency treegraph
 
Reported: 2018-11-22 10:26 UTC by wrost@edina.xnc.com
Modified: 2019-04-29 10:29 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments
DOCX with logo (64.84 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-11-26 18:56 UTC, Roman Kuznetsov
Details
result PDF from 6.2 beta 1 (52.09 KB, application/pdf)
2018-11-26 18:56 UTC, Roman Kuznetsov
Details
odt-File (71.72 KB, application/vnd.oasis.opendocument.text)
2018-12-31 18:30 UTC, wrost@edina.xnc.com
Details
pdf-file exported from the odt-file (52.09 KB, application/pdf)
2018-12-31 18:32 UTC, wrost@edina.xnc.com
Details
pdf file with bad logo (52.09 KB, application/pdf)
2019-04-24 21:54 UTC, wrost@edina.xnc.com
Details
odt file wiht good logo (71.72 KB, application/vnd.oasis.opendocument.text)
2019-04-24 21:55 UTC, wrost@edina.xnc.com
Details

Note You need to log in before you can comment on or make changes to this bug.
Description wrost@edina.xnc.com 2018-11-22 10:26:54 UTC
Description:
docx-file with logos gives bad result when I export to a pdf file.

Opening the file with OpenOffice pdf exportfile looks fine.

You can find the docx file at https://www.dropbox.com/s/bpvowgtz9fjzyby/LibreOffice-Bug-Logo.docx?dl=0




Steps to Reproduce:
1. Open the file with LibreOFfice writer
2. export to a pdf file
3. 

Actual Results:
look at the pdf file - logo is bad

Expected Results:
create a pdf file with correct logo


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Roman Kuznetsov 2018-11-26 18:55:38 UTC
confirm in

Version: 6.2.0.0.beta1 (x64)
Build ID: d1b41307be3f8c19fe6f1938cf056e7ff1eb1d18
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: CL
Comment 2 Roman Kuznetsov 2018-11-26 18:56:04 UTC
Created attachment 147054 [details]
DOCX with logo
Comment 3 Roman Kuznetsov 2018-11-26 18:56:31 UTC
Created attachment 147055 [details]
result PDF from 6.2 beta 1
Comment 4 Xisco Faulí 2018-11-28 12:12:41 UTC
I can't reproduce it in

Version: 6.2.0.0.beta1+
Build ID: ce7bb69f8205bcbe36cba4c53bd110e07ef3e05d
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 5 Xisco Faulí 2018-11-28 12:14:50 UTC
Nor in

Versión: 6.1.3.2
Id. de compilación: 86daf60bf00efa86ad547e59e09d6bb77c699acb
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: group threade

@Roman, Do you reproduce it in 6.1.3.2? Which PDF viewer do you use? Is the result different with another PDF viewer ?
Comment 6 Roman Kuznetsov 2018-11-28 12:41:17 UTC
(In reply to Xisco Faulí from comment #5)
> Nor in
> 
> Versión: 6.1.3.2
> Id. de compilación: 86daf60bf00efa86ad547e59e09d6bb77c699acb
> Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
> Configuración regional: es-ES (es_ES); Calc: group threade
> 
> @Roman, Do you reproduce it in 6.1.3.2? Which PDF viewer do you use? Is the
> result different with another PDF viewer ?

No, i can't repro it in 6.1.2.1 on Windows 7. PDF looks as DOCX. I use PDF-Exchange Viewer.
But I attached wrong PDF from 6.2 beta 1 on Windows 10 and you can look at it just in FireFox.

and in

Version: 6.2.0.0.beta1
Build ID: d1b41307be3f8c19fe6f1938cf056e7ff1eb1d18
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded

i can't repro it 

may be it's only windows 10 problem?
Comment 7 wrost@edina.xnc.com 2018-11-28 13:14:41 UTC
In the meantime I did an upgrade to 6.1.3.2 (x64). The problem still exists.
OS = WIN10


Please look at

    the docx-file:      https://www.dropbox.com/s/bpvowgtz9fjzyby/LibreOffice-Bug-Logo.docx?dl=0

    resulting pdf-file:    https://www.dropbox.com/s/3pb268tkbipevxr/LibreOffice-Bug-Logo.pdf?dl=0

Please look at the pdf-file in the upper left corner.


pdf-export with OpenOffice works fine!
Comment 8 Timur 2018-12-31 16:05:03 UTC
This doesn't look like a valid bug report. 
DOCX is created with LO. We need first source ODT. 
wrost, please don't use Dropbox but attach files here directly. 
Doesn't really makes sense to have this bug in Windows 10. I don't repro there. 
Roman, did you try with different PDF export options? 
Opened PDF with different PDF viewers?
Comment 9 wrost@edina.xnc.com 2018-12-31 18:30:21 UTC
Created attachment 147912 [details]
odt-File

odt-File with the logo at the upper left side.
Comment 10 wrost@edina.xnc.com 2018-12-31 18:32:42 UTC
Created attachment 147913 [details]
pdf-file exported from the odt-file

resulting pdf-file, produced by the odt-file.

Note: With OPEN OFFICE pdf-export works fine!
Comment 11 Timur 2019-01-03 08:26:58 UTC
wrost, thank you for your feedback. 
We can rule out PDF viewer issue but we still don't know the cause. 
And it's up to you that can reproduce to find it. 
Please:
- try different "Images" options in PDF export (lossless, quality, reduce)
- try HW acceleration on/off in Tools-Options-View
- try with and without OpenGL in Tools-Options-View
- try with different anchor in image right-click Properties 
- try with master from https://dev-builds.libreoffice.org/daily/master/Win-x86@39/current/ (it's separate to your working LO)
Comment 12 Telesto 2019-01-27 20:30:32 UTC
Repro
Version: 6.3.0.0.alpha0+
Build ID: 6740443311268b7d918bf4f43134d64fb78a0109
CPU threads: 4; OS: Windows 6.3; UI render: GL; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-15_23:37:04
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL

Only with OpenGL enabled..
Comment 13 Luboš Luňák 2019-03-22 14:09:53 UTC
https://gerrit.libreoffice.org/#/c/69213/
Comment 14 Commit Notification 2019-03-25 12:48:08 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/4b48f5c2fd2d0d6de1e1df4c13ceba47b1da7b5e%5E%21

fix grayscale jpeg writing in pdfexport (tdf#121615)

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Luboš Luňák 2019-03-25 15:12:58 UTC
*** Bug 119771 has been marked as a duplicate of this bug. ***
Comment 16 Luboš Luňák 2019-03-27 11:36:19 UTC
*** Bug 114705 has been marked as a duplicate of this bug. ***
Comment 17 Luboš Luňák 2019-03-27 14:31:12 UTC
*** Bug 106311 has been marked as a duplicate of this bug. ***
Comment 18 Xisco Faulí 2019-03-27 17:44:50 UTC
Hi Luboš Luňák,
Do you think this should be cherry-picked to 6-1 branch as well ?
Comment 19 Xisco Faulí 2019-03-27 17:52:17 UTC
(In reply to Xisco Faulí from comment #18)
> Hi Luboš Luňák,
> Do you think this should be cherry-picked to 6-1 branch as well ?

Considering the duplicates, I went ahead, fix the conflicts and backported it -> https://gerrit.libreoffice.org/#/c/69851/
Comment 20 Commit Notification 2019-03-28 08:15:33 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/a92340e6905cbc4b91028a8c7afb7c2e89cf187b%5E%21

fix grayscale jpeg writing in pdfexport (tdf#121615)

It will be available in 6.2.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Timur 2019-03-28 10:21:19 UTC
*** Bug 118532 has been marked as a duplicate of this bug. ***
Comment 22 Timur 2019-03-28 10:21:25 UTC
*** Bug 118410 has been marked as a duplicate of this bug. ***
Comment 23 Timur 2019-03-28 10:21:29 UTC
*** Bug 116545 has been marked as a duplicate of this bug. ***
Comment 24 Timur 2019-03-28 10:21:33 UTC
*** Bug 106357 has been marked as a duplicate of this bug. ***
Comment 25 Timur 2019-03-28 10:22:00 UTC
*** Bug 111963 has been marked as a duplicate of this bug. ***
Comment 26 Commit Notification 2019-03-28 13:50:51 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/57e6e1e1cec5465b81450bcbabac43beaee7ea74%5E%21

fix grayscale jpeg writing in pdfexport (tdf#121615)

It will be available in 6.1.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 27 Xisco Faulí 2019-03-28 13:56:13 UTC
*** Bug 124045 has been marked as a duplicate of this bug. ***
Comment 28 Roman Kuznetsov 2019-04-12 17:31:55 UTC
verified in

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 74288f5af28de3d14044c951e7e5d62bb2e22301
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-04-12_00:11:21
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 29 wrost@edina.xnc.com 2019-04-24 21:54:00 UTC
Created attachment 150989 [details]
pdf file with bad logo
Comment 30 wrost@edina.xnc.com 2019-04-24 21:55:20 UTC
Created attachment 150990 [details]
odt file wiht good logo
Comment 31 luca.manganelli 2019-04-29 08:38:52 UTC
Now I tested LibreOffice 6.1.6 RC2 and it works. Thank you!
Comment 32 Roman Kuznetsov 2019-04-29 10:29:33 UTC
*** Bug 124045 has been marked as a duplicate of this bug. ***